Jump to content
Sign in to follow this  
debi

SMTP with exg6.exghost.com

Recommended Posts

I've successfully tested the email plugin sending emails via both my business email (gmail) and a personal account (ipage). But I'm having difficulty getting this to work for a client who said she uses exg6.exghost.com.

Format I'm using is:

EmailConnectSMTP ( "smtp.exg6.exghost.com:465" ; "name@domain.com" ; "password" ; "ssl=1" ; True ; True )

Have tried several port numbers, including 465, 587, 25; also no port. 

Errors include "Couldn't connect to host, port: smtp.exg6.exghost.com, 465; timeout 30000" and then "java.lang.IllegalStateException: Not connected"

What am I doing wrong?

TIA,

debi

Share this post


Link to post
Share on other sites

For those extra parameters, where you have True ; True, you will need to pass them in as key=value pairs. So like you have for "ssl=1". The needed parameters are going to depend on the mail server and I don't have any specific information on exghost. Once you have that set up, and if it is still not connecting, you can submit a bug report and that will send us log files that can help diagnose the problem. You will need to reproduce the issue and then you can go to Filemaker Preferences > Plugins > 360Works Email > Report a Bug.

Share this post


Link to post
Share on other sites

Thank you Ben. I wrote to Appriver Support, asking how to set set the parameters for the EmailConnectSMTP functions, including the port, and whether I needed true or false for ssl, forcetrust, and tls settings. Here is their reply:

SMTP Server: smtp.exg6.exghost.com
SMTP Port: 587
SMTP Authentication: requires authentication
SMTP Secure Connection: TLS (if TLS is not available, use SSL)
 
How would that translate to the plug-in function?
 
TIA,
debi

Share this post


Link to post
Share on other sites

Just wanted to close out this issue. I tried "tls=true" and "tls=1" and a few other combinations of parameters related to ssl etc. Then I asked the client to verify that the account was working on their side. Apparently there was a glitch there, and once that was resolved, the code you gave me above was just perfect.  Thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Who Viewed the Topic

    1 member has viewed this topic:
    Divyash 
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.