Jump to content
The site is updated on a beta version. Maintenance tasks are running so search and index may not function at this time. ×

Unable to add records through portal in 3 related table database


Recommended Posts

Hello everyone,

I am fairly new to FileMaker and I have been trying to find a solution to my problem on all sorts of forums and in all forms of tutorials, but have been drawing a blank so far. Maybe you can help me.

I am currently in the process of preparing a historical database of officials delegated to supervise order in private estates. The existence of both the officials and the estates needs to be confirmed by historical sources. So the 3 tables are: Sources, Jito (the officials) and Jito-shiki (the jurisdictions in estates). One source can mention multiple officials and estates; an official may appear in many sources and hold jurisdiction in numerous estates; lastly, a given estate may appear in multiple sources and may have been under the jurisdiction of numerous officials during that time period - this led me to conclude that this is a many-to-many-to-many relationship.

Each record has a form view with its own fields as well as most essential information drawn from related tables via portal. I allowed for the creation of new records, so that I only need to type in the missing details in related tables and everything worked - so far, so good. The problem began when I wanted to add more related records via portal. For some reason it would only show one record and no new line would appear. I tried to create a button that would simply add another related record, but they wouldn't appear in the portal. Does anyone have any idea what I might be doing wrong?

The relationship graph is available here:
https://drive.google.com/open?id=1N_pGUcavM1eS5BegpQhKgUZVvITNr6cy

Link to post
Share on other sites
  • Replies 4
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Why not just post the graph here?  Might be easier to post a sample file.

Do you have 'Allow creation of records in this table via this relationship' enabled?

Link to post
Share on other sites

I tried to upload the graph directly, but it wouldn't let me for some reason. And yes, I have 'Allow creation of records in this table via this relationship' enabled on all related tables.

Link to post
Share on other sites

Maybe the fields aren't actually inside the portal? An easy way to check is, in layout mode, click the portal and then nudge it with an arrow key. Did the fields move along with the portal?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.