Jump to content

Recommended Posts

For years - at least fm 12 and most recently through fm 15 - I have used the script step 'send mail' successfully to send email through a gmail account. I have done that successfully as well with the base elements script steps BE_SMTPServer and BE_SMTPSend.  Sending mail through gmail has recently stopped working in several different solutions that use these  routines. Other, non-gmail accounts, continue to work so something seems to have changed with the way gmail handles requests from a Filemaker solution.

I have verified the SMTP settings in the solutions against the settings specified on various web-sites that specify the gmail SMTP settings.

I recently upgraded from FM15 to FM18 to see if that would resolve the problem. It didn't. Since my solutions are distributed as runtimes, upgrading to FM19 is not an option and I don't think that would resolve the issue anyway.

Has something changed in the way gmail handles requests from apps like Filemaker? It's curious that it just stopped working, not just in one FM solution, but all. My solutions are distributed to my clients as Runtimes and I actually learned of the problem from one of them. Has gmail perhaps added a setting that blocks attempts to send mail through apps like Filemaker?

Link to post
Share on other sites

It is a security change with Google, and Gmail. You need to either authenticate with OAuth, or use an App Password. The user has to set up the App Password to use with their account. We recently experienced the same thing. If your clients have a business account with google, they can setup the SMTP relay and use that, by allowing only their IP addresses to send email.

Link to post
Share on other sites

As I suspected - a security change (improvement?) with google/gmail. I'll see if I can make this work.

Thanks.

Link to post
Share on other sites

Ok, I have to confess my ignorance.

How/where do I find OAuth and do I set this up once and pass it through my FM 'runtimes' to my clients? Will the same OAuth setup work for all my clients?

Where can I find the process for the App password?

I've looked in FM for OAuth and have looked in the 'manage account' options for a gmail account without any success.

I doubt that in general my clients have business accounts with google.

Any help would be appreciated!

Link to post
Share on other sites

OAuth isn't quite as easy as flip on an option. At least not when you are dealing with sending email.

Your next option then, is to have your clients set up an app password. You will be responsible for securing it if you store it. This is better than storing the user's actual account password, but will require some diligence on your part to make sure no can get direct access to that password. https://support.google.com/accounts/answer/185833?hl=en

Link to post
Share on other sites

I've got it going without using OAuth or an app password. Following the process below on my google mail account, I got into security and a 'less secure app access' option. Google doesn't recommend using it, but by turning it 'on', I (and my clients, when they turn it on for their gmail accounts) will be able to send email from FM through gmail, just like it used to work before Google upped their security game.

Here's the process:

1. go to 
http://www.gmail.com

This should open your gmail account and display your inbox 
(at least it did for me).
If not, you may have to log into your gmail account.

2, Click the ‘gear’ (settings) in the upper right of the screen.

3. Then click ’see all settings’

4. Then click ‘Accounts & Imports’

5. Then click ‘other Google account settings’

6. Then click ’Security’ in the menu on the left side

7. Scroll down until you find the ‘less secure apps’ section:

8. It should be ‘off’. Now click on ’Turn on access’ even though it’s not recommended.
Then slide the ‘less secure apps’ button to the right to turn it on
 

Link to post
Share on other sites

Just note that Google has deprecated that option. So I wouldn't put too much time into building your features based on that option. In most GSuite accounts, it's already disabled.

Link to post
Share on other sites

Just when you thought it was safe to go back into the water.......

Thanks for the heads up.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.