Jump to content

Web publ problem: button with insert device function no longer works


Recommended Posts

  • Newbies

Last week, my URL link to my FM file shared via a FMS18.0.4 server worked perfectly with any browser on any smartphone. In my file I have a button calling the Insert from Device function to update a container field from any smartphone camera.

It worked perfectly... until few days ago, the button stopped activating the smartphone camera.  When I open the file with either FM19 or FM18 via, sometimes the script "take picture" for the camera button would just have its content emptied but sometimes reappearing.  When the content is emptied some functions no longer show up under the list on the right of the script (no more Insert functions for example).

What is strange is that if I open the file directly with FilemakerGo it works perfectly... but not through my browser anymore (it did work previously).

I am going crazy figuring out why is this happening as this link was working before. I have just created a simple file with only one button "take picture" and I get the same result, the insert from device function does no longer works and the script acts also weirdly as described above **REDACTED**

Can anyone help please ? 🙏

 

  

Edited by Josh Ormond
Never post your admin credentials to a public site. Your server is accessible to anyone, including people with nefarious intent.
Link to post
Share on other sites
  • Newbies

Thank god I have found a workaround even better that the Insert from device function:the Insert Picture function and best of all it works on a computer unlike the Insert from device that only works on smartphones (I maintained the fact that the insert from device worked previously on a browser.)

But I would really like to know why this weird behavior happened though because I know that I won't be the only one experiencing it.

 

PS: although the FM18 documentation says the Insert from device and Insert Picture are not compatible with FMS18, they both are (at least the latter works for me now as it is working with my Safari browser)

 

 

Link to post
Share on other sites

The reference in the help documents about the script step not being compatible means that it wasn't tested to work, or you will experience issues, not necessarily that it would never function at all. As you have found, it may or may not work without warning.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.