Jump to content

Is my file corrupt? Or is it something else?


Recommended Posts

Would some kind person please open my attached FMPro file in FMPro 16, and then try to add Records>New Record (Cmd-N).

This worked perfectly for me up to maybe 10 days ago, but when I opened it yesterday and tried to add a New Record I got the "spinning pizza/beachball of death" (in other words my computer hung). Using Macintosh MacOS 10.13.3 (High Sierra) and Filemaker Pro 16.

The only way I could get out of this was to use "Force Quit", which showed "Filemaker Pro (not respoding").

If this file opens for you and you have the same problem when adding a New Record, then the problem may be that the file has become corrupted.

If you don't have any problems adding New Records to this file, then maybe the problem is with my copy of Filemaker Pro 16.

Many Thanks in advance.

BTW   This is a small database for my own use, which I use to generate simple text files and/or send emails.

JCOM__v7 Copy COMPACTED.fmp12

Link to post
Share on other sites

Hi comment.  Sorry if I offended you, but I didn't get any replies to my earlier post in the other forum, and there seemed to be not many people posting there.

So, I posted here, which is a much busier-looking forum, hoping it would be seen.

Are you willing to look at my file for me?

Regards,   Philip

Link to post
Share on other sites

One thing to rule out.  I had similar problems with a database. 

I was recovering, using backups, rebuilding, still getting lock ups.  One thing I did, and then it never happened again was to clear my Data Viewer, Watch tab of all calculation after I'm done experimenting with them (and moved them to a reference database).  I was the DV to keep complicated calculation for this database and other db's I was working on.  Many SQL calcs, as I just couldn't get the hang of the syntax and was experimenting with them.

Now I can't say if it was a coincidence.  But it hasn't happened again with that database for the last 2+years.
Might not even be the problem...

Link to post
Share on other sites

I'm using FileMaker 18 on High Sierra and was able to add new records with no issue.

Link to post
Share on other sites

Thank you, Fitch.  That is useful to know.

Following advice from someone else, I tried logging-in my Mac as "Guest" (and also as a newly-created account) and both of those allowed me to open the file and add records.

So, the problem does not seem to be a corrupted file, but something wrong with my copy of Filemaker or its preferences.

Thanks for your help.

Regards,  Philip

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.