Jump to content

Why can't I sort a table by a related field?


Recommended Posts

It's been a while for me using FM, I've always sorted records by a related field and got records sorted without problem.

Today this doesn't seem to work, execute 'Sort records' changes the initial sort order but they don't get properly sorted.

This is happening in table view with records from two files hosted in FMS.

Any idea of why this may be happening?

Thank you in advance.

Link to post
Share on other sites
14 hours ago, naio said:

Any idea of why this may be happening?

Without providing a way to reproduce the problem, all you can hope for is guesses. If I had to guess, I would say it does "get properly sorted" - but your expectation of what "properly sorted" means is different from what Filemaker thinks. And in these disputes between human and computer, the computer is almost always right.

 

Link to post
Share on other sites

I've tried to reproduce the issue with a brand new file: I've made the same relationship with the problematic 'not-properly-sorted' field which is hosted in FMS.

When I created the new file in my machine, sorting worked as I expected.

Then I uploaded the new file to FMS, and sorting didn't work (at least not the same way as local), as you can see in the enclosed screenshots:

Local file, the 'id' field was filled as records were created. In the first image it is unsorted in the second is sorted by the 'engagement' field, it looks all correct.

local_unsorted.thumb.png.96de6edf21edeac3055a5252259bf387.pnglocal_sorted.thumb.png.bc52805d456c93e9449fc473cd55ab3c.png

 

The file now hosted and sorted by the 'engagement' field only, please note the sorted icon in the column header:

hosted_sorted.thumb.png.c7cea6de2d65dbc7afdf72faa9a97f46.png

FMS hasn't found any problem after verifying both hosted files.

 

You're right about the difference of expectations between me and FileMaker, it happens very often :), but you'll agree that sorting should work exactly in the same way regardless of the file being local or hosted, otherwise I'd love to learn why.

 

 

 

Link to post
Share on other sites
  • 2 weeks later...

Finally, after a couple of weeks researching, I've got a reply from FileMaker Support: it's a bug in FMS, it happens with a hosted file related to another hosted file using fmnet:.

The workaround is to use file: instead, however this prevents to have the external file in a sibling folder.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.