Jump to content

Importing data in FM5


john.daly
 Share

This topic is 7568 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I am having problems importing data from a backup file on floppy disc using a script in FM5. The whole thing works fine if I allow the dialog to display but when I include 'perform without dialog' it produces an error saying the script has been cancelled. The original files were converted from fp3 where it all worked fine (and still does) but I have created new files in FM5 and can still reproduce the problem. It only happens if the access privileges on both files do not allow access to the whole file (although all the options can be ticked and it still doesn't work). Has nayone encountered this problem?

The script I am using is:

Enter Browse Mode []

Show All Records

Delete All records [No Dialog]

Import Records [Restore, No Dialog, "BackUP.fp5"]

Link to comment
Share on other sites

Thanks for the tip but unfortunately it isn't tht simple!! I only wish it was. I have created two very simple files with a single field in each. It works perfectly in FM4 but not in FM5. It works in FM5 if the import mapping dialog is enabled in the script or if the password for both file is the same. It will not work however if the passwords are different (even if the default password on the BackUp file is 'no password') although the access privileges are the same for the two passwords.

I could email you files if you want to have a look at it or you could create them yourself. You just need a single filed in each file and the script in the main file.

Contact me at [email protected]

Link to comment
Share on other sites

  • 2 weeks later...

It doesn't answer my problem!!

You can export from Filemaker in csv, tab separated or dbf formats and all these can be imported into Outlook. The only problem is that Outlook requires the first record (or row of data) to contain the field names it uses or if you are going to use dbf format then the Filemaker database needs to have the exact same field names as Outlook. Best thing to do is to export your data from Outlook in csv format and see what field names it uses.

Hope this helps.

Link to comment
Share on other sites

My first thought is that I would count on a floppy disk to back anything. As often happens, floppy media has become such a cheap commodity that they don't work reliably any more. First, I would suspect a disk error. Norton the disk and/or copy the files from the floppy to the hard drive. Perform without dialog can restore a couple of things. First the filename. If the filename or path is different (like from a floppy), the file won't be found. The second thing that can be restored is the import order. I would:

1) Transfer the file to the hard drive.

2) Perform a manual import resetting the file name and import order.

3) Open and close the script. When the script closing dialog comes up asking to keep or replace the import order, replace it (with the order you just established with the manual import).

When you want to automate this import you must either manually specify the file each time or make sure you provide a consistent file name and path to the file for the automatic script.

-bd

Link to comment
Share on other sites

Thanks for the thoughts LiveOak. Unfortunately it's not the floppy disc that is at fault. I agree with you about floppies for backup but I use it also to transfer data between computers and as a last resort if for instance the backups on the HD are lost due to a malfunction. I've recreated the fault with two very simple (only one field) totally new files and Signal has now run these and reproduced the same problem on his Mac. It's not just a PC issue. It even happens if you have the backup file (which is not a copy of the original) on the HD. The strange thing is that if the script shows the import dialog box then it works OK but not supressing the dialog causes the script to cancel itself. I've never seen this happen before. This doesn't happen in FM4.

In the meantime I shall just have to work around it but it upsets a system that worked fine before and I have 80 users who relied on it!!

Thanks anyway.

Link to comment
Share on other sites

This topic is 7568 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.