Jump to content

Import Records Script Step


This topic is 7338 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I have a solution developed in FM4.0 on a MAC. There is no indication of a problem on the MAC side.

In Win98, under FM4.0, the 'Import Records' script step fails and damages the file (I get the Windows message 'If this problem persists, contact the vendor'). 'Recover' does not fix the problem. I suspect there is some other damage to the file.

The import records script step is used to update one version of the solution to another. It is a technique I have used successfully for some 30 previous version updates of this solution and it has allowed me to 'skip' versions when updating a data base. The import records specs are set up to import all fields from a backup of the current version. For this reason, when importing from an earlier version, some of the fields the import records step looks for may not exist. This has worked well up to now. There are 24 files in the solution and this is happening to 2 of them.

Does anybody know of anyone who looks at and attempts to repair such file problems? The problem is reproducible and I have tracked it to the specific script statement that fails. It would be a nightmare to rebuild the files from scratch.

TIA

Link to comment
Share on other sites

Do you still get the damage file if you do the import manually on these two files? Does the data set have any effect?

I am wondering if just rewriting these scripts is the solution, or if there is some corrupt data.

This is a very difficult type of problem to diagnose on a web board!

Jerry

Link to comment
Share on other sites

Thanks for the response, Jerry.

When I do the import manually, everything looks ok. But the manual import isn't exactly the same request. In the script, I select the 'restore', 'no dialog' and 'file' options for the 'import data' script step. If the file has fields a, b, and c, the 'restore' is set up to look for a, b, and c in the data being imported. If a, b, and c are there, everything's OK. But if importing from an earlier version of the file, there may only be fields a and b. That's when the problem occurs (illegal operation/invalid page fault). When that occurs, the file becomes 'damaged'. Does anybody know how to read/debug with the 'details' of the Windows error message?

I tried clearing the script and reentering the script steps (haven't deleted and recreated the script - will try that) to no avail. Same problem. Because I can import manually, I don't think the data is corrupt - but something is!! I've been using this technique for over a year and this is the first time it's bit me.

Any other insight will be greatly appreciated.

TIA again

Link to comment
Share on other sites

This topic is 7338 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.