Jump to content
Sign in to follow this  
Soenso

Send Mail script not launching mail client

Recommended Posts

I'm running Filemaker 8.5 on a Windows 2003 Server. I've installed MS Outlook 2003 and configured an email account using a Exchange account. I've also configured a POP gmail account using Outlook Express 6. I am unable to get either of these mail clients to launch when I run the "Send Mail" script. Any help would be much appreciated.

Share this post


Link to post
Share on other sites

What launches when you right-click on an icon on the desktop and select Send To>Mail Recipient?

Not being too familiar with Windows OS, why are you running FM on a Windows Server?

Share this post


Link to post
Share on other sites

bcooney,

I attempted to send mail via the "select Send To>Mail Recipient" method you mentioned. It did nothing (just like the "send mail" script). A quick Google search took me to the following website:

http://windowsxp.mvps.org/sendtomail.htm

It stated the following problems:

- The default mail client is not set

- The MAPI DLL registry path for your mail client is missing

It recommended running the following commands:

regsvr32 sendmail.dll

"%ProgramFiles%Outlook ExpressMSIMN.EXE" /REG

regsvr32 "%ProgramFiles%Outlook Expressmsoe.dll"

After having run those commands, I am now able to send mail via the "Send To>Mail Recipient" method. The Filemaker script, however, still does nothing.

Thanks for your help.

Share this post


Link to post
Share on other sites

Yeah, it's a quick way to make sure the client is all set. So, now you're left with the FM problem.

Try not using a script yet. Just use the command directly from the File menu. Send to your email address. If you get the test email, then it's your script.

Also, check Outlook settings. There's a setting that has to be checked to allow other programs to send mail using Outlook. Search the forums for more. Sorry, I would but out of time right now.

Share this post


Link to post
Share on other sites

I attempted to send mail via the Filemaker "File>Send Mail.." menu item. I get the send mail dialog window. I entered my email adddres, a subject, and some email body text, and sent the mail.

I checked Outlook Express, and found that there are no emails in my "Sent Items" or "Outbox" folders (I know that Outlook Express is configured properly, because I can manually send mail from it).

I configured Outlook Express' security settings to warn me when an app tries to send mail through my account. I am not getting that warning.

Share this post


Link to post
Share on other sites

Make Sure Outlook Express is the defualt Mail Client in your Internet options. (Filemaker sends to default mail client, Outlook express can be intalled properly and work and still not be the default.)

Share this post


Link to post
Share on other sites

I checked my Internet Options and Outlook Express is my default app for Email.

Share this post


Link to post
Share on other sites

I could be wrong and don't have time to doublecheck but ..

The last time I was playing with emailling from a script, I found that the email program (Thunderbird in my case) had to be open beforehand. Otherwise FMP just pretended to send it.

Share this post


Link to post
Share on other sites

Yeah, I thought that might be the issue. Filemaker behaves the same regardless of whether Outlook Express 6 is launched or not.

Share this post


Link to post
Share on other sites

Have you tried with Outlook as the default client?

Share this post


Link to post
Share on other sites

Yesterday I had a support call with a similar issue (only on Mac).

Resolution: the new messages are saved in the Drafts folder, the mail client does not automatically open then in a new window.

See if this solves your problem too.

Share this post


Link to post
Share on other sites

My turn for good catch, Vaughn. OMG, and I knew that. (I spent a month with Prod Computing's Outlook Manipulator). By now he would have received one of them, right, lol!

Share this post


Link to post
Share on other sites

I had a problem similar to this on WinXP with Outlook Express. Never could get it to work exactly right. I did get it working but only with a warning for EACH message that I was attempting to send out of FIlemaker.

Filemaker calls for the new email message via MAPI on PC so I decided to use Thunderbird (which is reportedly MAPI compliant.) Obviously, you can still use Outlook as the main email program, just open it and use it normally. The only thing you'll miss by installing Thunderbird and setting it as the default is you can't click on mailto links and expect them to open in Outlook...

Incidentally, I still have problems using SEND MAIL on Mac OS-X. According to the Filemaker User Manual, Filemaker sends the call for a new mail message to the default email client on Mac. The call gets handed off IF the default email client is Mail but it gets lost with anything else I've tried. (I can't use Mail because of the delsp bug that breaks URLs.)

Does anyone know a pop e-mail client that Filemaker will successfully call to?

Share this post


Link to post
Share on other sites

You could always use the Mailit plugin from Dacons at http://www.dacons.net/

Share this post


Link to post
Share on other sites

FMP works with Ms Entourage. New messages are put in the drafts folder and don't open in their own windows.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Who Viewed the Topic

    1 member has viewed this topic:
    enstorms 
×

Important Information

By using this site, you agree to our Terms of Use.