Jump to content
Sign in to follow this  
datalink

Irish Family Names

Recommended Posts

We recently had a fellow whom, being very proud of his Irish heritage, wondered why our system always displayed his name in title case, rather than allowing for a second capital letter in his family name. I figured that this was a simple formatting issue, but I can't seem to turn it off.

When the field was originally defined it had an auto replace calc on it to set the contents of the field to title case, but that is switched off at this point.

The reformatting happens as the name is being keyed; not at commitment.

Anyone have any ideas? At this point it just seems bizarre to me.

Share this post


Link to post
Share on other sites

It this on version 7? If its a later version, perhaps the auto-complete option is on?

Share this post


Link to post
Share on other sites

Its v9. I checked for that. Its not auto complete. Its very strange. As the operator types in the last name field it seems to ignore that shift if pressed.

Share this post


Link to post
Share on other sites

The field has no formatting on it other than font (nothing strange there).

If I delete a character at the begining of the name, the second character, which then becomes the first, instantly goes to cap.

Share this post


Link to post
Share on other sites

You may have something effecting else wrong here, maybe corruption, or something you just aren't seeing. I would attach a copy of the file, so that we can look, test, etc. too.

BTW, remove any confidential information, or make a No Record Clone.

Share this post


Link to post
Share on other sites

Can you post a cloned copy of your file?

Share this post


Link to post
Share on other sites

:giggle:

it's a tie

Share this post


Link to post
Share on other sites

So it seems... :mickey:

Share this post


Link to post
Share on other sites

The field has no formatting on it other than font (nothing strange there).

Are you sure about that? Go into Layout mode, select the field and choose Format > Text... It's more likely than not that Title Case is checked on there.

Share this post


Link to post
Share on other sites

I thought of that too and I did check to make sure. What's more I created a new layout and added a fresh copy of the field to that layout. It too, without any formatting on it behaves the same way.

Defining a totally new field and adding it to that same dev layout the same way, it behaves correctly. Its almost like the issue is at the field definition level. But the settings between the original name field and the new one are identical.

Share this post


Link to post
Share on other sites

It sounds like the data was pasted into the field, and had the Formatting of the Clipboard?

Where is the copy of the file?

Lee

Edited by Guest

Share this post


Link to post
Share on other sites

Your description of data being reformatted as you type, without exiting the field, is consistent with layout-level formatting - and no other explanation I can think of. Why don't you attach the file, so we can tell for sure?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.