Jump to content

Automatically set font for field


Larryo
 Share

This topic is 4386 days old. Please don't post here. Open a new topic instead.

Recommended Posts

All,

Is there a way to preset a font and size so that no matter what font is entered into a field it comes out the same. OR is there a way that I can change all the contents in a field for the whole data base to one font and size.

Right now, I'm doing every line by hand and it's painfully slow. Thanks.

Larryo

Link to comment
Share on other sites

All,

Is there a way to preset a font and size so that no matter what font is entered into a field it comes out the same. OR is there a way that I can change all the contents in a field for the whole data base to one font and size.

Right now, I'm doing every line by hand and it's painfully slow. Thanks.

Larryo

At the layout level, you can assign a field a font/size. This can also have conditionals with the use of conditional formatting to display other font/sizes. One trick on a Windows machine, you can select one Field and hit CNTL + SHFT + A and it will select all objects of the same type. This would allow you to set font/size on all fields on a layout at the same time. Just be careful, this will adjust the size of your fields if you make text larger than what the field is sized for currently which could create some design fixes for you to deal with. I always suggest making a duplicate of your layout just in case whatever you do can be reverted easily if you don't like it.

Link to comment
Share on other sites

At the layout level, you can assign a field a font/size. This can also have conditionals with the use of conditional formatting to display other font/sizes. One trick on a Windows machine, you can select one Field and hit CNTL + SHFT + A and it will select all objects of the same type. This would allow you to set font/size on all fields on a layout at the same time. Just be careful, this will adjust the size of your fields if you make text larger than what the field is sized for currently which could create some design fixes for you to deal with. I always suggest making a duplicate of your layout just in case whatever you do can be reverted easily if you don't like it.

Russel,

Thanks, but I can't get that to work. I've tried in Layout Mode:

Highlight the field, in this case it's "phone". And then go to FORMAT/SIZE, and FORMAT/FONT, and it only changes the font in the layout, not browse.

OR--- Highlight the field, And then go to FORMAT/CONDITIONAL, Select ADD, Click on MORE FORMATTING, select the font and size there. Again it does not change the info in the field.

Help?

Link to comment
Share on other sites

The font you set in Layout mode is applied only to plain text. If the text has its own font attribute, it will override the layout setting. You need to remove the font formatting from the data in the field.

Conditional formatting has nothing to do with the issue.

Link to comment
Share on other sites

The font you set in Layout mode is applied only to plain text. If the text has its own font attribute, it will override the layout setting. You need to remove the font formatting from the data in the field.

Conditional formatting has nothing to do with the issue.

Comment,

Thanks, but how can I do that automatically? What I'm doing is pasting entries into the field, and the formatting from where I get them seems to follow, and then I have to manually change the font and size which is what I'd like to get away from.

Thanks for the help.

Larryo

Link to comment
Share on other sites

TextFormatRemove() is a function that will take out all formatting. There are a variety of other text formatting functions for specific tasks.

If you put an auto-enter calculation of TextFormatRemove ( Self ) and set it to always replace, that should take care of your problem..

DJ,

That one is over my head.... have no clue. However, taking a guess.... I went to FILE/MANAGE/DATABASE, selected the field I wanted (I eventually want all of the fields), clicked OPTIONS, checked CALCULATED VALUE, and clicked OPTIONS. Then on the upper right I scrolled down to TextFormatRemove ( Phone ) and added "phone" in the ( ). Clicked OK, unchecked DO NOT REPLACE... and clicked OK. Nothing happened.

Am I in the right place? I'll bet I don't have the proper sequence on something?

Larryo

Link to comment
Share on other sites

...Nothing happened.

..Yet.

That will take care of all Phone entries in the future.

To fix the existing ones, you've got to do a replace.

Show all your records.

Enter the Phone field.

Select Replace Field Contents.

Choose "calculated value"

Enter TextFormatRemove(Phone) where Phone is the name of the field you're in.

Click OK and the formatting will be removed from existing records.

I'd recommend backing up your file before doing any of the above.

Link to comment
Share on other sites

..Yet.

That will take care of all Phone entries in the future.

To fix the existing ones, you've got to do a replace.

Show all your records.

Enter the Phone field.

Select Replace Field Contents.

Choose "calculated value"

Enter TextFormatRemove(Phone) where Phone is the name of the field you're in.

Click OK and the formatting will be removed from existing records.

I'd recommend backing up your file before doing any of the above.

Wow, worked like a champ, THANKS!

Larryo

Wow, worked like a champ, THANKS!

Larryo

Now one more question.... is there an easy way to do that to ALL of the fields, or must they be done individually? I only have 15 fields in this data base.

Also, I've missed something, it doesn't do it with new entries... they keep their original format.

Again, what I did:

FILE/MANAGE/DATABASE

Selected the "Phone" field.

Clicked OPTIONS, Checked CALCULATED VALUE, Clicked SPECIFY...

On right, scrolled down to function: TextFormatRemove ( Text ), and double clicked it.

Then added "Phone": TextFormatRemove ( Phone ), Clicked OK

Unchecked DO NOT REPLACE.... and clicked OK., and OK again.

Larryo

Link to comment
Share on other sites

You seem to have the auto-enter text format "stripping" calc set up correctly. Are your users copy/pasting the data from somewhere into FM? That really is the only scenario that requires this technique. Otherwise, the assigned format in layout mode will prevail.

Link to comment
Share on other sites

This topic is 4386 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.