Jump to content
Sign in to follow this  

CWP not working on WinSrvr 2003

Recommended Posts

Upgraded from FMSAdv11 yesterday to FMSAdv12, to try to relieve pressure on a Win2011server where my install of FMSAdv12 is a disaster.

Things went a LITTLE better than most of the installs of ServerAdv12 that I've done to date, and IWP actually works in the 2003 install.

There was nothing in that final listing to indicate anything failed, but when I tested CWP from the Tech Tests page it returned a "The page cannot be found" and a bunch of gibberish at the bottom. When I tried to test things on a real live site, I simply received a "cannot read page" message.

This is a server that has worked as our web server for years, on implementations of Server versions 5.5, 6, 8, 9, and 11.

Why suddenly are huge chunks of 12 not working? (CWP isn't the only chunk, but I'm trying to separate problems, since my previous post about the ENTIRE mess got no responses.)

Any ideas on what would suddenly KO CWP when it has worked through all of these iterations?

Share this post

Link to post
Share on other sites

Check the FMS 12 installation log: did it report any problems?

You mention "gibberish" at the bottom of the test page, what's that? What does it say?

Share this post

Link to post
Share on other sites

The only issue the deployment log mentioned, and that only once, was "Start WPE: Error 10006".

As far as "gibberish", that was a poor term on my part.

What it gives is as follows, at least in the case of the 2003 server. (The 2011 box is another story ...)

The page cannot be found

The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.

Please try the following:

  • Make sure that the Web site address displayed in the address bar of your browser is spelled and formatted correctly.
  • If you reached this page by clicking a link, contact the Web site administrator to alert them that the link is incorrectly formatted.
  • Click the Microsoft Product Support Services and perform a title search for the words HTTP and 404.
  • Open IIS Help, which is accessible in IIS Manager (inetmgr), and search for topics titled Web Site Setup, Common Administrative Tasks, and About Custom Error Messages.


On the brand new 2011 installation, Running FM, we get the following:

HTTP Error 500.0 - Internal Server Error

Calling LoadLibraryEx on ISAPI filter "C:Program FilesFileMakerFileMaker ServerWeb Publishingpublishing-engineweb-server-supportiisisapi_redirect.dll" failed

The Event log says:

Log Name: Application

Source: Microsoft-Windows-IIS-W3SVC-WP

Date: 9/4/2012 3:17:02 PM

Event ID: 2274

Task Category: None

Level: Error

Keywords: Classic

User: N/A

Computer: FMWEB4.wgweb.local


ISAPI Filter 'C:Program FilesFileMakerFileMaker ServerWeb Publishingpublishing-engineweb-server-supportiisisapi_redirect.dll' could not be loaded due to a configuration problem. The current configuration only supports loading images built for a AMD64 processor architecture. The data field contains the error number.

But if we turn ON 32-bit applications in IIS, then we never get a page back.

Share this post

Link to post
Share on other sites

Situation resolved with an installation on a spare Server 2008 *Standard* box - appears SBS components in both cases were getting in the way.

2003 case was a bit more complicated, but got that one too.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use.