Jump to content

Imorting text file issue


christoff
 Share

This topic is 2921 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Hi,

 

Yesterday I installed Filemaker 13 and converted my Filemaker 9 database to Filemaker 13.

 

Just now I went to use a script I've been using for 5 years and tried to import a text file but it didn't work and the issue is this:

 

In the 1st screenshot attached you can see that Filemaker 9 used to separate Source Fields into different Target Fields, which is what I wanted.  In the 2nd screenshot you can see that Filemaker 13 is not separating any of the Source Fields during the import and is putting them all into Column A.

 

As far as I can tell, nothing has changed and I'm not sure why this import is suddenly not working, when all I did was to use an updated version of Filemaker.

 

Can anyone help me, am I forgetting to do something?  Why is Filemaker not recognising the commas in the text file that is being imported?

 

thanks..

post-98813-0-68315800-1417484499_thumb.j

post-98813-0-56791600-1417484522_thumb.j

Link to comment
Share on other sites

Hi, good to hear from you again!

 

I'm not sure if I'm answering your question but I still have Filemaker 9 on my old laptop, and I put the new AXF file that I want to import onto the old laptop and it imported fine.  With both FM 9 or FM 13, whenever I get to the Open File box to select which file I want to import, I always have to select "All Files" in the drop down menu to even see the file I want to import, if i select Comma-Separated Text Files then i can't see the file.

Link to comment
Share on other sites

Yes it is something I do regularly and it's been the same script for about 5 years, always importing fine, so it's strange that I now have to change the extension of the file but I'm willing to try anything to get FM 13 working for me.

 

So, I made a copy of the .axf file and changed the extension to .csv and executed the import script and when the Import Field Mapping box came up it was separating the Source Fields which is great but I had to manually select all of the right arrows so that the Target Fields would become populated.  When I continued with the script the .csv file ended up importing properly, thank you for your help there!

 

When I went to recreate this by importing the .csv file again, I thought it might remember the settings but when the Import Field Mapping box came up, I had to once again manually select all of the right arrows...

 

This new FM does some strange things!

Link to comment
Share on other sites

I would delete the Import Records step in your script and insert a new one. Then set it up using the file with the .csv extension. Once it all works, change the file reference to the real file with the .axf extension (assuming you want to hard-code the file name).

Link to comment
Share on other sites

I probably would prefer not to hard-code the file name but I deleted the Import Records step and inserted a new one and it did import the .csv file properly, so from now on I will just have to convert every .axf file to .csv before import which is far preferable to not being able to import at all.  Thank you for helping me sort this out!

 

cheers

Link to comment
Share on other sites

I can only get it to work if I hard code the .axf file and select .csv from the drop down box, then it imports fine.  But the file names I need to import are always different so I can't hard code it and when I remove the reference to the .axf file, then it goes back to the original problem.  I don't remember FM9 being this hard..

Link to comment
Share on other sites

This topic is 2921 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.