Jump to content

EmailAttachFileInline not working on FMServer


ignotum
 Share

This topic is 2382 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Windows Server 2012
FMS 11
Email plug in v1.622
 
 
My process works like this:
 
SuperContainer stores the images giving me a known path to the images.
 
When writing an email an "Activity" record is created with placeholder text for a header and footer graphic.
 
The Server runs a script that finds any activity records that are emails needing to be sent. In the course of creating and sending the email I use the EmailAttachFileInline function to place the Header and Footer into the email in place of the placeholder cid text.
 
This works fine if I run the script from the client computer. If server runs it (via a schedule) the graphics are not included in the email, only the placeholder text shows up...
 
To further complicate things we just recently moved to this 2012 server from a 2008 server where this all worked just fine. What could be causing this to fail? Might it be a permissions issue? If so, where and on what?
 
This is very frustrating.
 
Mark
 
 
Link to comment
Share on other sites

Hi Mark,

This sounds like it is a permission issue with FileMaker Server. In the past I have had issues with FileMaker Server being able to read from a folder outside of its own documents folder. Try placing the attachment in the FileMaker Server Documents folder at ...FileMaker Server\Data\Documents and see if the inline attachments come through. Alternatively, try placing the attachment in a container field and reference the container field rather than a file path in the EmailAttachFileInline function and see if the attachment comes through. If either or both of those methods work than I would think that it is a permissions issue where FileMaker Server can't read from the location where your attachments are.

Link to comment
Share on other sites

Windows makes it somewhat difficult to set permissions and I am unsure what account FileMaker Server uses for read/write permissions. I didn't have any luck finding any info about setting the permissions in Windows(everything seems to be for Mac) so it may be that you need to contact FileMaker support. Before you chase down the permissions thing, did you try what I suggested in my previous post?

Link to comment
Share on other sites

To follow up it LOOKS like a plug-in version issue! Lesson: check the simple things first... I'll be able to swap the plug in tonight, I'll report back after that...

 

Thanks to Caleb for his help and support on this... and that you Ryan for posting here... 

 

 

Link to comment
Share on other sites

This topic is 2382 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.