Jump to content

Error 102-field missing


clevow
 Share

This topic is 7197 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I've got a series of web pages that I created for a database that is residing on my computer. When I search on a username I am returned the correct records. When I click on a record to get to the screen where I can view the entire record and edit it, I am returned the correct information. If I change that information and then hit the submit button (-Edit), I am returned a 102 error, which I believe is "Field is Missing."

The information that I have says that the only required tags are -DB and -RecID. I've got -Lay, -Format and -Error as well. Every single field that exists in this database is on the edit screen and every single one is showing the correct value (read: everything is spelled correctly). I just can't edit the darn thing. I can duplicate or delete just fine.

The database is quite simple. It has only 7 fields - 3 in date format, 3 in text. Nothing is validated. No portals, no related fields, no repeating. No passwords. Very simple. I don't understand what is going on.

All of the HTML files live in the same directory. All the names are spelled correctly. I actually took a working example and changed the field names and hidden fields only and I get the same error.

Any suggestions? I'm going nuts here.

Thanks,

Carrie

[ November 15, 2001: Message edited by: Carrie ]

Link to comment
Share on other sites

Uh, the display fields and the edit fields are one and the same. That is, it shows a text box with the existing text in it, you add to it and submit it again. It's all the same. I don't see how it could display correctly but submit incorrectly.

I checked the spellings. They are all correct. The spacing is all correct. Just for kicks I tried cutting and pasting from the Define Fields window in FileMaker to my HTML. I even used ctrl-a in the 'name' field and then copied in case there were spaces I wasn't catching. I swear, they are all correct.

As for access rights, if I go to Define Passwords all it says is "(no password)" and everything on the right side is checked off.

Anything else?

Link to comment
Share on other sites

Are you using the same -lay tag on all pages? In other words, are all pages drawing from the same layout? Are you using claris homepage? What I like to do is print out the HTML code, print out your "define fields" and highlight the fieldnames in both. As Anatoli says, it's almost always cuz I was a dumb a-- and added a space or missed a letter.

Link to comment
Share on other sites

Okay. I figured it out. Stupid error, but not spelling. I had one of my text areas named the default "text" instead of the FM field name.

I guess that's what you were trying to say, Anatoli, about the display and the submit being different.

Thanks for the help.

-Carrie

Link to comment
Share on other sites

Precisely smile.gif" border="0

I am always putting all fields in database on layout CGI for web. That way I know all fields are there and available.

Then I NEVER EVER type the name of field in CDML tags in HTML. I am copying all names from CGI layout.

BTW, GoLive even not 100% friendly to CDML is quite all right. It saves me great deal of time. I am probably better with HTML, than with FileMaker.

Link to comment
Share on other sites

This topic is 7197 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.