Jump to content
Sign in to follow this  
Meridian

Appletalk on pc versions?

Recommended Posts

I'm wondering if any of the pre-V.5x versions for pc have appletalk as an available protocal. I need to use my XPpro system on a Mac/Appletalk based network, and while I have Appletalk set up (filesharing is available) my version 3 F.M.Pro does'nt give me the option to use Appletalk. Was there ever a patch? Do ANY versions on pc support this?

Share this post


Link to post
Share on other sites

Windows versions of Filemaker do NOT support Appletalk, only IPX and TCP/IP. Just reset your Filemaker Server to support either TCP/IP alone or both Appletalk and TCP/IP.

Share this post


Link to post
Share on other sites

Thanks for your response!

I did'nt realise it was possible to set my server to two protocols at once. Is there somewhere other than the Preferences/Application menu to set this up?

I'm running v.4.? on my server, but it seems that only one protocol can be set up at a time. Am I missing something?

Share this post


Link to post
Share on other sites

Well, I think I'm stuck with Appletalk because of a hardware limitation. Most of the machines on the network are 7100 series power pcs without an internal network card.

We're using Asante Friendlynet ethernet adapters to hook them into our network, but no matter what IP/Subnet Mask settings I use, the TCP/IP just does'nt work. I figure that its simpler to play with the settings on my pc laptop instead.

(unless there is a way to set both protocols on the server?)

Share this post


Link to post
Share on other sites

Using 7100s - don't they have an internal apple network card, you just add a transceiver for your cabling?

try private ip addresses in the 10.x.x.x range with a mask of 255.255.0.0

There is no limitation on TCP/IP on the apple hardware, and i hope you did not install any Asante Ethernet drivers since this is included in MacOs. Just don't use the "MacIP" setting, use TCP/IP control panel and set everthing manually.

MacIP is IP-over-AppleTalk and needs a special (software-)router to work with "real" TCP/IP devices.

Share this post


Link to post
Share on other sites

The 7100s used AAUI-15 but not 10baseT so yes we used an adapter, but I'm wondering if the localtalk hardware has a problem with TCP/IP or if its just my version of open transport (I'm running OS 8.1).

I've tried to manually set up IP addresses around 192.168.1.x but I don't know about the 10.x.x.x range. I also usually set my subnet mask to 255.255.255.0 but none of this has seemed to work.

(and don't worry I've kept away from MacIP entirely)

My question is this though, does FM server give the ability to have BOTH TCP/IP and Appletalk going at the same time?

Share this post


Link to post
Share on other sites

localTalk?: That's phone wire @ 256kbps (sometimes 768), with a very chatty protocol. Feels like a 2400 baud modem if used with several Macs in a chain. No way you can use LocalTalk with TCP/IP. There MacIP is the only solution.

The only MacIP gateway that is halfway current is MacIPGW running on freeBSD. 10Years ago, we had MacIP Router installed on a IIci to connect a Powerbook 170 to the Internet, but I cannot find the disks anymore.

Any Ethernet Cabling (AAUI->10base2->Adapter ->10baseT) will do, however. We have been using 1 cheap 5port Hub per room with a BNC port as an Adapter for years without problems.

>Does FM server give the ability to have BOTH TCP/IP and Appletalk going at the same time? No idea, never tried it. And cannot test, since we use OS X/Win2K machines only.

Share this post


Link to post
Share on other sites

Ooops, maybe I don't have the right term here (my knowledge base is mainly pc) I thought localtalk was the proprietary name for Apple's pre 10baseT, Appletalk based network hardware. (there was a name for it, but I can't remember)

Thats why I was wondering if this is a hardware limitation, or just too early of a version of Open Transport. (v1.3 in OS 8.1) I'm looking for ways to upgrade my OT, but Apple's support site is not as helpfull as I remember it to be a few years back.

If I was sure FM server (I only have the regular versions of FM so although I refer to the machine that holds all the files as the server, this is really just peer-to-peer) could handle 2 protocols at once, I'd just get that and solve all my problems.

So, should a stock hardware 7100 be able physically to run TCP/IP on an ethernet based network if its using an adapter to gain a RJ45 port?

Share this post


Link to post
Share on other sites

Hi Meridian,

About AppleTalk: that's the overal name for Apple's 'ancient' network protocol.

The version that works with the telephonewire as hardware is also called LocalTalk, the version that uses ethernet (either 10, 100 or 1000baseT over UTP cable or 10base2 over coax cable is nowadays just called AppleTalk, but when ethernet was something new-and-exciting it also was called Ethertalk, to distinguish it from LocalTalk.

Then the server: I'm reasonably sure that version 4 already had the possibility to use AppleTalk and TCP/IP (and MacIPX!) and if you can lay your hands on a AAUI to RJ45 converter then the 7100 should very well be able to use TCP/IP and AppleTalk over ethernet.

Just did a search on google for: 'AAUI RJ45' and found:

http://www.diacables.com

TRANCVRMAC10T

Share this post


Link to post
Share on other sites

see http://docs.info.apple.com/article.html?artnum=30411

on OpenTransport 1.3

http://docs.info.apple.com/article.html?artnum=30410

Open Transport 1.3 to 1.3.1 Update Version: 1.0 was released on February 13, 1998. This update requires the US English Mac OS 8.1 Update and version 1.3 of Open Transport. It can be downloaded from the Apple Software Updates Web site at http://www.apple.com/swupdates.

Note: Open Transport 1.3 is installed with the Mac OS 8.1 Update. For more information refer to article 30345: "Mac OS 8.1: About Mac OS 8.1 Update".

If you stll have the BNC transceivers, simply run a BNC coax to connect you macs and a cheap hub with BNC to connect to your 10/100baseT network.

also make sure you run the latest version of MacOS 8.1 on your 7100s. (8.5/8.6 would be slowing them down too much, 7.6.1 just lacks vital features(HFS+ compatability, 8.0 is buggy & update to 8.1 is free) 8.1 is just ideal for 7100 series. free updaters for several components of 8.1 are still available on www.apple.com

Share this post


Link to post
Share on other sites

WooHoo! I got it running! I was reading some of the readme's about OT on a G3 system disk (OS8.6) where it discussed problems with initiating TCP/IP within some programs.

It suggested turning off the "load when needed" option in the TCP/IP control panel, and that worked! Now mind you, this experiment was done on a 7600 series machine running 8.1 but I don't forsee a problem doing the same thing on a 7100 running 8.1.

Thanks for all the suggestions/info!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By Norbert Wells
      This may be a really amateur question... but for the life of me I can't figure out how to do a find on a text field for records that "begin with" or "start with" a specific text string whether it be part of the first word or the entire first word. I am using FM Pro 4.0 and wonder why FileMaker Inc. didn't include a way to quickly and easily perform this seemingly simple task.
      Any thoughts? (I have already searched FileMakers Tech Info Library to no avail.)
    • By Sharky K
      hi everyone,
      I have a dutch mac news site: http://mactag.cjb.net/ running on FileMaker Pro.
      My question is: can I make with Filemaker Pro a kind of message board so people can post comments on news posts?

      An other question is: Is it possible to make a search so that you must type in both search fields? (it is maby a little bit odd but i want to make that you get a kind of login/password and when you type them right you will find your own records.)
      ------------------
      kind regards
      Sharky K.
      [This message has been edited by Sharky K (edited June 18, 2000).]
    • By jmichea
      Not sure if this qualifies as a basic question or not but here goes...
      I am looking to do a find for an item that may appear in several different fields across multiple records. For example, I have a record with one section that contains 10 fields listing parts. I want to do a find that will find the name of the part in any or all of those 10 fields. Not sure how to do this.
      Thanks
      Jeff
    • By donwolf93
      A user was using FileMaker 3 (we use 3 and 4) on our network and tried to print and crashed so he restarted the machine. Now when I try to access the file, I get the message: "That file has been damaged or possibly had its access priviledges tampered with"
      I've tried opening it from 3 and from 4, and copying the file, and recovering the file. (Recover performs steps one and two and then reports that it cannot find the file in question)
      Any idea on how to recover this file?
      email appreciated donwolf93@hotmail.com
    • By Stan
      The username says it all...rookie.
      Working in FM4Pro, developing on a Mac and porting to PC.
      I'm trying to do a simple sign-in roster, where users enter their user ID, hit OK and are logged in, date/time stamped, and set active (an entry in Timein field). Users are stored in the employee database. New users will set up a new record (userid, firstname, lastname, and orgid) in the employee database as part of the log in. When they log out, all users just enter user ID and the program pats 'em on the bottom, says goodbye, and calculates the amount of time on. Simple.
      Except when I ported it from the Mac to the PC, it began to fall apart. F'rinstance:
      --The login screen wouldn't zoom to 75% on startup, even though the script is identical to what worked on the Mac.
      --Part way through a trial run of current users, it wouldn't log out, but kept logging them in, or vice versa (out, but not in)
      --New users weren't led to the data entry screen when they weren't found in the employee database.
      I think it's a procedural issue, but I can't put my finger on the problem.
      Printing out the scripts to check the Find parameter(s) is tedious (is there a better way?).
      The Find parameters have changed without my help, apparently on a Paste Date function. Should that happen?
      Comments invited; Thanks!!
  • Who Viewed the Topic

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.