Jump to content

Escaping quotes in a calculated field


This topic is 5733 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Hi,

I need to add a slash to all double quotes in a text field so that when exported, it can be properly interpreted by the program we are sending the flat file to.

So, for example,

this: he said "hello, how are you?"

becomes this: he said "hello, how are you?"

It seems like a pretty simple fix by using the substitute function, but I'm having problems getting the syntax right, i.e. this doesn't seem to work:

Substitute(FieldName;""";"")

Any idea how to do this?

Thanks,

Andrew

Link to comment
Share on other sites

You must specifically specify unstored in Storage Options. Copying your calc and pasting into my definition, it works and produces:

he said "hello, how are you?"

I tested it both in 7.0v3 and 8.0v2. :wink2:

What version of 7 are you running?

Link to comment
Share on other sites

Strange. Yep, it's breaking alright.

Well, it said I didn't have the right font so I changed it to Verdana. Then your calc field produced smart quotes. This may be why it's breaking.

Link to comment
Share on other sites

This topic is 5733 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.