Jump to content

calc fields displayed in portal do not update automatically


elvis_impersonating_penguin
 Share

This topic is 7378 days old. Please don't post here. Open a new topic instead.

Recommended Posts

ok.. i have a portal, and one of the fields that is displayed is a calculation field. One of the fields it is calculated from is on the layout with the portal. Now if i change the field i have to click on the portal rows, or change layouts and then go back, or change to another mode and then back again, to get the calculation to update, or atleast display that it is updated. Its probably updating, its just not showing up in the portal. Unfortunatly using a script is out of the question (unless i were to use a plugin to activate the script when the user leaves a certain field, and I dont want to install a plugin on every machine that will be using the database). So there is probably no way to fix this problem. My question is, why does it do this? Why doesnt it show the update automatically??

Link to comment
Share on other sites

quote:

Originally posted by bman:

My question is, why does it do this? Why doesnt it show the update automatically??

Technically, I do not know. I am sure that there is some issue with FMP knowing when to refresh, simply changing a field does not cause FMP to refresh, so the portal does not update.

However, you do know that Filemaker is the ONLY software with dynamic portals into related databases, so this is a pretty small price to pay. You already know what things will cause FMP to refresh the screen and thus the portal, so one of those things must be done.

Link to comment
Share on other sites

SSSSSTOP,

don't escape & wait a mom. : if i remember i had some similar nightmare in one of my solutions !

Let me investigate where and which way i had put 'sleepy calcs' at work.

I don't remember if i've solved it with a 'visibility' trick or a relationship trick or other: i will inspect the files (pardon me and be patient , are tons....) and i will back with some kind of answer or ideas.

While i'm investigating, do you can post the formulas of your calcs & the order in which you dispose them in layout ?? (obviously if there aren't HMS -HER MAJESTY SECRETS)

Best greetings.

Link to comment
Share on other sites

LiveOak, that is actually the way i refresh portals when a script can be used. unfortunately a script would not be practical in this instance. so i may just have to live with it not refreshing.

and for jpaul, this is the calc i am using..

Case(IsEmpty(purchasing_::PReceived), LRecieved, Lquantity)

this is a field in my line items database, and it is displayed through a portal in my purchasing database

[ August 06, 2001: Message edited by: bman ]

Link to comment
Share on other sites

Something that I have done in the past in similiar situations is to put a button on the screen called "Update Portal" or something like that. This runs a simple script which will cause the screen to refresh, thus updating the portal.

This at least give the users a way to cause the portal to update.

Link to comment
Share on other sites

Originally posted by bman:

[QB]LiveOak, that is actually the way i refresh portals when a script can be used. unfortunately a script would not be practical in this instance. so i may just have to live with it not refreshing.

and for jpaul, this is the calc i am using..

Case(IsEmpty(purchasing_::PReceived), LRecieved, Lquantity)

this is a field in my line items database, and it is displayed through a portal in my purchasing database

OK, as promised here i am; as supposed it is a 'visibility & refresh trick' i put in a db i've crafted last year for a Swiss forwarding & shipping Company.

Here are the steps to follow:

  • in line item db create a field Preceived1 (the same type of Preceived, number i think)

  • in the portal displayed in Purchasing db, hide this field under the regular Preceived field and make it transparent.

  • for Preceived1 field only (in the portal) set the attribute 'editable', while locking th regular Preceived

  • modify the tab order so the Preceived1 is tabbed before Preceived (this trick forces the refresh)

When you tab in the portal the field Preceived1 appears (usually set to 0) in place of the Preceived field; when you exit the field Preceived is refreshed.

Hope this helps, best regards.

P.S: You can easily prevent users from inserting unwanted contents into the Preceived1 field simply by setting its 'VERIFY' attributes.

Link to comment
Share on other sites

This topic is 7378 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.