Jump to content

Checkbox field truncating values


Hijack
 Share

This topic is 2820 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Here's an odd one....

 

I'm building a value list of data which comes from a static field in a relationship.  That builds just fine and changes as I nav the parent record set.  And example of the list might be:

 

iDRAC (00:00:00:00:00:02)
Server On-board 1 (00:00:00:00:00:00)
Server On-board 2 (00:00:00:00:00:01)

 

That's a combination of NIC ports and MAC addresses on a server.  I can confirm the list is correct by using the Data Viewer to monitor:

 

ValueListItems ( Get ( FileName ) ; "Server Ports and MACs" )

 

I want to be able to select from this list in a field but when I apply that list to a checkbox field the options display as:

 

iDrac

Server On-board 1

Server On-board 2

 

The display of the values is truncating.  I can do the same thing with a static list and build the values similarly and they display truncates as well so I'm pretty sure it's not the list creation.

 

if I select some values in the checkbox and monitor the contents of the field, they are the full string values, not the truncated display values.

 

Anyone know what's going on?

Link to comment
Share on other sites

Nope.  That's not it.  I've expanded that field with plenty of room and no change in the output.  It seems to be related to the layout style because doing the same thing in another layout with a different style produces different truncation points (sometimes in mid-word or 1 character from the end, etc.).  I can't see anything about the style definition that would be involved though.

Link to comment
Share on other sites

Ah, then possibly ... go to Inspector > Appearance > Advanced Graphic and look at padding.  Some themes have large padding set (such as 6 on both sides).  In my test, without padding all of the value shows but with padding of 6 on both sides, it truncates as you've indicated.


And this matches what Voltron is saying.

Link to comment
Share on other sites

Thank you, LaRetta!  That did the trick.  Setting the right padding to 0 removed the truncation.  I would have thought the field would have displayed as much of the content as possible rather than chopping it off at a space.

 

But, now I know so I can work around the issue.

 

Thanks again.

Link to comment
Share on other sites

I would have thought the field would have displayed as much of the content as possible rather than chopping it off at a space.

 

Just as in setting margins or any indents, FM respects those boundaries.

 

But, now I know so I can work around the issue.

 

Precisely.  A single tweak ... set the padding to 0 and save it as a new Style or update your prior Style (your choice).  Then if you wish it to ripple through all fields with same Style (on every layout with that Theme in your solution), save it to your Theme.  I love Themes and Styles in 13; can't wait for 14!

 

I'm pleased you worked it out.  :-)

Link to comment
Share on other sites

This topic is 2820 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.