Jump to content

This topic is 3106 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Hello

 

As you will notice, I'm working like mad on starting point to get it customized to taste!

 

I found this issue with DATE FORMATTING. I use "the rest of the planet" date format DD/MM/YYYY which is my system date format.

Everything goes OK until now. I tried to change a payment period from monthly period to weekly and the date assigned to start and end period reverted to MM/DD/YYYY.

Question: How do I get dates to respect the system date format( DD/MM/YYYY) ???

Here is a screenshot

FileMaker_Pro_Advanced_SCR_001.thumb.pngFileMaker_Pro_Advanced_SCR_002.thumb.png

Link to comment
Share on other sites

Enter Layout made and select the field you wish to change.

in the Inspector, go to the "Data" tab.

In the "Data Formatting" section, make sure the date option is selected, and choose "Custom"

You can now enter the date however you would like it displayed.

 

P.S.

You also have the option of a short and long system date, which I believe would work in your case.

 

Thanks

-JH

Link to comment
Share on other sites

Have you tried File > File Options > Text tab, "Always use current system settings" ?

There is also Ye Olde Trick of saving a clone of the file. That will reset the date format the first time you open the clone.

Link to comment
Share on other sites

Thank you guys, BUT that is not it. 

1- "Always use current system settings"  That is set and works fine for other dates in other fields

2- In the "Data Formatting" section, make sure the date option is selected, and choose "Custom" - This option is greyed out on the inspector (field is not locked)

The selection of weekly bi-weekly etc is calling script 
1218 Set_Pay_Period_Suggestions, and the date after this script is reversed to MM/DD/YYYY beside the field contains DD/MM/YYYY. 

I was not able to completely understand how it is reverting to an American style date.

APPARENTLY this is where it is happening but NO CLUE why
SetField [T14_PREFERENCES::Pay_Period_Start_Day_Adj ;  Get ( CurrentDate )- Mod (   Get ( CurrentDate ) -  T14_PREFERENCES::Pay_Period_Start_Day_Adj   ;7 )]

Thank you

Beto Boton

 

Link to comment
Share on other sites

 

2- In the "Data Formatting" section, make sure the date option is selected, and choose "Custom" - This option is greyed out on the inspector (field is not locked)

 

That would suggest the field is not a date field. Perhaps check in the Table what field type it is.

Link to comment
Share on other sites

This is a known issue: when you set a text field to the current date (or a derivative of current date), the result will ignore the file's setting and always use the date format stored with the file.

Either change the field type to Date, or clone the file as explained earlier by Fitch (or both).

  • Like 1
Link to comment
Share on other sites

This topic is 3106 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.