Jump to content

Buffer overflow


dwal
 Share

This topic is 7361 days old. Please don't post here. Open a new topic instead.

Recommended Posts

It appears I am having buffer overflow problems with Web Companion v6 for Mac using FileMaker 5.0 on an Apple G4, OS 9.1. Every few hours Web Companion ceases to serve although FileMaker file sharing functions normally. Reloading FileMaker fixes the problem for few hours. I suspect it is caused by Code Red. The access log is flooded with entries as follows:

172.129.121.209 - - [07/Aug/2001:17:50:08 -0700] "GET /default.ida?XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX%u9090%u6858%ucbd3%u7801%u9090%u6858%ucbd3%u7801%u9090%u6858%ucbd3%u7801%u9090%u9090%u8190%u00c3%u0003%u8b00%u531b%u53ff%u0 078%u0000%u00=a HTTP/1.0" 404 1362. Last Thursday I talked with FileMaker and they say no one else has reported this. They asked me to send a copy of the access log and am eagerly waiting for a reply. I am surprised no one else is having this problem. Has anyone found a solution to this or seen this problem?

Link to comment
Share on other sites

Hi dwal,

I have had the same problem with a machine I have just set up with FMPro 5 Unlimited on an OS 9.1 Mac. I have turned my logging on but the duration between my problem is about 28 hours. I will keep an eye on it. I will try OS 9.0.X and see how I go.

Link to comment
Share on other sites

Tony, OS 9.0.4 did not solve the problem. It did lengthen the time it takes for the server to fail.

On Saturday I configured our firewall to block many of the code red requests to our server and this has solved the problem. Serving has functioned without problems since Saturday afternoon! Unfortunately there are so many code red infected servers to block I had to in some cases block large ranges of IP numbers and thus I have probably blocked legitimate requests of our server.

I notified FileMaker of this and hope they can solve our problem.

Link to comment
Share on other sites

This topic is 7361 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.