Jump to content

SMTP Connect Fails - Mac only over SSL


This topic is 2761 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Hey

A client is having an issue with the email plugin. Up until just a couple days ago, everything was working fine. Then they started experiencing SMTP connect failures. The connect code is:
EmailConnectSMTP( "smtpout.secureserver.net:465" ; "[emailaddress]" ; "[password]" ; "ssl=1" )

Pretty straight forward. It's Go Daddy hosted email. This has worked for months. I tested on two different Macs in different locations and the same issue, where previously this worked as well.

I tested on a PC and it worked fine - odd. Why would it work on a PC but not on a Mac?

I checked my client's Mail program on their Mac, and it is using 465 and SSL to send out and that sends out fine.

So I removed the SSL attribute from the code and changed the port to 80 (per email set up instructions) and it sends out fine.

I tried a different email account that uses 587 and TLS and that worked fine from the Mac.

So, the issue seems to be that when using 465 and SSL on a Mac with this email server and the plugin, it fails. But change any of those attributes and it works.

Nothing has changed on our side, so I'm assuming the email server has been adjusted to some small degree.

The only thing left that I can think of (and differences between what I see in the Mail client and plugin attributes) is the password type is not specified when using EmailConnectSMTP. Of course it's not when sending from a PC either and that works...

I've looked at the plugin logs and I see it failing but the detail is not meaningful to me.

Anyone come across this issue before? Any ideas on further troubleshooting? Many thanks.

Duncan

Link to comment
Share on other sites

Hi Duncan,

I have a feeling I may know what is causing the issue but I would like to confirm that from your logs. Please replicate the issue on one of the Macs and send your logs to [email protected] and reference this thread. See this page for log locations. Be sure to send the logs before closing or restarting FileMaker as this overwrites the logs. 

My inkling is that the mail server may have been updated to only accept Diffie Hellman keys (DH key pairs), which are used to establish SSL connections, at a length of 2048 or longer. This is a problem for our plugins running on Mac because they require Java 6 to operate but Java 6 can only generate DH key pairs with a length of 1024. I will be able to tell if this is the case from the logs

Link to comment
Share on other sites

For others coming across this issue, Ryan's response above and his inkling were correct after examination of the logs. If you have this issue, please contact 360 Works support using the details Ryan supplied above for further assistance. Many thanks to Ryan for helping out in a very timely manner.

Link to comment
Share on other sites

This topic is 2761 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.