Jump to content
John Chamberlain

Headers do not show or print

Recommended Posts

Starting a new project in FMP 14. I have designed a report with title header and a page header. When I view the page in Browse the headers do not show, nor do they appear in a printout.

I have attached a file and the layout in question is #4. Can someone give me a clue here, please?

Distribution Grids.fmp12.zip

Share this post


Link to post
Share on other sites
Lee Smith    147

You need to set the layout part to show and print.

 

layout parts.png

 

Also, change the header type to Top Navigation and see if that is what you need.

Share this post


Link to post
Share on other sites

Hello Lee

I think have this set up the way you showed it, but the header still won't print. I also tried eliminating the page header, and put all of the items into the Top Navigation header, Sorry to be so dense, but I have been forced into FMP 14 by a problem with FMP 11 no longer working in Mac OS 10.12

 

image.thumb.png.8f679c335d810153b35ed7a04cac490f.png

Share this post


Link to post
Share on other sites
Lee Smith    147

Hi John, I got sidetracked yesterday and didn't send this.

In layout mode, double click on your header part and select Top Navigation. 

HTH

Lee

Share this post


Link to post
Share on other sites

Sorry Lee, I must be missing something. The picture I sent you shows the header as Top Navigation. Could you please clarify?

Thanks,

John

Share this post


Link to post
Share on other sites
Lee Smith    147

Hi John,

Sorry I'm confusing you. The 2 attachments might help

Your file I modified 

Another screenshot of the Layout showing the Part Tab I'm referring to.

Show Header chang.png

Distribution Grids MOD Lee.fmp12

Share this post


Link to post
Share on other sites

Sorry, but I am still not getting it. The Mod you sent still does not print the headers. As you can see, it prints is a page with no headers and the field names in place of the headers, like this:

image.thumb.png.fb4b4534ffa34709e3fa28d0ea34f3cd.png

If you get a different result than I do there must be a systemic problem ... I did uninstall, then reinstall FMP 14 but the result is unchanged.

Thanks again for your help.

Share this post


Link to post
Share on other sites
Ocean West    106

Top and Bottom navigation parts are non printing objects - all other body parts will print. (if it shows up in preview it will print )  

Share this post


Link to post
Share on other sites

Hi

Thanks for your reply. I am very new to the .fmp12 extension. I was forced to abandon FMP11 (.fmp7 extension) when it would no longer work on my Mac (long story).

I didn't realize that there was such a large gap between FMP 11 and FMP 14.

Guess I'd better rush off to Barnes & Noble and get a manual for FMP14 and start to learn FMP all over again.

Share this post


Link to post
Share on other sites

Thanks, Lee. Yes, this will do it.  Thanks for your patience. I guess I have a lot to learn about the fmp12 format.

Share this post


Link to post
Share on other sites
Lee Smith    147

Glad It work. It was the order of the layout parts you used.

Lee

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×

Important Information

By using this site, you agree to our Terms of Use.