Jump to content

Works in Pro/Not in Go: Scroll Window [To Selection]


Recommended Posts

[Cross Post - I posted this as Claris Community, but didn't get any bites after 24 hours]

I am trying to scroll to the active record in List view.

It works perfectly in Pro (19).

I am running the script from Go (iPhone) using the FileMaker Network (lightning cable to my Mac)

I cannot get it to work in Go. It goes to the right record and field because I can manually scroll to it, but the script won't do it.

Here is the simple script:

======================================

Go to Field [Select/Perform; Person::FirstName]

Scroll Window [To Selection]

======================================

It doesn't budge in Go.

I have used a dialog window/Data Viewer to confirm I'm actually in the right field and on the right record, but Go will not scroll to it.

I have tried every imaginable combination of Pause/Refresh Window/Scroll Home/Scroll End, etc.

Nothing in the docs indicate it should work differently between Pro/Go.

Anyone have any ideas?

Link to post
Share on other sites

I'm in List view with a sort based on Urgency (Urgent, Concerned, Regular).

I go to a card window (same context, not that it matters) that has three stars for urgency. I change the Urgency.

I close the card window that returns me to List view. The same/right record is selected in Pro/Go, as it should be. But, Pro is still showing that record even if it moved 100 spots due to being a different Urgency. Go doesn't. I can't get Go to scroll to that record, even though it is even selecting a field on that record. I can scroll down a few pages and there it is, on the right record with the Go To Field ready to edit.

I tested it by using Scroll Window [Home] and Scroll Window [End] instead and it scrolls to the top and bottom accordingly. So, I know it is executing that line of code.

This one really has me baffled... 

Edited by whardy
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • By Bbuwell
      What would it cost to have someone make me a database using filemaker go on a single ipad for managing a lost and found inventory?  
       
      What I would like it to do ... 
      1.  log into the database each item being put in and by whom 
      2. take a picture of each item 
      3. print a sticker to affix to each item with a barcode so it can be referenced for disposal or pickup by owner
      4. have email reminders for auditing on specific items that can perhaps only be stored for X hours before being destroyed (credit cards and such)
      5. generate a weekly and monthly report for all activity in the lost and found safe.. 
       
      Thanks.. Brian 
      bburwell@gmail.com 
       
    • By typewriter
      I have a problem with FileMaker Go 18.0.3.325 (iPad, iOS 13.x). The app crashes when I adding an autograph to a container field using Insert from Device. Does anyone have a similar experience? I has worked fine, using older versions of FMGo. How does this function work anyway? Is it kind of interactive webviewer that is called using Javascript to capture the autograph and putting it back as a graphic into the container field? Claris' documentation is non-existing on these kind of topics.
      NB on other occasions, I noticed that an 'interactive container field' is in fact a webviewer that interacts with the container storage, and FileMaker sometimes seems to get confused, so I guess this is happening here too. Should I check for some non-standard browsers on the iPad (it's a customer's iPad, not my own)? Any suggestions would be welcome!
    • By ironsuit
      Filemaker Go 15 instantly crashing on launch(iPhone) since IOS 14.2 upgrade.  Anyone else? 
    • By mvoogt
      Hi have a PDF that I annotated on my iPad. I upload this pdf to a container field in FM Go. If I go to my desktop FM Pro, I can see the annotations just fine in the container preview however on FM Go, the annotations do not display in the preview.
      If I export the pdf from the the container, the annotations are indeed there.
      What can I do to get the annotations to show in the container preview in FM Go (as they do on FM Pro on the desktop).
    • By mvoogt
      I'm on iOS. I'm using iOS shortcuts and FM Go.
      In FM Go, I send a container's PDF to iOS shortcuts via a x-callback-url with an "input" of the Base64Encode PDF. I annotate the PDF in iOS Shortcuts. I then send the annotated PDF back to FM Go to insert it back into the container...however there seems to be some characters in the Base64encode fmp url parameter that can't be passed in the URL coming back.
      Is there something I can do to further encode this Base64 script parameter (that is the annotated PDF) so that it will pass back to FM Go via the URL.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.