Jump to content
Sign in to follow this  
Learner1

Check boxes problem

Recommended Posts

Hi everybody,

I have a problem with check boxes.They are normally used to select multiple choices but I can,t check more than one box. I have to uncheck it to be able to check another one. Can anyone advise me about this?

Thanks in advance for your help ;)

Share this post


Link to post
Share on other sites

Double chcek to make sure that the field is text.

Share this post


Link to post
Share on other sites

Can you post this file? Best to make a copy and delete everything except the problematic field and its value list.

Share this post


Link to post
Share on other sites

Hi Comment, I am trying to let the user choose one or more administration for each file (or fiche. Sorry if it's in french but it's in french but it's only 2 tables :)through the fiche layout.

I would realy appreciate any help beacause this problem is driving me crazy ;)

thanks in advance

Thanks for the advice Lee Smith.

test1.zip

Edited by Guest

Share this post


Link to post
Share on other sites

There is a list of files that the Forum will accept by the Manage Files link. Among them is .zip. This is the best format for both platforms to use, so just Zip the file first, and it should work.

Report back if you have any other problems.

Lee

Share this post


Link to post
Share on other sites

The field you're trying to change is used both as the key field for another relationship and has an auto enter lookup based on that relationship. I believe what's happening is that when you try to change it, it looks itself back up and finds itself again. Tre zen.

Remove the lookup for the match field (you have it in the other relationship too) and you'll be good.

Share this post


Link to post
Share on other sites

Hi David,

Thanks for your answer but there are things I'm not getting . What do you mean by lookup and how can I remove it?

Sorry if I'm asking stupid questions but I'm still a beginner ;)

Share this post


Link to post
Share on other sites

In the Define Database options for a field, you can set the field to automatically enter information from a related table.

Go to Define Databases, choose the table FicheUnite, doubleclick on the field Code_Unite, make sure you're in the "Auto Enter" tab and uncheck the box that says "Looked up Value".

Share this post


Link to post
Share on other sites

Thank you very much.This works very good, I was confused beacause I have a french version and the vocabulary is different.

I have another question: Is there a way to have the choices stocked in seperate recordes instead of having a record store 2 or more values.

Thanks again ;)

Share this post


Link to post
Share on other sites

If you want to split the values out into different records, you will have to change your data structure around a little bit. You will have to create another table to store the Nom_Unite and the Numero_fiche( since that is the id of the fiche record and you will need it for your relationship). Instead of using a check box set to select a unite, use buttons to create your new records in your new table and insert the users choice.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.