Jump to content
Sign in to follow this  
Matt Malyschko

FileMaker Go App Maker

Recommended Posts

I have been using the App Maker tool for some time now, but always with hosted solutions, which works fine.

 

When I try to create a webclip for a local database, when I try to open the webclip it gives an error..

Cannot Run Script

Safari cannot run the script because JavaScript is not allowed to be used this way.

 

I assume it's something to do with iOS 8 maybe, given the App Maker does only say it supports up to iOS7... but they haven't released an update yet.. Are there any other ways of doing this, or can I adjust the fields in the App Maker so it produces the correct JavaScript?

 

Thanks in advance

Share this post


Link to post
Share on other sites

OK, this is AMAZING! What are the odds -- I came here to post this very question, and then figured I should do a quick search first . . . . .

Share this post


Link to post
Share on other sites

This problem seems to have arisen again with the latest version of iOS.

Couldn't find an update anywhere - has anyone been doing something new for this purpose?

Share this post


Link to post
Share on other sites

I updated the App Maker database when ios8.0 came out and I have not had any issue with it, which I have not test in a while.  My webclips that I last created still work on my iPhone 6.

My dropbox was in a mess so I move files to different folders and broke a lot of my links.  

Here is a new link to the lastest version I updated.  https://www.dropbox.com/s/cjidji6tlzvhg6u/App%20Maker.fmp12?dl=0

Note the original App Maker can be download from the filemaker community forum.

I did not write the database.  I had found several solutions  on different forums and decided to make the updates myself and share it. 

I tested the app maker and I add a ios 8.3 profile under setting. 

Prior to ios 8 used one filepath then the path changed for 8.0., a screen pops up with error message,  I added setting to run full screen so second screen would be solid black.  It appears with 8.3 that the old filepath prior to 8 works with 8.3.  The  8.3 setting in App Maker sets path back to old path and sets profile to run in full screen so second screen is still black instead of message.

 S Chamblee   

Edited by schamblee
Did follow up testing, and added details about testing
  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.