Jump to content

Date fields pushed to hosted as "?" (question marks)


siroos12
 Share

This topic is 2284 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Hi all,

 

On hosted file, date fields show "?" in them after syncing. It is not font or field small to show the text, it is a pure "?" in the field.

 

Any help would be highly appreciated.

 

Thanks.

Link to comment
Share on other sites

2 hours ago, comment said:

What do you see when you click into the field? And what is your file's date format in use?

 

Comment,

 

It is a "?" even when I click in the field, even when I export it to text file or Excel file. I tried all the date formats on both mobile and hosted files. Nothing changed.

Link to comment
Share on other sites

Hi siroos12, 

Can you replicate the problem?

Is this an existing file that this is, just now rearing its ugly head, or a new solution that you are in the process of development?

What is the source of the date impute? Could it be a system difference?

Is there any other users seeing this?

Just some thoughts on a lazy Saturday (here)

Lee

Link to comment
Share on other sites

2 minutes ago, Lee Smith said:

Hi siroos12, 

Can you replicate the problem?

Is this an existing file that this is, just now rearing its ugly head, or a new solution that you are in the process of development?

What is the source of the date impute? Could it be a system difference?

Is there any other users seeing this?

Just some thoughts on a lazy Saturday (here)

Lee

Dear Lee,

  • This is an existing solution which has been working fine before.
  • The date input source is the Ipad calendar drop-down. 
  • The users see the dates properly on their Ipads. But all Pro users see the "?" in the hosted database, even on Pro on server machine. I believe it is not formatting issue on the hosted file as if I edit the field on Pro using calendar drop-down, it shows the edited date correctly.I think it has something to do with FMEASYSYNG not pulling dates in correct format. Is there any way of checking that?

Thanks,

 

Siroos

Link to comment
Share on other sites

5 hours ago, siroos12 said:

It is a "?" even when I click in the field

If the field truly contains a "?" then that's what it has been populated with. Most likely, you have used a Set Field[] script step with a calculation that results in an error.

You say this happened "after syncing" and you have posted this in the FM EasySync section. I am afraid I know nothing about that, but I'd bet that's where the problem lies.

 

Link to comment
Share on other sites

 

Sorry for not giving proper information.

 

Yes, the file is hosted on FM server 14, and the iPads are using FM GO. The syncing script is FM EasySync. I think I will have to remove the wjole syncing script folder from my iPad file and redo it from scratch. I will let you know if it solves the problem.

 

Regards,

Link to comment
Share on other sites

On 3/12/2016 at 0:14 AM, comment said:

If the field truly contains a "?" then that's what it has been populated with. Most likely, you have used a Set Field[] script step with a calculation that results in an error.

You say this happened "after syncing" and you have posted this in the FM EasySync section. I am afraid I know nothing about that, but I'd bet that's where the problem lies.

 

I even add a new date field in both files, it still pulls "?" from iPad to hosted file.So I believe it is not setfield() script step. something is wrong with transferring/processing payload from iPad to hosted file.

Link to comment
Share on other sites

OK, I have been advised by Mr. Lee Smith to upload my files here. Please receive attached a clone version of Ipad file and hosted file I am having troubles with. 

As a history,

We had one hosted file and 25-30 Ipads syncing using EasySync and 15 FM Pro users. Everything was working perfect. All of a sudden, our Filemaker pro users started complaining about the performance, they used to open the hosted file remotely on their PCs using FM Pro over local WIFI network. I did check the hosted file and realized that the file size is abnormally big (72 GB-almost 18000 records) although all the containers were set to store data externally on an open source.  And the server RAM usage was at 99%-100% all the time. 

To resolve the issue, I did split the big monster file into three separate files for records of 2014, 2015 and 2016. then we did upgrade the server computer to 32 GB of ram, Core i 7 CPU 3.4 GH, SSD 1 TB hard drive. The files are still big like the 2016 with 2800 records is about 20 GB. But the whole system runs much faster but still the RAM gets to 99%-100% when I run a sync from iPad or when I do import into the file on the server computer. 

All the container data are really stored externally as I check the data source folder on local hard drive, but it does not effect on the file size. I did set the containers to not to store externally, the file size is still the same. I even closed the file with external storage and did restart the FM server and server PC, but nothing changed.

The file is hosted on FM Server 14.0.4.412 .

 

  • First of all, it pulls "?" to hosted database on all "Date" fields.
  • Secondly, It gives me the error of  " The Pull request has failed. No Payload was received from the server. " Although there is no ES_PULL TOs in my files.
  • Thirdly, The Server computer RAM usage is abnormally high, specially when a script is running and we do an import on the server PC. 99%-100%.
  • And at the end, it takes something like 15-20 minuets to sync only one record with no image in that record, only text.

Username: Admin

Password: Admin

I hope I could explain it clearly.:)

 

I would appreciate any help on these matters.

Siroos,

Host Clone-20160313.fmp12

 

Edited by siroos12
Upload hosted file
Link to comment
Share on other sites

OK, I could sort out the file size issue, I just followed a suggestion from " Joshua Willing Halpern " to set the B64 calc fields to unstore the calculations. after I closed an re opened the file, Volla!! my file is 1.3 GB now. So the performance issue is resolved by now. Thanks a million Joshua!!!!

 

But I still have the issue of "?" in date fields. 

  • If I change date fields to text fields, it works but then they are not dates any more. 
  • When I add a date field into both files, it still pulls "?".
  • I did test the EasySync sample survey file and it works perfect. So I did re-import all the scripts and re-setup every thing like from scratch but still dates pull as "?"

Any thoughts?

 

Regards,

 

Siroos

 

 

Link to comment
Share on other sites

If you set the value of the field from a computer using regular FileMaker Pro, will this field still be synced to server as: ?

Edited by ggt667
Link to comment
Share on other sites

16 minutes ago, ggt667 said:

If you set the value of the field from a computer using regular FileMaker Pro, will this field still be synced to server as: ?

Yes, I did test it on pc using FM pro and Ipads. It does the same. :|

Link to comment
Share on other sites

On 14 March, 2016 at 1:58 PM, siroos12 said:

So I believe it is not setfield() script step. something is wrong with transferring/processing payload from iPad to hosted file.

If you only knew what's in those sync tools...

Link to comment
Share on other sites

1 minute ago, ggt667 said:

If you only knew what's in those sync tools...

Well, my database is a simple file. Not too many scripts. Specially I have no script in date fields. 

On the other hand, I used calendar drop down for data entry, even I did input dates manually but nothing has changed. 

  • Like 1
Link to comment
Share on other sites

I’m not sure what I’m missing/seeing,

I looked at the intro date and see it is a value list date from data in a field.

The date is text in the table, but it is index, could this be affecting the data?

Because, when I tried to put a USA date in a new record,  i.e. 3/22/2015,  it rejected it. 

Maybe if you turn off the indexing for the fields, it will accept the text format date.

Lee

Link to comment
Share on other sites

2 minutes ago, Lee Smith said:

I’m not sure what I’m missing/seeing,

I looked at the intro date and see it is a value list date from data in a field.

The date is text in the table, but it is index, could this be affecting the data?

Because, when I tried to put a USA date in a new record,  i.e. 3/22/2015,  it rejected it. 

Maybe if you turn off the indexing for the fields, it will accept the text format date.

Lee

Sir,

 

You are right, the intro date is only a text field. The issue on filed called "collection dates" and "Bought date" in table "We buy cars Reps Table" on layout "Data Entry Reps". Those two fields pull ?.

 

The 2 tables occurrences involved in syncing are called "ES_PUSH_We buy cars Reps Table" on both Ipad and hosted file.

 

Please let me know if it is not clear yet so I will explain more.

 

Thanks 

Link to comment
Share on other sites

5 hours ago, siroos12 said:

OK, I could sort out the file size issue, I just followed a suggestion from " Joshua Willing Halpern " to set the B64 calc fields to unstore the calculations. after I closed an re opened the file, Volla!! my file is 1.3 GB now. So the performance issue is resolved by now. Thanks a million Joshua!!!!

Hey, glad that worked.

 

5 hours ago, siroos12 said:

But I still have the issue of "?" in date fields.

I just looked at your file. I see that the Bought Date fields are different types in the host and client files. one is timestamp and one is date. I'm not sure that this would cause the behavior you're seeing though. Just to verify, all the other fields are syncing correctly?

Link to comment
Share on other sites

31 minutes ago, Joshua Willing Halpern said:

Hey, glad that worked.

 

I just looked at your file. I see that the Bought Date fields are different types in the host and client files. one is timestamp and one is date. I'm not sure that this would cause the behavior you're seeing though. Just to verify, all the other fields are syncing correctly?

It is like that because I was testing other fields types than Date type, So I changed it to timestamp to see how it syncs. and I forgot to set it back to Date type :( But if you set it back to date type, you will see that it syncs "?". Even if you add a new date field in both file you will get same results. All other fields are syncing correctly.

Link to comment
Share on other sites

Are both solutions using the same date format?

I have 2 suggestions, 1) make both fields( each side of the sync ) use the same date formatting, f ex mm.dd.ccyy, and 2) make sure both fields are of the type timestamp

Edited by ggt667
Link to comment
Share on other sites

Hey, I uploaded your file to a server and tested the date syncing. When I ran it the dates synced correctly. I'm low on ideas. 

Maybe there's a difference in the two computers' system settings? I'm totally grasping at straws here.

My advice would be to try to replicate this problem in a new (or cloned) file and if the problem disappears, move your data to the new copy. Maybe try a free trial of another hosting service and see if the problem exists there too.

Link to comment
Share on other sites

I have had many unexplainable issues with FileMaker Server when the language of the server is not default English.

Link to comment
Share on other sites

OK, After debugging the scripts, I found that in script "Push payload", date formats are like 2016-03-22 , then on the other hand, in script called "Process Payload from Client" on server on step line 264, we have below:

 

Set Field By Name [$table_name & ": :" & $ Field_name; $field_value]

 

On this step, the calculation results can be text only. I think maybe that is causing the issue on date fields. 

If I type in  2016-03-22  in date fields, it accepts the format and everything is fine, but if I use set field script step to do the same(I created a test script to set the field value by using set field script step), it shows "?".

I tried various date format on date fields and even I changed the server date format on windows in different ways, But still I get "?" if I use set field script step.

 

Further than that, it won't help even if I change date fields to timestamp. 

 

Any ideas?

 

Thanks,

Siroos

Edited by siroos12
Link to comment
Share on other sites

It sounds like a format issue to me. Have you tried slash marks "/" instead. My filemaker requires dates formatted e.g. "03/22/2016".

I've replicated the "?" issue. When i use a script to enter 3-22-2016 I get ?.

Try switching to "always use file's saved settings" in File Options.

Screen Shot 2016-03-26 at 2.18.32 PM.png

Link to comment
Share on other sites

5 minutes ago, Joshua Willing Halpern said:

It sounds like a format issue to me. Have you tried slash marks "/" instead. My filemaker requires dates formatted e.g. "03/22/2016".

I've replicated the "?" issue. When i use a script to enter 3-22-2016 I get ?.

Try switching to "always use file's saved settings" in File Options.

Screen Shot 2016-03-26 at 2.18.32 PM.png

If I change the set filed calculation to this format : "22-03-2016" it works, but what mobile file sends to server from script "Push payload" is "2016-03-22". odes it means that I need to change date formats on all the iPads? Or can I change the date format of the server computer windows? I believe I did change the server date format to match "22-03-2016" and it did not work, I will give it a try for a second time.

Link to comment
Share on other sites

41 minutes ago, siroos12 said:

If I type in  2016-03-22  in date fields, it accepts the format and everything is fine, but if I use set field script step to do the same(I created a test script to set the field value by using set field script step), it shows "?".

That's not possible. Not in the same file.

Link to comment
Share on other sites

I even changed the windows date format to use / instead of - but did not make any change:(

 

Maybe I should set all iPads date format to dd-MM-yyyy. I still need to Google how to do that ;)

Edited by siroos12
Link to comment
Share on other sites

53 minutes ago, Joshua Willing Halpern said:

I just tested this, I was able to produce the ? via script and the date (03-26-2016) via typing directly.

I don't see any quotes in your script step. That means you are setting the field to the result of calculating 3 minus 26 minus 2016 - which will return a negative number (-2039).  This will of course result in an error.

If your file accepts 3-26-2016 as a valid manual entry, then it will also accept:

Set Field [ YourTable::Datefield ; "3-26-2016" ]

 

 

Edited by comment
Link to comment
Share on other sites

6 hours ago, siroos12 said:

Set Field By Name [$table_name & ": :" & $ Field_name; $field_value]

Hi Siroos,

I am coming into this late and will not have a chance to test but I notice there appears to be a space between $ and Field_name ...

Did you manually type this or did you copy/paste it?  Anyway, that's probably not the issue but I spotted it so I wanted to bring it to your attention.

If you mean to include the dollar sign then it should be wrapped in quotes and if you mean to use a script variable, there should be no space unless you have a space at the beginning of the field name, which you really shouldn't have.  :-)

Link to comment
Share on other sites

22 hours ago, comment said:

I don't see any quotes in your script step. That means you are setting the field to the result of calculating 3 minus 26 minus 2016 - which will return a negative number (-2039).  This will of course result in an error.

Yeah, you're right. I'm just trying to replicate OP's problem. It sounds like the format he's using has the year first, e.g. 2016-03-26, which will gives 1987. However, he said he's getting a ? regardless.

It's sounding more and more like a date format discrepancy.

Link to comment
Share on other sites

On 3/27/2016 at 5:29 AM, LaRetta said:

Hi Siroos,

I am coming into this late and will not have a chance to test but I notice there appears to be a space between $ and Field_name ...

Did you manually type this or did you copy/paste it?  Anyway, that's probably not the issue but I spotted it so I wanted to bring it to your attention.

If you mean to include the dollar sign then it should be wrapped in quotes and if you mean to use a script variable, there should be no space unless you have a space at the beginning of the field name, which you really shouldn't have.  :-)

LeRetta,

 

You are right, it is my typo. but the script itself is correct. Buy the way, if you check the video I did upload two days ago, you will see that it does ? in my date field.

On 3/26/2016 at 0:12 AM, comment said:

I don't see any quotes in your script step. That means you are setting the field to the result of calculating 3 minus 26 minus 2016 - which will return a negative number (-2039).  This will of course result in an error.

If your file accepts 3-26-2016 as a valid manual entry, then it will also accept:

Set Field [ YourTable::Datefield ; "3-26-2016" ]

 

 

Comment,

Thanks for jumping into this post, I see what you mean about quotes in Joshua's script, but I did use quotes in my script and it is still the same.

Link to comment
Share on other sites

OK, The problem solved!

 

Actually, based on below link from FM support, New files and clones of existing files use the current operating system format for date formatting. this means that the file will use date formatting of operating system which was used when you created the file, as file date formatting, no matter what format you choose to be displayed in date fields on layouts. So if you make a file on a computer which uses "2016-03-28"  and then move it to a computer which uses "28/03/216", the file still uses "2016-03-28" not matter what format your current system uses or what format you selected for date fields to be shown on layouts. 

http://www.filemaker.com/help/12/fmp/html/create_db.8.13.html#1028802

 

So what I did to solve the issue was as below:

 

  1. I did check the format on hosted file by clicking into a date field, it was like "23/03/2016"
  2. Then I set my client PC date formatting to match with "23/03/2016" (This is the computer I use for developing my iPad files)
  3. After that, I made a clone copy of my iPad file using client PC, now date formats for the iPad file would be like "23/03/2016" which correspond with format of the hosted file. And it syncs properly.
  4. At this step, to make sure that this will not happen again, I did set file options to use file formatting instead of current operating system formatting as suggested by Joshua Willing Halpern .

From now on, I will make sure that the computer I use to develop client files is set to have the same date format with server computer, to prevent this kind of issues.

 

 

At the end, I would like to thank you all for your time, efforts, and advises.

 

Siroos,

 

 

 

 

Link to comment
Share on other sites

This topic is 2284 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.