Jump to content

Problems with CentOS 7 on Mac Mini 6,2

This topic is 940 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Hi all,

I installed CentOS 7 (minimal) on a Mac Mini 6,2 Server model with Dual HD (250 GB SSD), got FMS 19 running on it, all was well.

But if I try to reboot it or restart it the power light comes on but the OS doesn't appear to startup. I thought it was a fluke so I reinstalled everything from scratch, had everything running nicely again, held my breath while I did a reboot ... and the same thing happened.

If I connect a monitor to it after a reboot attempt it's blank, i.e., no Terminal, nothing. It doesn't show up on my network at all.

Is there something in particular I need to do to get this particular Mac Mini model to run CentOS? I Googled and found nothing.

I'd really like to get a little more life out of this machine as a Dev/Test server, so I'd greatly appreciate any help offered.



Link to comment
Share on other sites

I think I solved the problem. It appears that the automatic disk partitioning & setup doesn't define the mount points automatically, at least from what I can gather. When I reinstalled CentOS the 3rd time I manually configured the mount points and it seems to have solved the problem.

If any of you who are more well versed than I am in working with CentOS have any additional feedback/comments I'd like to hear it. My knowledge of Linux installations was limited to playing around with them on VMWare and Parallels before this, and they seem to take extra measures to configure everything automatically on installation.

Here are resources I found useful:





Link to comment
Share on other sites

Hmm, there still seems to be something else causing the problem. I think it might be the yum update command (not upgrade) that causes its inability to boot. I've done a reboot after every single yum install (installed a few helpful tools, apache, php), opened firewall ports, etc. Everything works fine until I do the yum update. Then it won't boot, I just get a machine with the power light on.

I probably don't need an update right now, but that's not going to be the case forever. Anyone have any ideas as to why this happens?

Link to comment
Share on other sites

This topic is 940 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.