Jump to content
Sign in to follow this  
Howard LeCanard

SMTP settings

Recommended Posts

I have faithfully copied my smtp settings over from Mail, but despite an hour or so of tweaking, can't seem to get an email to go out. I keep getting error #1506.

Is there a trick to this? I mean, those exact settings are working fine in Mail.

Edited by Guest
Turned on users FM Profile

Share this post


Link to post
Share on other sites

Are you using version 10?

If so, state it in your Preferences, if not, I'll move it to the SMTP Topic Area.

Lee

Share this post


Link to post
Share on other sites

Error 1506 must be vs. 10.

Share this post


Link to post
Share on other sites

Oops! I haven't even looked at those prefs in ages (obviously). Yep, I'm using FMPA10 on OS 10.4.11.

I filled that in when I was entering my topic, but I guess it didn't show anywhere.

Share this post


Link to post
Share on other sites

Check your firewall settings to make sure that port 25 is not being blocked.

Share this post


Link to post
Share on other sites

Did you, therefore, specify port 587 in the outgoing server info?

Share this post


Link to post
Share on other sites

Could be something else, but I had same problem trying to send via smtp.gmail.com - trick was to use port 465, rather than 587...

Share this post


Link to post
Share on other sites

I've tried ports 587, 465, 25, 110, and checked and rechecked that I brought all my settings over faithfully from Mail. I still get error 1506.

I can't find any security settings that try to dictate what apps can send mail. Could there be some other thing happening in the OS?

Is there a log somewhere that will help me get a better idea of what the error is?

Share this post


Link to post
Share on other sites

I just read on one of the email lists that others were having this problem. They fixed it by not including a name in the SMTP settings.

That fixed it up for me too.

Share this post


Link to post
Share on other sites

I have been reading elsewhere that the problem with SMTP email using a runtime solution is in the name field. Some people write that the name cannot have spaces. Other people write that the name field must be left empty altogether.

I find this confusing and would like to know if anybody has the definitive answer about error 1506.

Share this post


Link to post
Share on other sites

Nothing definitive, but a few more pieces of the puzzle...

Sometimes an error 1506 is related to the format of the email address given to the To: parameter, when you try to include the recipient’s name along with the address. Specifically, it cannot be in the most common form that includes the full recipient name by using angle brackets around the email address: Full Name [color:red]=BAD. To include both name and address, use the alternative form that places parentheses around the name, as so: account@domain.com (Full Name) [color:green]=GOOD.

Also, to help find successful combinations of SMTP Send Mail parameters, you may find the following file useful: SMTP_SendMail_Interrogation.fp7. Essentially it attempts to send email using every variation of the settings you give it (SSL on/off, auth type, port #s, etc.).

Hope this helps!

Lee Lukehart <lee@savvydata.com>

Certified FileMaker Developer: v10/9/8/7

Expert FileMaker Trainer: v10/9/8/7

SavvyData

[color:orange]Making Data Make Sense.

Share this post


Link to post
Share on other sites

Also, to help find successful combinations of SMTP Send Mail parameters, you may find the following file useful: SMTP_SendMail_Interrogation.fp7. Essentially it attempts to send email using every variation of the settings you give it (SSL on/off, auth type, port #s, etc.).

Lee,

This is a great tool - thanks!

Share this post


Link to post
Share on other sites

This bug still exists in FMP 11. For some more light reading, check out this conversation:

http://matthaughton.wordpress.com/2009/01/20/filemaker-send-mail-step-with-smtp-server-option/#comment-23

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.