Jump to content
Sign in to follow this  

ODBC File on FileMakerServer Adv - Remote

Recommended Posts


Got a problem with establishing ODBC connection on relations: my local PC to the file on remote server.

"Failed to connect to listener[2]" is the error which I got out of ODBC FileMaker DSN configuration manager while testing connection.

I did use manual and advices from this link:

http://help.filemake...kw/xdbc drivers

Few possible reasons:

1.) In FileMaker ServerDatabase ServerExtensions folder I'm missing


I was digging the web to find


plugin but couldnt get it.

Does anyone know where I can download


2.) In official JDBC/ODBC filemaker manual they are mentioning xDBC driver for FileMakerPro and FileMakerServer Advanced.

But in further text they talk only about configuring ODBC driver related to the FileMakerPro.

So, is the there specific ODBC driver for FileMakerServer and how can I install it?

3.) When we go in FileMakerPro on File->Sharing->ODBC/JDBC - it is turned on but cant relate sharing to the specific privilege set because these options are blocked, simply no radio button available to check one of offering options: All Users, Specify users by privilege set or No users. Why these options are blocked for checking?

Is anyone familiar with this kind of situation?

Thanks in advance

Best Regards

Share this post

Link to post
Share on other sites

You do have FileMaker Server Advanced, right? If so, did you choose to enable xDBC as part of the deployment wizard? Is the xDBC option enabled in the FileMaker Server admin console?

As to your #3: do you have a file open and selected in the "currently open files" list when you try that?

Share this post

Link to post
Share on other sites

Thanks guys,

Yes Wim, I did make all these checks before I posted here.

Just to add that m able to establish ODBC locally but when targeting remote, ODBC test failed.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.