Jump to content

Plastic Cancel Subscription problem for Authorize.net


This topic is 2619 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Hi Folks,

 

I'm having a problem canceling a subscription. I've got a sandbox account set up on Authorize.net.

 

My script in FileMaker registers the plugin first 

 

I've tried setting the gateway as both:
CCSetGateway("Authorize.net") and 
CCSetGateway("Authorize.Net"; "url=https://apitest.authorize.net/soap/v1/Service.asmx")
 
Test Mode is off:
CCSetTestMode(0)
 
I've verified that the Merchant Account, password  and Subscription ID being passed are correct for my sandbox account and the Subscription. Then the script calls a variable:
 

$Cancel =

CCCancelSubscription( 

$MechantAccount; 
$MerchantPassword; 
Globals_and_Prefs::g_Cancel_Subscription_ID
)

 

After executing, $Cancel gets no value, neither a 1 or ERROR. CCLastError comes up empty too. In the Authorize.net transaction report, the subscription stay as Active.

Where have I gone wrong?

 

D

Link to comment
Share on other sites

This topic is 2619 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • By Ben Douglas
      Hi, we recently switched gateways from Plug n' Pay to PayTrace, but we are suddenly finding that the returned raw response has significantly less data. If a card fails it does not even give us the reason why it failed. Also I've tried capturing the transaction data using CCLast___ and nothing seems to give any good information. Am I missing something? Is this something to discuss with the gateway? Have any other people using 360works with PayTrace found a way to handle this?
    • By Donald Clark
      Hi,
      Yesterday I had tested the CC not present script (somewhat modified) that comes with Plastic from a WebDirect connection.  The script worked perfectly 20 or so times over several hours and in previous tests over the past few months.  
      This morning, the FM client still gets the proper results but the WebDirect connection never seems to connect to Authorize.net.  Both are using the exact same script from the same layout.  Instead of a response with some message or error in it, all I get in the $result variable (and raw response, etc.) is a question mark (?).  I'm not sure what that means - is the request not making it to Authorize.net?  If not, why not?  You can see what I mean at this link:
      https://monosnap.com/file/OPmsuOmK1IBxIh8Yt9dCnXkBldHtxi
      I am using FM client 16 on a Mac running High Sierra using Chrome. I also tested it from Chrome on Windows.  Again, it runs fine from the client, so I think it is a WebDirect issue. 
      The server is FM 16.3.304 (the latest) running Windows 2012R.  The server is running Plastic 2.33, but I upgraded it to V 3.06 on the server to see if that would fix it (no luck, obviously).
      I also double checked the java version (144), the firewalls and the security setting on the AWS server.  All is normal. 
      Any help is appreciated, as this db goes live on Tuesday morning.  I have been testing this for a couple of months without any issues.
      Thanks,
      Don
       
       
    • By kgasman
      I have seen the below statement in other responses, but I do not understand the script steps necessary to achieve this. I have the latest Plastic plugin
      Please help
       
      "But using Plastic can help make your practices PCI compliant. For example, if you use Authorize.net as your gateway, Plastic can submit payment card and ACH account numbers to Authorize.net's PCI-complient CIM database in exchange for a token, which is PCI-compliant to store in your database. Plastic then lets you run charges against these tokens, and Authorize.net looks up the corresponding account information in their CIM to complete each transaction"
    • By Tim Cormier
      Since this morning we have been receiving an Error when trying to process credit cards using Plastic. Anyone else using Payeezy and experiencing this issue? Any suggestions?
      Thanks!
    • By FMFun
      I have had 2 transactions that come back with the error "Declined: 15005" - which means the transaction is declined by the card issuer. This is a card not present, simple transaction so the only info being passed is the cardholder name, credit card number, expiration date, verification code and card type. Both customers called their banks and the transaction is being declined in one case because the address doesn't match and the other because the zip code didn't match. This makes no sense because that info is not even being passed in the transaction. Both cards that gave the 15005 error were ran via ICVerify outside of FM and they were immediately approved. Any idea why Plastic can't get them to go through? 
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.