Jump to content

Server 12 and secured/SSL client connection status


Justin Close
 Share

This topic is 2594 days old. Please don't post here. Open a new topic instead.

Recommended Posts

We are using FMSA 12.05 on OS X 10.8.5.  We have configured the server to require secured connections (i.e. use SSL) for the FMP client.  However, we don't appear to always be getting secured connections when clients log in.

 

We have an 'open' script that runs when clients log in, finding various information about that user.  I included a step to set a global variable to the connection state when a user logs in, and that is displayed on a layout.  90% of the time when I log in (local account, full access) it shows that I am connected via a secured connection (state=2).  But, the other 10% of the time, it tells me that I am on an unsecured connection (state=1).

 

This is the calculation (done to make it more human readable when displayed):

Case (
    Get ( ConnectionState ) = 0 ; " 0 - no network connection for the current file " ;
    Get ( ConnectionState ) = 1 ; " 1 - non-secured connection " ;
    Get ( ConnectionState ) = 2 ; " 2 - secured connection using FileMaker Server’s default SSL encryption" ;
    Get ( ConnectionState ) = 3 ; " 3 - secured connection with a fully verified server name in the certificate " ;
    "No information available."
)

How can it be giving non-secured connections, if the server is configured to require secured connections?  It apparently is dropping the user to an unsecured one if it can't establish a secure one, is my guess... but why would it do that instead of throwing an error and informing the user about the problem?  (Yes, we could do that ourselves in our login script I suppose.)

 

I haven't been able to narrow down or replicate the problem consistently.  If I notice it, and log back in, chances are high that I will get a secured connection the next time around.  Not always though; there have been times when I logged in a few times and still ended up unsecured.  But then co-workers would log in at that same time and get secured connections.  

 

Any ideas as to what's going on and how the decision tree about secured connections works?

 

Thanks,

Justin 

Link to comment
Share on other sites

This topic is 2594 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • By HOnza
      Everyone is excited about Lion. Even though many new features on Mac OS X 10.7 are giving us improvements we kept asking for since 10.1, Apple has again succeeded in giving all the new features the strong essence of innovation that makes us unable to hesitate to install and try Lion out as soon as we are able to.
      But we are also afraid. What if some important apps stop working?
      Read more in my article. Alredy updated with links to other resources and opinions...
    • By mleiser
      I go into my FM server like I always did before. The only difference is I'm coming in through teamviewer as I'm not in the office. I get this message and just don't know what to do:
      I get the following error message. Tried to push the button to start database on the top left and it's hanging.
      The database server is not available
      admin console functionality is limited to filemaker server overview and the log viewer panes.
      to use other functionality, the server administrator must start the database server again.
    • By Teilo
      So, the time has come. Runtime support is gone in 19.
      This puts me in a quandary. At my company, I have a handful of small apps that do nothing but import CSVs and print labels with barcodes on Zebra label printers, or packing slips with pictures for each item. These are one-off special purpose databases. There is no active data management. The scripts clear out the DB and import a fresh CSV on each run.
      I have tried making these applications work with Server, to no avail. I doubt anything has changed in 19.
      I can understand Claris wanting to move to an online subscription-based model, but the problem is that the server version is not at feature parity with the desktop client for certain essential things I need, like printing to a label printer, or exporting PDFs with images that come from a folder full of PNG files that change on each run.
      I have some time, obviously, but version 18 will not run forever, especially if Apple's shenanigans continue. Is Claris listening, or should I just assume that this is a lost cause?
    • By Cheyanne
      I am trying to use the following but I am getting the attached error:
      GetURLasContainer( "https://generator.barcodetools.com/barcode.png?gen=1&data=A31254&bcolor=FFFFFF&fcolor=000000&qsize=1&xdim=1&w=&h=&fmt=0&mode=0&angle=0&quiet=1&alignh=1&alignv=1" )

    • By ggt667
      As I was not able to make the GUI approach in beezwax blog to work; I wrote this blog / HOW-TO on how to sign your own certificate mainly on command line: https://github.com/TyrfingMjolnir/SelfSignedCert
      I wrote this blog / HOW-TO after doing a deployment for a KYC( Know Your Client ) system for a financial institution.
  • Who Viewed the Topic

    1 member has viewed this topic:
    Daemon 
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.