Jump to content

Can't launch shell script via server schedule (MacOSX Server & FM 13)


mdenyse
 Share

This topic is 2800 days old. Please don't post here. Open a new topic instead.

Recommended Posts

  • Newbies

Hi all,

 

I’m trying to execute a shell script from a FileMaker Server schedule. FM 13 and MacOSX Server 10.8. It’s a simple script to put a message in the syslog to test. Running from the Terminal app works fine but from within FM Server it doesn’t seem to kick off (no error messages anywhere I can find).

 

Things to consider:

 

- MacOSX Server 10.8 and FileMaker Server 13

 

- File is in the right location (/Library/FileMaker Server/Date/Scripts/) as I'm able to select it when creating the schedule

 

- fmserver is the owner and fmsadmin is the group of the .sh file

 

- I’ve tried permissions of 755 and 777

 

- File contents (following 2 lines):

#!/bin/bash

syslog -s -l error "This is a test."

 

- I’ve tried #!/bin/bash and #!/bin/sh

 

- Running from the terminal app works as expected - I see the message in the Console app (using either /bash or /sh)

 

- When I run the server schedule, FM server's Event.log file shows:

  2015-04-03 11:12:27.866 -0400 Information 146 XXXXXXXX Schedule "test" run now by "YYYYYYY".

 

  There's no succeeding line of a process ID being spawned so it looks like it's not even trying to execute the script.

 

- The server schedule has the default settings for the account (fmserver)

 

Anyone have any bright ideas of why this isn’t working?

 

Mark

Link to comment
Share on other sites

This topic is 2800 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.