Jump to content

Filemaker bug with certain characters


This topic is 2738 days old. Please don't post here. Open a new topic instead.

Recommended Posts

  • Newbies

I would like to see if anyone could help me to verify if the problem I am having is a bug in Filemaker.  I have recently upgraded my network from Filemaker 13 to 14.  In 13 I did not experience this issue.  It seems that in Filemaker 14, when a particular Hindi character is pasted into a Filemaker field it crashes the database.  I have tested this on numerous machines within my network with the same result.  I am hoping that someone will run this simple test for me and report back if it happened to them as well.  I just need someone to create a database, create one text field.  Create a new record and paste this Hindi character in that field.  Then do a find and place your cursor in that field. At this point the database should crash.  If anyone can confirm this I would love to know, thanks! 

Hindi character: क्स्ड (I will also attach a text file with the Hindi character in case something messes up when I post this...)

hinid_error.txt

Link to comment
Share on other sites

I could not reproduce this behavior in Filemaker Pro 14 Advanced v14.0.6 on OS X 10.11.6.

I tried to just add a field in an existing table, paste the character, and perform a find on that field. It behaved normally. I then followed your sequence of creating a new db, creating a field, and pasting the character in the field.

In either case, performing a find on this field created no problems. I pasted the character in Find mode, performed the find, and the record with that character was found with no problems.

EDIT: I would start troubleshooting by suspecting a corrupted font file.

Edited by doughemi
Link to comment
Share on other sites

  • Newbies

OK, I threw away the FntCache.dat file, I removed every program from my system that was unnecessary (and all my Adobe programs except for Photoshop - I read online about this type of error with Adobe PDF, I restarted my computer and am still getting the same error.  This time I copied the error from the event viewer, it is faulting the xpal.dll  Not sure what to do at this point, I know this is a stack buffer overflow error, but I don't know how this applies.  My problem is that certain (not all) Hindi characters cause the database to immediately crash.  If anyone has any thoughts....  I am not sure if this is a problem for everyone (with Windows) or something that is local to my computer. Thanks Doug for verifying that it is not a problem on the Mac :)  That is helpful...

Faulting application name: FileMaker Pro Advanced.exe, version: 14.0.6.602, time stamp: 0x57364413
Faulting module name: XPAL.dll, version: 14.0.6.602, time stamp: 0x5736488a
Exception code: 0xc0000409
Fault offset: 0x000000000007cf08
Faulting process id: 0xdf0
Faulting application start time: 0x01d247a809da7b8f
Faulting application path: C:\Program Files\FileMaker\FileMaker Pro 14 Advanced\FileMaker Pro Advanced.exe
Faulting module path: C:\Program Files\FileMaker\FileMaker Pro 14 Advanced\XPAL.dll
Report Id: 506262ad-b39b-11e6-82e9-8056f2ff202b
Faulting package full name: 
Faulting package-relative application ID: 

 

Link to comment
Share on other sites

This topic is 2738 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.