Jump to content
Sign in to follow this  
DaveTolle

Phantom record created with 2 specific data entries in find.

Recommended Posts

Could use some help hunting this down. I have a relational database with one table containing 3 primary data fields to find records including a status which is Pending, Active or Complete. The other selection fields are Activity, Project type, Program type.

 

When the found set selection is status is Pending and Program type is Emergency Repair, a phantom record is created which I can delete. If I add the Project type to the find, no phantom. If I add the Activity to the search, a phantom is created.

 

When I search for Pending on all other Program types in the database, there are no phantoms created. It is only for this one program type, Emergency Repair.

 

Once parameters are met to switch the record to Active, there are no phantom records created for a search for Emergency Repair. Only when in the Pending status for Emergency Repair.

 

Baffled. Ideas?

 

Thanks,

Dave

Share this post


Link to post
Share on other sites

can you post the file and specific directions on how to reproduce the phenomenon your trying to fix?

Share this post


Link to post
Share on other sites

I performed a recover test on a backup and the problem is resolved. I am unable to attached the complete Recover log, but this is how it started:

2014-04-15 08:15:57.630 -0500    HCDMainBkUp4.14.14.fp7            808         FAILED consistency check, error 808

2014-04-15 08:16:42.491 -0500    HCDMainBkUp4.14.14.fp7            0              *** Started recovery of 'HCDMainBkUp4.14.14.fp7'

2014-04-15 08:16:42.532 -0500    HCDMainBkUp4.14.14.fp7            0              Scanning blocks and rebuilding file...

2014-04-15 08:16:42.559 -0500    HCDMainBkUp4.14.14.fp7            300         ERROR: Recovery of 'HCDMainBkUp4.14.14.fp7' failed

2014-04-15 08:17:14.351 -0500    HCDMainBkUp4.14.14.fp7            0              *** Started recovery of 'HCDMainBkUp4.14.14.fp7'

2014-04-15 08:17:14.421 -0500    HCDMainBkUp4.14.14.fp7            0              Scanning blocks and rebuilding file...

2014-04-15 08:17:18.562 -0500    HCDMainBkUp4.14.14.fp7            0              Scan complete, found 91522 page(s) to process

2014-04-15 08:17:24.015 -0500    HCDMainBkUp4.14.14.fp7            0              Rebuild processed 91522 page(s), completing end of file

2014-04-15 08:17:29.180 -0500    HCDMainBkUp4.14.14.fp7            0              Completed copy or rebuild of file blocks

 

And ended:

2014-04-15 08:25:59.753 -0500    HCDMainBkUp4.14.14.fp7            8495       WARNING: problems were detected while recovering the database.  The recovered file should NOT be used going forward; copy only the most recent work from it into a backup copy of the original file.

2014-04-15 08:25:59.762 -0500    HCDMainBkUp4.14.14.fp7            0              File blocks: scanned and rebuilt 91522 block(s), dropped 0 invalid data block(s)

2014-04-15 08:25:59.775 -0500    HCDMainBkUp4.14.14.fp7            0              Schema: scanned fields and tables; some problems were found...

2014-04-15 08:25:59.787 -0500    HCDMainBkUp4.14.14.fp7            0                fields created to match record data: 0

2014-04-15 08:25:59.799 -0500    HCDMainBkUp4.14.14.fp7            0                field values deleted due to invalid ID or repetition: 0

2014-04-15 08:25:59.812 -0500    HCDMainBkUp4.14.14.fp7            0                records deleted due to invalid ID: 0

2014-04-15 08:25:59.824 -0500    HCDMainBkUp4.14.14.fp7            0              Structure: scanned; 6 item(s) modified

2014-04-15 08:25:59.837 -0500    HCDMainBkUp4.14.14.fp7            0              File size after recovery is 374599680 bytes

2014-04-15 08:25:59.849 -0500    HCDMainBkUp4.14.14.fp7            0              *** Completed recovery to 'HCDMainBkUp4.14.14 Recovered.fp7'

 

I do not know when this problem started and I am not sure about what the "original file" should be as there has been consistent updating since migrating to 11. I may have no choice, but to place the recover file to the server. See any problems with that?

 

Thanks,

Dave

Share this post


Link to post
Share on other sites

I have found that creating a new Status field takes care of the problem in the non recovered version. That is a least case fix and I will test that for a few days.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By FMRadio
      Basic Question:
      I am attempting to import 60 records from a CSV file. There are 4 fields per record: First Name, Last Name, Email and Source. 
      When I choose Import Records... > File... from the File menu, everything looks good, 4 data points point to the correct field names: arrow icon "Import this field" but the rest are the double dots icon, "Don't import this field," and when I click on the Import button only the first record is imported.
      I don't use Filemaker frequently enough to remember everything but when I need it, I really need it. I do not remember having to go thru and changing every icon in the Import dialog to import this field, I thought that was automatic.
      I there something missing in the CSV file? I can reprocess that if required. Having to indicate to import for every record will be tedious.
      Thanks in advance for any help.
       
    • By ZoinksScoob
      I just upgraded my Mac OS to Mojave (10.14.4).  I am running FMP Advanced 11.0v4, and my databases are in FP7 format (due to a legacy system at work.)  I now have a repeatable "glitch" where if I perform a find in a database and there are no records that come up as results (i.e., no records match the find), regardless which choice I make next (Cancel or Modify Find), the app quits and I keep getting the window to send the issue to Apple. I can immediately re-open the database, though usually the last 2-3 changes I made weren't saved.  Other than the obvious option of upgrading the app, does anyone know of a workaround for this? Thanks in advanc.
    • By JH Howland
      Filemaker Pro 11 is running on two Windows 10 computers connected as Host and Client over a network.
      The script to import data from an Excel .csv file utilizes the following script step options:
          1. Un-Checked - Specify data source - File
          2. Check - Specify import order, Import Action
              a. Select - Update existing records in found set
              b. Check - Don't import first record (contains field names)
          3. Check - Perform without dialog
      When the Import script is run from the Host computer, and the desired .csv file is manually selected, the Excel first row field names are not imported and the second row with the data is imported as expected. (See Host Import Mapping)
      When the same script is run from the Client computer, the Excel first row field names are imported and not the second row data.  To get the proper result, I have to leave the check box for "Perform without dialog" unchecked and then manually, from the "Import Action" group, check the box for "Don't import first record (contains field names)" to get the proper data imported. (See Client Import Mapping, check box is no longer checked)
      Is this caused by a defect in FMP 11?  I can't figure out why this is happening.


    • By JH Howland
      After my Windows 10 based Filemaker Pro 11 MarinaPro Solution is launched (Path = C:/MarinaPro/Marina.fp7), I need to create a variable ($$source = filewin:/C:/MarinaPro/ResScheduler/) to a revised default "Open File" path.  Because I need to select from several reservation request attachment Excel .csv files, placed in the ResScheduler directory by an Outlook 2010 Macro, my "Import Records" script is set with an "unspecified" data source.
      When my script is activated with Error Capture "Off", I get the obligatory Filemaker Pro Error message, "The file <unknown> could not be found..." and the "Open File window is still set to "Look in: "MarinaPro" (Default).  And, of course with Error Capture "On" there is no Open File window presented.
      I have to manually select and import the first Excel.csv file before the default directory becomes "ResScheduler".
      I want my default "Open File" "Look in:" directory changed from "MarinaPro" to "ResScheduler" before I open the first Excel.csv file.
      Is there a way, nothing I have tried is working.
      Import.pdf
    • By transpower
      I've updated my computer from Windows 7 Pro to Windows 10 Pro.  My FileMaker Pro Advanced 11 does not launch.  I get the message "The application has failed to start because its side-by-side configuration is incorrect."  What's the solution for this issue?
      Update:  I clicked on an fp7 file, and then Windows asked me to insert the FileMaker CD, which I did.  Some files were quickly copied over, and everything works fine now!
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.