Jump to content

All backups are empty! Not cloning!

Recommended Posts

balooka    0
Posted (edited)

Hi I'm running FMS server and have daily and hourly backups. I'm not using cloning and I do verify integrity. Today we ran into a major problem were some data was deleted and I wanted to use a backup and restore the data. I moved the backup file to a local machine (away from the FMS and to my local FMA 14) to check if the data we deleted was stil there. But the whole file is empty?! All backups are empty, zero records. The file size is large enough to assume it should be there but there simply is nothing. 0/0 records shown.

I'm not cloning for sure! I have made a new rule for backup and ran it right away and the data is still gone! So all 99 rolling backups are useless. I need this fixed as this is absolutely unreliable now. We assumes we had plenty backups, when there is actually no backup at all.




ps. Stopping the DB and downloading it results in yellow/red/green icons but I don't see it anywhere. Everything is on Macs and the FMS is running at another location.


Edited by balooka

Share this post

Link to post
Share on other sites
Wim Decorte    455

What is reported when you run a recovery on a copy of a backup?  Any errors?  Does the record count show up normally?

with "new rule" you mean a new schedule in FMS?

What else is running on that FMS server?  Usually these kinds of issues come interference with other processes like 3rd party backups, dropbox, OS level file sharing,...

Not to sound pedantic: this is precisely why you should not assume that the backups are fine; you have to proactively check them once in a while so that you can solve these kinds of issues without a gun to your head.

Share this post

Link to post
Share on other sites
balooka    0

Thanks Wim


Indeed I meant schedule in FMS. There's nothing else running on the FMS and there are only about 5 people active at the same time. I've done the same setup with FMS 13 and there were never any issues. I should have checked of course if the backups were OK, and I did by looking at the file size. I've tried to zip them before transferring them to my own machine but nothing really helped. I'm going to install FMS again on a new machine and see if I can replicate the problem. If not, I'll just wipe the remote server and start over. I couldn't find anything related to this besides making clones, which I'm not doing.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Richard Fincher
      Hi all,
      I recently upgraded my Filemaker Server 13 to Filemaker Server 14.
      To get the new version to install, I had to downgrade my Java8 from u113 to u67 (separately installing the old Java version, not allowing the FMS installer to install Java itself).  I also had to fiddle around to make sure it was running the httpd which comes with FMS and not the one bundled with Mac OS X El Capitan.
      My question is, am I now save to upgrade Java back to the latest version.  I'm not anticipating needing to install FMS14 anytime soon, but does the "Deployment" part of FMS use Java, and if so, is it similar fussy about which version?
    • By slywilcox
      So our IT group migrated a Filemaker 14 server with a business application that I support.  Since the migration, the system response has been horrible.  Screens that took about a second to render before are now taking 15 seconds.  I have monitored the server and the most significant statistic seems to be network latency.  Most of the other statistics seem fine, but latency has gone from 20-30 milliseconds to 800 milliseconds at times.  Does anyone have experience with the Scale HC3 architecture running Filemaker solutions?  What has your experience been? Are there words of wisdom to make this better?
    • By Genelia
      Hi to All,
      I am getting Issue from users where they are getting very unusual error message while connect with Filemaker application. i have attched screenshot of that.
      Currently we are using Filemaker server 14 and filemaker pro 14. All database is installed on FMS 14 and through Citrix platform , they get connected to databse by using filemaker pro 14.  But recently i get same kind of issue 3/4 times.
      They are trying to export something on application and they are getting error alert.
      I am attaching issue message.
      also when i checked Event log file, i got warning 30 for that particular user's id  that means he is disconnecting his connection."Warning    30   DBXXX   Client "ABCDEF  server ip addres xxxxx" no longer responding; connection closed. (10)
      Please help me out.
      Thanks in Advance,

    • By ernst
      I had to migrate a Mac OS Mini Server running Mavericks 10.9.5 and Filemaker Server 13 to Filemaker Server 14.0.4 on El Capitan 10.11.6 today.
      It turned out to be an unpleasant and tiring operation, so I wrote a little manual that hopefully can help and save time for other people running into this situation.
      Some steps my not be necessary, but the following list describes the road I took, stumbling from one problem to the next.
      Rest assured that I left out a lot of swearing and three letter words that were also part of the process ;-)
      Greetings Ernst
      Backup your databases, stop and de-install any previous Filemaker Server version. 
      The Filemaker 13 de-installer is located in the Extra’s folder on the Filemaker Server 14 installation disk image.
      Install El Capitan 10.11.6 + updates 
      Do not install OS X server ( yet ) - see the notes at the end of this little manual.
      Remove the Java version installed with Mac OS - in my case Java 8 update 111.
      Steps from the Oracle website:
      In the Terminal window Copy and Paste the commands below:
      sudo rm -fr /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin 
      sudo rm -fr /Library/PreferencePanes/JavaControlPanel.prefPane 
      sudo rm -fr ~/Library/Application\ Support/Java
      Install the version required by the 14.0.4 Filemaker Installer: Java 8 update 60 before installing Filemaker.
      Installer is called: jre-8u60-macosx-x64.dmg
      After creating an Oracle account and logging in it can be downloaded from:
      - Scroll all the way down and click Java Archives
      - Click Java SE 8
      - Scroll down to Java SE Runtime Environment 8u60
      - Click Accept License Agreement
      - Download jre-8u60-macosx-x64.dmg
      The Filemaker installer is supposed to install this Java version by itself, but in my case it appeared to contain the Java 8 update 31, causing a loop within the Filemaker installer, repeating the process of installing the wrong version.
      Get Filemaker fms_14.0.4.412.dmg. 
      Use the full installer!
      In my case installing an earlier version and running the updater did not work - the updater to 14.0.4 hung during installation.
      Filemaker also advises this but unfortunately chose not to put the full installer on their website, so I had to Phone Filemaker support and supply the original sales contract number. After providing these details they mailed a link to the 14.0.4 full installer.
      Install fms_14.0.4.412.dmg 
      Because I was planning a co-install with OS X Server App I used port 8080 and 8443 in stead of the standard 80 and 443 during the setup.
      Also I did not enable web publishing and ODBC/JDBC during installation because I desperately wanted to get the normal services working.
      Do not start Deployment when the installer finished but click Quit in the finishing dialog.
      Next step is to stop the server process via the terminal, as per Filemaker’s instruction: type or paste sudo launchctl stop com.filemaker.fms in a terminal window, enter and administrator password when required.
      In my case I had to restart the Mac and do this last step again after a fresh restart, before the FileMaker Server 14.0.4b Software Patch wanted to run without complaining about the Server being running.
      Run the FileMaker Server 14.0.4b Software Patch from http://help.filemaker.com/app/answers/detail/a_id/15575
      Note that this installer will update your Java version to Java 8 update 66, in my case this went without any hiccups.
      Log in to the Admin console using the FMS 14 Admin Console.webloc shortcut placed on the Desktop by the installer.
      Alternatively point your browser to http://localhost:16001 and click Start Admin Console
      About co-installing with OS X Server version 5.2
      I know the true purist warn against this; in this case the server is under a relatively light load, so performance does not seem to be an issue.
      Getting OS X Server to co-exist with FM Server proofed tricky though. 
      Initially I had OS X Server app installed before trying the last FileMaker Server 14.0.4b Software Patch which caused the installer to hang again. 
      So I had to command-drag to move the Server App from the Applications folder to the Desktop. After authenticating the Mac detects the removal and presumably stops and repatches all services involved.
      Then the FileMaker Server 14.0.4b Software Patch installed, after which I could put the OS X Server app back, re-login to server, re-enable the services, restart the Mac and finally login to the Filemaker Admin console.
      Next time I would leave the OS X Server installation as last step; possibly this will be less work.
    • By Peter Barfield
      Hope someone can help with this issue.
      I have filemaker server 14 installed on windows 10 ( yes! I know that is not part of the recommended specs by filemaker but it has been very stable for me as I only use it for odd db's when I am out and about from the office) and was working fine no issues whatsoever. I use ports 8080,443 and have port forwarded them through router as well as all the other ports required as per filemaker documentation.
      All of a sudden it has stopped working. (no! There have been no windows updates)
      I have disabled all firewalls and Sophos(this really doesnt like server for some reason). 
      I can connect to the server via LAN (ie local network) fine. but connecting remotely has stopped all of a sudden. 
      I use changeip to create a dynamic IP and that is working fine.
      I have completely uninstalled and reinstalled the server as well.
      Any ideas as to where i could look to see where the problem may lie?
      I have tried to connect with filemaker go V13, 14 and 15 and filmaker pro 14 and 15 from variuos machines (no joy) now i am completely pulling what little hair I have out.
      cheers in advance.

Important Information

By using this site, you agree to our Terms of Use.