Jump to content
Sign in to follow this  
Ben_TFS

System Script user account

Recommended Posts

Hi There,

I am writing a system script that needs to be run using an admin account on a Windows Server 16 machine. However when I try to set this up it says that the script is missing or invalid.

The login details I am entering are to an admin account on the local Windows Server 2016 machine. I have tried both these, and the default administrator account.

If I try to enter the login details for the FMS16 account it says Invalid account.

For now I am just trying to run a test script. This script executes successfully when I run it manually as well as when I schedule it to run using the default account.
 
Code in test.bat:
@ECHO OFF 
PowerShell.exe -NoProfile -ExecutionPolicy Bypass -Command "& 'C:\Program Files\FileMaker\FileMaker Server\Data\Scripts\test1.ps1'";
 
Code in test1.ps1:
$put = "C:\Program Files\FileMaker\FileMaker Server\Data\Scripts\test.txt"
$filecontent = "Hello World"
$filecontent | Out-File $put -Encoding ASCII
 
Screenshot 1 shows the option I am talking about. For the test if I do not tick this then it executes fine.
Screenshot 2 is showing that it comes up as missing or invalid.

Screenshot 1.png

Screenshot 2.png

Edited by Ben_TFS

Share this post


Link to post
Share on other sites

Have you tried "putting" the test.txt file somewhere outside the program files folder? Ie, in the user folder of Ben? Windows (as of v8 I think) gets pretty cranky when you tried to write to the program files folder. I would say it's a permissions problem.

Share this post


Link to post
Share on other sites

Hi Olger,

Yes it is a permissions problem, which is why I am trying to get a script to run using an admin account.

The point I was trying to get across with this script is that it will run if I use the default account but will say it is "missing or invalid" when trying to run it using admin credentials. The actual script sequence I am trying to set up definitely does need admin permissions in order to work.

Share this post


Link to post
Share on other sites

A bit late to the party, but I ran into this issue now and thought I'd provide my solution in case it helps someone.

I found out that you need to provide the domain name also on Windows, even if you are using a local account.

Something like: MyWindowsServer\administrator

You can find your complete user name by running the command whoami in the command console.

Edited by Andreas T.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By daveinc
      Hi,
      I have a performance conundrum that I have not been able to figure out for the past month and a half or so and am looking here for some guidance. 
      We have a 9-year old FM system that we run our entire Production operation on. We have approximately 150 users in 9 locations across the US and Canada for this solution.
      We have a Windows Server 2012 VM with 14 CPU Cores, 60GB RAM, and an SSD Array SAN that we run our Production Server on. We have separate Drives configured for the Operating System and Data. All users not in the facility housing the server use Remote Desktop to access the system.
      The design of this system is not optimal for performance, but it has been running very well for the last 2 years (until early February 2020).
      In early February, it began to stall no matter what we did when we had more than 120 users or so connected and working normally.
      We identified several severely taxing actions, mainly Finds on related tables with millions of records, and eliminated those. No luck.
      We added unnecessary extra CPUs, RAM, and Disk space to no avail.
      We created a completely new VM with a fresh install of FM Server 16. No love.
      Finally in desperation, we moved the server to older, slower hardware with non-SSD hard drive array and voila! the system works fine again.
      This older VM is similar in every other way: Windows Server 2012, 14(slower) CPU Cores, 60GB(slower)RAM, FastSCSI Disk Array.
      As an anti-bonus, in thinking this would be temporary, we have both the OS and the Data on a single C drive on this older hardware.
      It works splendidly on this lesser setup.
      We had all variety of hardware experts in to make sure the newer/faster setup was performing correctly. We updated all firmware and restarted the whole setup. 
      All benchmark tests show the newer system to be considerably faster in all phases, especially Disk.
      We have no problems with any other VMs on this newer/faster setup(including some less intensive Filemaker Servers).
      The one thing that occurs on the newer/faster machine that DOES NOT happen on the older/slower one, is that it stalls and the Disk is consumed by writing tons of data to FMTEMPFM* files for an extended period of time while there is no increase in data being written to the .fmp12 files.
      This particular FM Server and dataset is the only one that this happens to. We have two other FM Servers on there that have 200 plus users 24 hours a day and nary an issue.
      Does anyone know what is happening when the Disk Monitor shows the System Process is writing tons of data to FMTEMPFM files and not writing any more data than normal to the .fmp12 files?
      Thanks in advance for any guidance.
      Dave
       
    • By DPaquin
      When opining the FMS localhost I try to enable the ScriptMaster Plugin. 
      For some reason I click to enable the plugin, I sometime been able to click on save sometime..
      However, each time I close the host reopen the FMS localhost, the plugin is ALWAYS disabled.
      Would someone have an idea?
      With regards!
      Daniel


    • By DPaquin
      When opining the FMS localhost I try to enable the ScriptMaster Plugin. 
      For some reason I click to enable the plugin, I sometime able to click on save sometime not able.
      However, each time I go back to the FMS localhost the plugin is ALWAYS disabled.
      Would someone have an idea?
      With regards!
      Daniel


    • By Richmilnix
      What's the latest version of FMP / FMPA that gets along well w FMS16?
      I'm in a workplace where I have access to version upgrades, but we're working with files hosted on Server v16.
    • By Dr. Zathras
      We're running FMS 16.0.4 on Windows Server 2012 R2 and Java 8 U181 and everything is fine. Unfortunately our IT security people want me to take Java to v8 U201 and I've been caught by Java updates breaking control of FMS in the past.
      Does anybody have any experience on using FMS 16.0.4 and Java v8 U201?
      Thanks.
      Colin Hunter
  • Who Viewed the Topic

    7 members have viewed this topic:
    Josh Ormond  Alistair Bradshaw  johnBuckingham  IanW  Siva D  kpeart  Desmo 
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.