Jump to content
faaslave

Value List

Recommended Posts

Hello all,

I just started using FM17. It has been a long time, since FM11 that I have used FM. I am setting up a solution starting with FM Starting point. I created some value lists to use and all of them are fine but something strange keeps happening with one of them. I select the field, the options come up, I pick one, and I get this. "This operation could not be completed because the target is not part of a related table.". Filemaker does make the change when I select a new value from the list. How can I get this warning from a value list? Doesn't this error have to do with a script? I am not running a script that I can see.

 

Thanks.

 

Dave

Share this post


Link to post
Share on other sites

Hi Dave...

I think this is when the value list is tied to a relationship if the value list is to just show ALL values from another table than it wouldn't have that issue.

When the value list is defined to look up thru the relationship you will that value list will only work from the context of the layout where the relationship is valid.

 

Share this post


Link to post
Share on other sites

Long time no see. This is a value list with custom values. Not tied to any table. That is what is so strange. I have two on the page. One works fine, one does what I am talking about. I'll recheck it

 

Dave

I deleted the field on the layout. Made one on the layout again, and it fixed it. Must have had something tied to it from ther starter solution template.

 

Thanks

 

Dave

Share this post


Link to post
Share on other sites
Posted (edited)
19 hours ago, faaslave said:

"This operation could not be completed because the target is not part of a related table."

This message comes up when you have a script trying to perform some action (e.g. set a field or go to related record) without having a relationship to the target of that action.

It also appears  if you place a field from an unrelated TO on the layout, then try to edit the value in that field manually.

Most likely, the field you have deleted had a script trigger attached to it. And you probably copied it from another layout, where the script was in the proper context for the action to take place. 

Bottom line, you must be very careful when modifying an existing solution made by someone else.

 

 

Edited by comment
  • Like 1

Share this post


Link to post
Share on other sites

That is exactly what happened. Thanks Comment. Glad to see you are still on here

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By MacFileman
      Hey....
      Currently running FMS15 on a dell optiplex from 2015. No real issues to speak of. I want to upgrade to FMS17. Was thinking of switching to a Mac Server, wanted to know your thoughts.
      I do hit my server now from the outside and plan to use more heavily with images, uploading to my server into image containers, etc.
      Why switch...for one, my shop is primarily graphics and Mac based and we are just better all around with Macs. I realize there are probably better hardware configurations getting a new PC.
      Thanks!
      Mike
    • By gczychi
      FMS17: In my Import.fmp12 database, I have specified an external FileMaker database file:Main.fmp12 and added a couple of table occurrences to this file (with the same names as in Main.fmp12) and added the corresponding layouts.
      When I open Import.fmp12 from a client, I can see and work with all records of the Main.fmp12 file, just fine. From the client, I can also run any script just fine.
      However, when I run the same script as a scheduled script from the server (only with server compatible script steps, of course) the script runs, but I can’t see any record !
      Here are some script steps that I use:
           Go to Layout [ “Kontakt” (Kontakt) ]
           Show All Records
           Set Variable [ $id_Käuferbetrieb ; Value:  Let ( [ ~fmsql_execute = True ; ~query = "  SELECT id FROM Kontakt WHERE Betriebsnummer = ?  " ; ~columnSeparator = Tab ; ~rowSeparator = ¶ ; ~result = … ]
      And this is what I get:
      (Import is a local table and a local layout)
      LayoutName: Import
      RecordCount/FoundCount: 1324/30
      LastError: 0
      (Kontakt is a local layout with data from a remote table of an external data source from Main.fmp12, with TO «Kontakt»)
      LayoutName: Kontakt
      RecordCount/FoundCount: 0/0
      fmsqlresult: ?
      LastError: 0
      I’m puzzled — Any idea what’s wrong?
      Thanks a lot for any help!
      Gary
    • By fmbug
      Hi All,
       
      Scenario: 
      We have 7 Severs -  3 DB ( xyz1.abc.com (Database Server), xyz2.abc.com (Database Server) & xyz3.abc.com (Web Server (Child of xyz2.abc.com) ) and 3 Citrix Servers where FileMaker client is installed (xyz4.abc.com, xyz4.abc.com & xyz4.abc.com ). 
       
      Current relationships are as below:
       
      xyz1>>xyz4, xyz5, xyz6
      xyz2>>xyz4, xyz5, xyz6
      xyz3>>xyz4, xyz5, xyz6
      xyz1<<>>xyz2
      xyz2>>xyz3
       
      Could you please help us to know how many SSL Certs we need to purchase in case SAN type?
       
      If we need to purchase SSL certificates from other vendors which are not listed in FileMaker CA, can we purchase it from them and one more concern will that be working fine in FM Server?
    • By doughemi
      xpost:
      I have installed a copy of my website on my local server with installed FMS 17. 
      Direct contact with the (local copy of the) database works fine through File–>Hosts–>localhost, and I can access the Admin Console via localhost:16001.
      When I try to connect via a php script, I get an Error 22 message:
      Communication Error: (22) The requested URL returned error: 503 Service Unavailable - This can be due to an invalid username or password, or if the FMPHP privilege is not enabled for that user.
      I can run other scripts which do not access the database successfully.
      I made this installation so that I had a testbed for my operational website. The database and php scripts are exactly identical to the files on my remote host (except, of course, for the server name in the php connector files).
      What steps should I take to isolate the problem?
    • By Eli Walker
      I'm working on a set of FM solutions that all share data links between one another. Currently, I'm working on local versions of the files but eventually the solutions will be uploaded to FM Server. Is there anyway that I can upload all of these solutions at once without breaking their links to one another? Or is it best I just build those links after the solutions are uploaded to FM Server?
      Thanks!!!
  • Who Viewed the Topic

    1 member has viewed this topic:
    spand 
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.