Jump to content
Sign in to follow this  
Donald Clark

RemoteScripter problems

Recommended Posts

Problem 1: I have the latest version of Remotescripter running on an AWS 2012R2 server, with FMS 18 and FMP 18 client running on the same machine (I know, not recommended, but necessary for now). Basic connectivity and communication works fine.  This machine is a robot, so I need to suppress errors from popping dialogue boxes – which stops the client from responding until the box is cleared.

The command to do this is:

RemoteScripterSetErrorCapture ( errorCapture )

Toggles error dialogs on or off. When something unexpected happens, the plug-in will pop up a dialog displaying the error message. This makes it easy to see what went wrong. However, in some cases, you (the developer) may prefer to show your own message to the user, or possibly not show a message at all. In that case, you can call RemoteScripterSetErrorCapture with a parameter of true. That will suppress the error dialog from appearing to the user.

 

Parameters:

errorCapture - set to true to suppress the default popups.

 

When I set a variable  (or a field) to set error capture = "true", I get a response of 1 (success).  However, the errors are not suppressed and still show.  And it is not an FM error - it is a RemoteScripter error.

Problem 2 - kind of related.   When I quit the FMP Client solution, I want to deactivate the port I open when using RemoteScripter.  The command for that is:

RemoteScripterStop ( 8900 )

Stops listening on this port.

Parameters:

When I set a variable (or a field) like this, the result is true (1), but the port is still listening.  When the robot client solution is restarted, it pops an error code that the port is already in use.  And pinging the port does get a response. 

Has anyone encountered these problems?  And have you found a solution?  

Thanks for your help.

 

 

 

 

Edited by Donald Clark

Share this post


Link to post
Share on other sites

Hi Donald,

For problem 1 I suspect you are passing in "true" instead of True. The difference being when you put the parameter inside quotes it is treated as a word/String instead of the necessary boolean value. When passing in a String, the function will still execute but the value is ignored since it is not a boolean so the error capture remains the default which is false. The function will return 1 unless an error is set so that is why you are still seeing a 1. Make sure you are calling this function with a boolean value.

For problem 2, I have not seen this reported before. Please reproduce the issue and send your logs to support@360works.com. See this page for log locations.

Share this post


Link to post
Share on other sites

Hi Ryan,

Thanks for the fast response!  You are correct - I was passing in 'True", not True (without the quotes).  Old time habits, I guess.  Anyway, it works now.

And, for some strange reason, the Stop is working, too.  Ran it several times manually and on last window closed without success.  Ran the same script again today and it worked.  Need to cut back on long dev sessions, maybe.

Thanks for your help!

Don

Share this post


Link to post
Share on other sites

Excellent! If you see the issue where it does not stop listening on the ports again, please send us your plugin logs so we can help trouble shoot.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By Timothy Ackerman
      Here's what I did.  I copied the Demo table, scripts, and even the layout items and pasted it all into my solution, which is called "Intakeform".  I related the Demo table to my main table by creating a field called personal_ID in the Demo table, and relating that to my Personal Info table via agreement_ID.
      What I'm trying to do is create PDFs on webdirect.  The only difference between what I'm trying to do, and the Demo database from 360Works is that I want to navigate to multiple layouts, save them all as PDFs and then append them to one PDF, and have it show up in the container field.
      I have that working in Filemaker Pro Adv, hosted remotely, and local to my machine.
      For testing purposes, I Filemaker Server running on my local machine.  I am planning to move it to my hosting environment at Foxtail tomorrow.
      When I click the button on webdirect, nothing happens.  When I click the button on Filemaker, it collects the layouts, saves them to PDF, and it shows up in the container field, without fail.
      I'm wondering if the problem is the port.  I am going to try to hard code that, instead of getting it from the port field in the Demo table.

       
      So this is what I am attempting:  hardcoding the port.
      Changed above IWP_Generate PDF script to hardcode port.
      RemoteScripterTrigger( Get(HostIPAddress) ; //We assume that FileMaker Pro client is running on the same computer as IWP, but this could also be the address of a separate processing computer
      7244 ; //Selected port number. Needs to match the port number that the plugin was started on in FileMaker Pro Client "param" //It is possible to put anything here, which will be sent to the script as a script parameter  )
       
      And then I'm restart the plug-in on localhost.
      timothy$ fmsadmin restart wpe -y
      timothy$ fmsadmin restart fmse -y
      timothy$ netstat -a | grep 7244
      tcp4       0      0  *.7244                 *.*                    LISTEN     
      Marthas-MacBook-Pro-2:~ timothy$ 
       
      Still no luck.
      Webdirect first click, nothing shows up.

      In filemaker pro, everything works as expected:

       
      Then in webdirect, we see the attachment in the container:

       
      I need to make this work in webdirect alone.
       
       
       
    • By jrie818
      I'm not sure what I'm doing wrong but when I check the version of the RemoteScripter 1.82 plugin from WebDirect client browser, I get the "?".
      The FMSA15 is installed on OSX El Capitan, inside FileMaker Server/Web Publishing/Publishing-Engine/wpc/Plugins. Restarted the server.
      I wrote a script that registers the plugin and I invoke the registration from the WebDirect client browser. And what I get is "?" from Version, Error or License Info check.
      Can someone help me? THanks.
       
    • By HALBURN
      We have a FileMaker 13 Server and a dedicated slave computer that we want to use to execute RemoteScripter tasks.
       
      The slave computer is at IP address 10.1.10.169 and we have reserved port 7244.
       
      Our goal is to trigger 'Perform Script on Server' scripts from FileMaker Pro and FMGO clients and then have the server send the requests to the slave computer via RemoteScripter.
       
      I have upload the RemoteScripter demo file to our FileMaker 13 Server and I opened it from both the slave computer and the FileMaker Pro client that I am using to trigger the script. I have modified the demo script so it points to the slave IP address and port number. When I try to run the script it returns the following error: "The host’s capacity was exceeded, try again later."
       
      Can you please provide an example script of how this is done? I can be something really simple like telling the slave computer to execute a script that creates a new record.
       
      What's confusing me about the demo file and the instructions are all of the references to IWP. If I am using FMP and FMGO clients how does IWP factor into this workflow?
       
      Our ultimate goal is to use the slave computer to push invoices and customer payments to QuickBooks via the FMBooks Connector plugin.
       
      Thanks.
       
       
       
      Here is the script that I modified:
      Commit Records/Requests [] If [Demo::Are we in IWP]     Set Field [Demo::_gMessage display[]; RemoteScripterTrigger( "10.1.10.169" ; "7244"; "param"  )]     If [Demo::_gMessage display = "ERROR"]         Set Field [Demo::_gMessage display[]; RemoteScripterLastError]     Else         Set Field [Demo::Fake field[]; Get ( CurrentTimeStamp )         Commit Records/Requests []     End If Else     Perform Script ["Generate PDF"] End If I just noticed that the script is not running on the server and I am unable to enable it.
       

    • By GW
      Is it possible to capture the URL that is used with a Web field in FMP Go when it activates a script using RemoteScripter?
       
      I want to send the Lat/Long of the iPad as part of the URL and them parse it out on the remote FMP Computer.  I already have the connection working using RemoteScripter; I just need to be able to extract the Lat/Long that is part of the URL that I send.
       
      I hope this is not too confusing!
       
      Gwallis
    • By estebancv@gmail.com
      I'm testing with the demo RemoteScripter but the parameters sent to the script fail when I call to Get (ScriptParameter)
       
       
      Startup
      IF [ RemoteScripterStart ( 7244; Get ( FileName );  "Procesos Remotos" ) ≠ "ERROR" ]
       
       
      Call RemoteScripter
      RemoteScripterTrigger( "TECNOC21";  7244; Home::temp_variable )
       
      Script "Procesos Remotos"
      Get(scriptparameter)
      ....
       
      Thanks
  • Who Viewed the Topic

    7 members have viewed this topic:
    rdfoto3  Ocean West  doughemi  Lee Smith  naina  Fitch  Rick Whitelaw 
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.