Jump to content

Maximum # Licensed nightmare!!


Kurt Knippel
 Share

This topic is 7159 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Well, first of all, you obviously have an error somewhere. I fear that it may be part of your "Restore" procedure and what is happening is that you keep restoring the problem.

You typically see this message after either a crash or Force Quit without restarting the machine, as it seems to think that the same copy of Filemaker is already open. Restarting usually takes care of the problem.

Am I correct in understanding that you ONLY use Filemaker to host databases to the web? Or are you using Filemaker Unlimited along with a web browser as a way of avoiding the licensing for copies of Filemaker on LAN workstations?

What applications are running on the machine aside from Filemaker Unlimited?

What version of Filemaker Unlimited are you using? Do you have the latest revision? Have you performed your restore procedure, and then installed Filemaker Unlimited?

Personally I found OS 9.1 to be very problematic in general. I like either OS 8.6 or 9.2.2, both of which are very stable on our servers.

Link to comment
Share on other sites

Someone has installed FileMaker Pro on more than one machine using the same single unit install code number.

FileMaker Pro Unlimited has a different type install code that permits it to have more than 10 connections in a 12 hour period. That install code does not permit multiple copies of either FIleMAker Pro or FileMakr Pro Unlimited to be installed.

In Version 5.5 the splash screen will say FileMaker Pro Unlimited. In 5.0, you must actually check the Web Companion configuration to get the number of allowed connctions. It will say either 10 or unlimited. That info is also present in 5.5, but the splash screen will tell you.

Check the server settings to see how many guests are allowed to connect, although that is not supposed to generate the message you are seeing.

HTH

Old Advance Man

Link to comment
Share on other sites

First of all, let me thank both of you for responding. It's so nice to actually be talking with people about this problem. Although I don't have an answer yet, I feel closer to one, after hearing your suggestions.

I had suspected that FileMaker was installed twice on another machine on the LAN... which, is what started this problem... now how do I fix it? As I've said, I have a licensed copy, of FileMaker Unlimited 5 (not 5.5).

And I've eliminated all the other copies on the LAN period. A "fresh" install isn't doing the trick. Is this error in regards to the maximum IP limit? If so, my web companion settings has "Unlimited" by the "Guest IP Limit" in the configuration window.

quote:

Am I correct in understanding that you ONLY use Filemaker to host databases to the web? Or are you using Filemaker Unlimited along with a web browser as a way of avoiding the licensing for copies of Filemaker on LAN workstations?

I only use it for the web, no one in our company has a use for FileMaker databases. Most departments are on PCs, they use excel, etc.

quote:

What applications are running on the machine aside from Filemaker Unlimited?

Webstar and NetForms, that's it.

quote:

Check the server settings to see how many guests are allowed to connect, although that is not supposed to generate the message you are seeing.

I have checked the web companion "guest ip limit" and it currently reads "unlimited".

So this error is not about reaching that IP limit? It has to do with the actual FileMaker versions on the LAN? What could be the cause of this? I have no other copies of FileMaker on our LAN at all. Is there some kind of trace left on a machine when you eliminate a copy? (I only ask because I fear the Temp could have installed a copy on one of the workstations, then just deleted the copy, unaware of what he has caused).

If this has to do with another copy out there with the same key-code, then why isn't FileMaker producing an error on installation? Why is this causing FileMaker to crash randomly?

The other problem I have with that theory is why am I getting the same symtoms on a completely different machine after a fresh install?

Again, thank you guys so much for responding, I really appreciate your comments. Just reading your responses has lifted a big portion of my stress.

Link to comment
Share on other sites

The only thing I can add is that the licence ID's are held in the IP stack on each computer.

Sometimes after a crash the same problem occurs in that network believes that too many of the one licence exists. Usually after a restart, which clears the IP stack, the licences are fine again.

Hope this is of interest. All the best.

Garry

Link to comment
Share on other sites

I just had another thought.

Could this be from hosting too many databases with FileMaker Pro Unlimited 5?

How many can it host? I only have 10 databases... I was under the assumption that FileMaker could handle a lot more than that.

They are not big databases, so I just assumed that wasn't the issue. I only bring it up because they are the only thing that has remaind the same.

Perhaps a bit of currpt data in one of the dabases is bringing FileMaker down when accessed. Somtimes when I relaunch FileMaker says it's doing a check on the databases becuase they were not closed correctly.

After they relaunch, they always check out okay.

Link to comment
Share on other sites

A couple of months ago I made the mistake of going on vacation. While away I had to have someone else in the company monitor the server.

About a week into my vacation he calls me in a panic. The server has crashed and everything is gone!!

No problem I say, I was careful enough to provide a full mirror backup of the drive, simply insert the CDRom and it will guide you through a restoration of the server.

Being a new person to our network, I should have never trusted him with such a responsibility.

Since then this employee has left the company... no problem, he really didn't help us out that much.

My problem occured a few weeks later when FileMaker Pro went down. At first I wasn't that concerned. A message poped up saying something about maximum serial numbers, I didn't think too much of it, becuase I figured that this guy had probably mistakenly installed a copy of FileMaker on one of the workstations. I figured all I had to do was hunt the machine down that he did the installation on and kill that copy of FileMaker Pro. I was wrong. What was to follow was easily one of the most frustrating events in my IT career.

After about a week of searching from machine to machine, all the while doing daily restarts, sometimes up to 6 times a day, I came up with nothing. No other work station had a copy of FileMaker even on it. We had five licensed copies of FileMaker, but only one of them was an Unlimited version (which we used on the webserver to host our databases).

After eliminating the other workstations, I turned my focus on the host machine. The only program that was going down was FileMaker Pro... all other hosting apps were fine. So I bumped up FileMaker's memory allocation which produced no positive results.

The symtoms are that FileMaker goes down automatically, without warning. (no error message etc.) Upon relaunch I get the splash screen but then the following error occurs and it shuts down the program:

"The maximum numeber of licensed users are currently using this copy of FileMaker Pro. Please refer to the installation code section of your Installation and New Features Guide for further instructions."

This must have been the error message I was getting all along. After a machine restart I can run FileMaker again, but it's not up for more than 10 hours and it dumps me.

At this point I've pretty much figured out that it's a licensing issue. I had been seeing clues that the temp tech didn't do as I instructed. I figured a complete refresh of the machine, down to the drive, would eliminate my problems.

I posted sites to the backup server, installed a client version of FileMaker (with a guest IP limit of 50) on that just to get me through the formatting of the drive, etc. I zeroed all data, since I had all day to do so. I brought the system back to it's original working status...

Mac OS9.1

FileMaker Pro 5 (Unlimited)

etc, etc...

That brings us to late last night... I fully expected the problem to go away, but this morning when I checked the system, it was doing the same thing!

What can I do to fix this? What's going on? Does it have anything to do with the number of client visitors? Is this some kind of virus in one of the daabase?

Any help would be great... I've searched FileMaker's website with no luck at all! I have no idea what to do... other than downgrade to a working copy of FileMaker Pro 4!!

We paid $1000 for this software, so I don't think I'd like to explaine to my boss that we just tossed his money out the door.

[ February 27, 2002, 12:16 PM: Message edited by: evildan ]

Link to comment
Share on other sites

I would agree that FileMaker isn't being shut down correctly... but I don't see how FileMaker could be shutting down when in fact It's a clean install on a clean system? And the fact that it's going down in the first day of installation would indicate to me that something else is going on.

It's all very odd, I've check memory allocation, FileMaker seems to have plenty of memory...

Any other things for me to check on the system?

Link to comment
Share on other sites

Start by disconnecting the machine from the network. This will tell you if it is a local problem or a problem being caused by another machine.

If the problem is local, then you really need to do a "Clean" install. Meaning that you need to reformat the drive and reinstall both the OS and Filemaker from the ORIGINAL disks.

If the problem is over thw network, then somewhere on your LAN you have another copy running.

Link to comment
Share on other sites

I want to continue to thank everyone who has helped my out in this string.

I really do appreciate all of your help. I've often been on the other end of tech support, and get passed over when it comes to a "thank you."

I wanted to add some more information to the story. It would seem that this was a damaged database... or all signs are pointing to that now.

One or more of my databases was damaged. Of course, this was a popular database, it gets hit all the time by web visitors.

My theroy is that the file, when access would cause FileMaker to quite, then of course upon retart of FileMaker, I would get a maximum serial warning message. Once a restat occured, FileMaker was able to restart, but it had to launch the bad database along with it in my startup of the system. The system was secure, up until the database was accessed, then the whole thing started again.

This could explain why the issue followed me with fresh formats of the drive along with fresh installs of the OS and FileMaker all from their original cd's. The problem was in the database, the only thing I was "copying over" from a backup drive.

I am going to eliminate the trouble database for a day and see if it indeed was the one brining down the program.

I'll keep you all posted, and again, I thank all of you for your help.

Link to comment
Share on other sites

Well, I've given up on FIleMaker 5 Unlimited. I can't stand it any longer. Never in my life have I spent so much of my time and money into something that just doesn't work.

I've wasted hours on the phone (with tech support) only to find that what's occuring is just "one of those things"

I am not happy, I was happier with FileMaker 4... so this leads me to my question, how to I convert my fp5 files to .fp3 format... don't tell me, I can't... becuase if I can't I'm going to freak out. I get an error asking me to call tech support, and I think you'll understand that I've already burned that bridge.

I am so very frustrated at this product right now. I love to develope in this program, I think it's both an easy program to learn and a very powerful tool when it's running.

I've tried every combination of FileMaker Unlimited that I can... the tech support guy had the gaul to ask me if I wanted to invest in an uprade to FileMaker 5.5 unlimited while I was on a rant about how I was disappointed with this program.

I'm am, to say the least, at a loss for what to do.

How do I downgrade .fp5 files to .fp3 format please?

Link to comment
Share on other sites

When was your last backup? You have no choice but to go back to it, although you should export your data and import it into the old version.

Seriously though the problem you are experiencing is NOT normal and is NOT "just one of those things".

Did you disconnect the machine from the network and see if the problem persisted? Did you cleanly install the OS and Filemaker and NOT restore any backups?

The "problem" you are referencing can happen, but I have never seen it cause more than momentary frustration, unless something ELSE is happen which is causing the problem in the first place.

Filemaker Unlimited is a pretty stable product and I highly recommend that you stick with this version.

Link to comment
Share on other sites

I don't remember where I saw it. but there is at least one outfit which does reversals such as you desire.

I empathize.

I published my db (finally this past month) in FMPro 4.0 on purpose. For all the added costs, 5.0 and 5.5 have nothing of significance to offer except perhaps a higher profit margin for FMI, and I am not a stockholder so I can't tout it. Security is no better. Where it does work it can be described only as inelegant. ScriptMaker is still single-threaded (which is why I developed my solution for the cdml -script tag). Coordination between functions, esp. security functions, is not something in FMI's vocabulary.

Of course, if they do solve these issues I don't think we can expect an "unlimited" version below $3k, possibly even $5k.

But browser solutions do negate the need for licensing as in hosted solutions.

And most of the security issues are something to be feared from geeks like me and you. And if the browser solution is over a wan (not www), then that issue is greatly minimized.

I would rather develop a browser solution than a served solution. I am of the opinion that the browser offers more versatility.

Link to comment
Share on other sites

If you really want to downgrade, there is a program called FMP Reverter that may help. Then again it might make things worse! I don't know much about it. The site warns that it's only for data recovery, not to be used for live data. shocked.gif

Link to comment
Share on other sites

The only problem you have is that Filemaker keeps quitting....

We use filemaker as a workgroup database and for web applications (unlimited) and we always get this licence error when filemaker either unexpectedly quits or is forced to quit (after locking)

I would forget the licence error as this is a problem that only occurs as a symtom of filemaker not closing properly - crashing or force quit.

It would seem that the application preferences are still loaded in the memory somewhere and the only way to clear the system down is to restart the server (as you have mentioned)

I would concentrate on why filemaker is crashing - perform a clean install (original disks - a file may be corrupt on your backup) of the system, WebSTAR and FMPro removing all unused extentions, when running WebSTAR i would recommend removing appleshare for a start, before you install WebSTAR and Filemaker

have a look at

http://www.lassodev.com/lasso3/notes/MacServer.html

it may be some help regarding WebSTAR

Conflict catcher may also be an option..

laugh.giflaugh.gif

[ February 28, 2002, 01:04 PM: Message edited by: scratchmalogicalwax ]

Link to comment
Share on other sites

Thanks again guys for all your help... I'm leaving the office this morning and driving 300 miles to the office where the server resides. I have no choice but to be there, becuase the server has taken a turn for the worse.

Daily restarts have caused more issues for the machine.

Honestly, I can't see why I should stay with FileMaker 5 Unlimited. But I have some hours on the road to think about it.

I have plenty of backups, but as I said in another post, I've developed some of the databases strictly in FileMaker 5, which then cannot be downgraded to 4.

So I'm looking at recreating those databases in version 4... but I dred the workload... becuase I have a lot going on in some of my more recent databases. And of course the downtime for those databases will be to most recent clients, who are constantly looking at their sites.

I'll check the board in a few hours after I make my destination to see if there's another solution.

Let me, again, thank all of you for your support in this matter. Even if I opt to downgrade, this community has made it worth the experience. I'll keep all of you posted as to the events to unfold.

Thanks,

Link to comment
Share on other sites

You have to try to accertain why FMPro keeps quitting.......this is the only problem u have.

RE: "just one of those things" ???

the licence error when FMPro crashes is "just one of those things" the fact that FMPro keeps crashing IS NOT!!

U said in an earlier post that it could be a database........have you proved this theory :?

If it proves to be the database:

1, try recovering it.

2, check all scripts (if u have any?!?!), formulas and relationships to see if these are causing problems

3, If all else fails rebuild the database from scratch and attempt to export the data from the old one. (Make a backup and test the database before and after you import the data,)

If it isnt the database:

1, reinstall OS from original disk....I would seriously recommend using server OS NOT the standard G4 OS.

I use G4 Server 9.1 OS which is much more stable with WebSTAR especially when all unused extensions (including chooser extensions) and control panels are removed (disabled).

If you don't have Server OS make sure u remove (disable) ALL unused extensions, control panels etc.

2, reinstall FMPro Unlimited

Test server for crashing.....

3, Reinstall NetForms.

4, If you still experience problems invest in Conflict Catcher - an essential utility for anyone that works with Macs all day

http://www.casadyg.com/products/conflictcatcher/

The most important thing is not to give up!!!

I very rarely have problems with my FMPro Unlimited's. Even when I was running WebSTAR, Lasso and FMPro off one box.

laugh.giflaugh.gif

Link to comment
Share on other sites

Well, I could not think of starting today without posting.

On friday of last week, I woke up and drove 200 miles to where the server was located. I arrived at my location around noon. After a short lunh break, I was ready to fix the fileMaker problems.

Since all of the content was on a backup server and the orginal server was not serving anything at the time, I thought it was a good time to reformat the drive (zero all data, etc.)

The machine is a beige G3. I started by putting Os 9.0 on the box. After that I couldn't find the OS updates CD that I created (Which has OS 9.04) So I decided to install FileMaker Pro then look for the disk while it was installing. (There's a reason for me mentioning this).

Still unable to locate the CD, I installed Webstar, then finally Netforms.

I was now in a position to test FileMaker. The databases were restored and I had configured FileMaker (Adjusted memory allocation, Web Companion's port settings and security settings).

FileMaker Pro was somewhat stable, it didn't go down right away.. it took about a half an hour or less for FileMaker to actuall go down. I was hitting one Database all the time... trying to make sure that it wasn't another database bringing the program down.

After about a half an hour, I thought the program to be stable, but just then, with one more hit to the same database FileMaker went down.

At about 1am in the morning I had a brainstorm, why not upgrade the system to OSX? OSX is stable, and I feel comfortable enough to configure a system using the OS.... why not? It would give me a whole nother set of variables to test... since I would be using the OSX versions of the programs, I could finally rule out almost everything but the databases.

Well I didn't realize that we didn't own a copy of FileMaker Unlimited for OSX, and the Webstar was only a beta version. I had actually gotten osx on the box before I came to this conclusion, so I advanced the clock by an hour or so. I realized even if I got OSX with all of the current versions of the programs I had I was only delaying the problem. I would have to invest in an OSX version of Unlimited, and Webstar before they both expired, which could be next week for all I know. So I dropped the idea and went back to OS9.

So frustration set in.

Back in OS 9.0, I restarted FileMaker (by restarting the machine). I took some of the databases down and started hitting another database with requests. I made sure to take down the database that was being hit before in the last test. After about 25 minutes, FileMaker crashed again.

In frustration, I decided the only thing I could do was to advance the OS, test, drop a few databases, test again, then repeat the entire process until had the most advanced os and the least amount of databases possible.

This carried me through 9.04, 9.1.x, 9.2.x and about every combination of databases that I could with all three versions of the OS.

It's now 4:30 AM, I am on my hands and knees, the problem broke me. I've been everywhere from zeroed drive all the way up to OSX with no positive results.

Now there was nothing left for me to do... but then two things passed through my mind. One was what scratchmalogicalwax said "The most important thing is not to give up!!! "

And the second was something my old chemistry teacher use to say... "If after you conduct a series of tests which all conclude a negative result, the tests were not a waste of your time, try compairing the negative results to each other and see if that brings you closer the answer."

Then it hit me as I was testing the os's with each advancement FileMaker Unlimited 5.0 went down a bit quicker then before... os 9.04 took a solid half an hour, while 9.2.2 was dropping the program with every hit. Could this be an OS FileMaker issue?

I realize that FileMaker Pro Unlimited is suppose to work on OS9, but I had real world data that suggested it wasn't working in my case.

The server upgrade was done just before my vacation, which is why I had forgotten it. I didn't handle the OS upgrade, but if I remember correctly, we only had os 8.6 on that system, but it was bumped up to os 9.04 and then again to 9.2. Symtoms could be traced back that far... this all started to makes sense... I had reproduced the results at around 5 AM, with every advanceement in the OS, it took less requests to knock FileMaker down. So there was some form of conflict between the OS and FileMaker? Possibly? Or was it sleep depravation setting in?

I rushed to install os 8.6, but the 8.5 was a full install and not an upgrade to 8, so I had to find our 8.5 disk, which wasn't in the office (of course).

It was nearing 6am and I decided I had to go, I needed to be somewhere by 8am, so I couldn't stay any longer. But I feel I'm one step closer to the answer of this problem.

I am going to bring the system to 8.6 and test it there. I have also turned on logging and I will consult that more often than I have been.

One interesting side note, after putting OS8 on that system, I never saw it so responsive before. That night I had all of the os's from 9.0 -> osx, and none of them ran as fast as os 8.0, it was taking requests and hitting the drive with speeds that made me think I was on my dual G4 533 MHz at home.

I'll get the OS to 8.6 and let everyone know what happens!

Thanks again to everyone... your words and ideas have helped me more than I can express.

Link to comment
Share on other sites

OS 8.6 is much much more stable than standard 9.x OS so you could be on to a winner!!

I have had lots of problems in the past with WebSTAR and OS 9 not Filemaker though.

I used to get very strange problems with my apple menu (I used to get two one on top of the other when opened neither of which worked!?!?!) and the server used to pause at irregular intervals, not to mention spurious crashes and crash every time i quit WebSTAR.

That is why I use the G4 Server OS 9.1. I also remove all the unused extensions.

From what you have written it sounds very much like an extension problem.....finding which ones can be a long process but with a web server you can remove nearly all of them so it is a little less time consuming than sorting a workstation.

Good luck

laugh.giflaugh.gif

Link to comment
Share on other sites

I too get the Max license error when FmP5u goes down, and similarly can only recover after a restart. Although I have not experienced the grief that Evildan has described regarding 5.0 unlimited, I agree with Keith that 4.x has a blend of cost, capacity, and stability that you just don't get with 5.0. Although my set up is stable for the moment, I aint selling my copies of 4.1

Link to comment
Share on other sites

To be clear any copy of FileMaker Pro 5.5 or FileMaker Pro 5.5 Unlimited installed with a single user install code will display this message if it quits inelegantly or if it detects another copy with the same code on the network.

This is by design. Use of a Volume License Install code produces different results. Anytime--anytime--a force quit or task end process with FileMaker Pro occurs--you should restart the mchine,

HTH

Old Advance Man

Link to comment
Share on other sites

Well it's Monday and I'm still unable to test my results with much luck.

Various things have keep the on-site person from installing os 8.6 on the system. I would suspect it to be done in the next hour or so.

Although as I type this, he has now messaged me and said he is doing a clean install of the drive... again. He is having problems with the removal of the osx files and that is forcing him to clear the drive via a format.

It might be another couple of hours before I can even test these results.

Again, I am keeping my fingers crossed, because up until this point I've run out of options.

Some other things I'm looking at are the remaining databases and memory settings.

Is it possible to allocate too much memory to Filemaker?

Link to comment
Share on other sites

If I recall correctly, during my switchover one of the things I overlooked was misspecified relationships - that is, relationships that specified .fp3 files instread of .fp5 ones. I seem to recall that this resulted in crashes when the relationships were needed for scripts or calculations - fortunately I've repressed most of that.

Anatoli - my mention of my crashes and max license errors was meant to reinforce the point that Evildan's problems have nothing to do with licenses.

Link to comment
Share on other sites

quote:

Originally posted by evildan:

Is it possible to allocate too much memory to Filemaker?

I have 200 meg minimum and prefered on my DB clients.......I don't have any problems.....they do get hit hard at times.........I build online recruitment solutions so when an ad(s) goes in national press I have to make sure the file cache is adequate until the download to server/disk time is reached.

I do however have dedicated DB clients so you have to take into account the other apps running on your server......Macs aint to good with memory so you don't want to swamp one app at the expense of another.

laugh.giflaugh.gif

Link to comment
Share on other sites

Well, as it turns out the nightmare continues.

I am now running the following configuration:

Mac OS 8.6

FileMaker Pro 5.0 v.2 (Unlimited)

WebStar 4.2

NetForms

Still no luck. One thing I've done is started logging errors and activity, but that seems to be adding more questions than answers.

For example, below is my error log, looking at it you could conclude that FileMaker lost it's internet connection at 8:37PM on March 4th. It did? I show loggs indicating that the databases were being hit before, during and after that time. But further logs errors indicate that it was serving at least to 10:47PM when it produced it's last error, which I'm assuming is a "no records found" error?

[04/Mar/2002:20:37:27 -0600] HTTP session disconnected.

[04/Mar/2002:22:24:36 -0600] ERROR: 4. No valid action in input form.

[04/Mar/2002:22:24:58 -0600] ERROR: 4. No valid action in input form.

[04/Mar/2002:22:47:18 -0600] ERROR: 4. No valid action in input form.

But ignore that... the activity log for yesterday showed the last entry for March 4th was at 11:24:34 PM

So sometime between that time and 8:05 AM March 5th FileMaker had crashed.

So the error didn't take FileMaker down, whatever it was, becuase FileMaker continued to serve database information up until at least 11:24 PM. I don't know if there were no more hits for a half an hour or if FileMaker went down exactly at 11:24 PM.

One thing entered my mind... File Indexing... If I remember the OS is set to index the content of files at midnight... but I am almost possitive I've eliminated the OS from doing this... and I don't see an OS error message of any kind in the morning... FileMaker is just down. But I've double checked that Find-By-Content is disabled.

All of this information would point to an even stronger case that it was one of the databases brining the program down (or perhaps memory allocation). But I've completely rebuilt the database that is listed as the last hit... Which I was sure was the problem yesterday and I've hit every record but I cannot get it to crash.

Is there a utility that can check to see if I have a bad database? I realize FileMaker does that on startup, but perhaps it's missing something.

I never thought of checking the relational information since the problems, but it seems to me I removed all of the .fp3 references when I upgraded. I'll double check that after I post.

So it's clear that more time has to be invested into this matter. And this might be one for the FileMaker Knowlede Base.

Webstar really is only acting as a router in a way. Almost all of my hits go to FileMaker. If I wanted to remove FileMaker and have it on it's own machine, how would I go about doing that? Is there a way to have WebStar route all traffic (port 591) to another machine? Or do I have to do that at the router level?

I'm not sure I want to get into all of that until I figure out what's going on... although as previously mentioned, that could be the cause for FileMaker going down... but I have my doubts that WebStar is taking any resources away from FileMaker, they both have plenty of memory allocated to them. (with plenty of system memory left over).

I think tonight I am going to stay up with the machine... I'll stare at the machine until it goes down... that way I can see exactly when it's going down and maybe be a bit closer as to why.

Link to comment
Share on other sites

>Mac OS 8.6

>FileMaker Pro 5.0 v.2 (Unlimited)

>WebStar 4.2

>NetForms

Not on the same machine, I hope. The 5.0v3 updater is a free download. The last version of the WC was either 5.0v5 or 5.0v6 depending on some specific circumstances. These are on the FMI site.

Where are you located? You may need to get a FileMaker Pro network expert to come in and take a look at this.

Old Advance Man

Link to comment
Share on other sites

Okay, updates done successfully.

I'm also rebuilding some more databases today, just for the heck of it.

Lastely, I'm monitoring the memory allocation... so far FileMaker doesn't seem to be ending the allocated memory.

Ruled out bad memory chip, by both testing it and have duplicating the error on another system.

As always, any suggestions are welcomed! I'm willing to try anything at this point.

Back to the grind....

Link to comment
Share on other sites

Ok! This is the hard way – and I’m neither a server, net, nor Mac expert – but a process of elimination can find a problem any time.

Step1. Backup everything

Step2. Clear the whole machine (Format) and that means every drive.

Step3. Disconnect the server from every outside source – LAN, WAN; NET etc.

Step4. Install the operating system (NOTHING ELSE). And let it run for at least twice as long as the average crash time you’ve been getting.

(If it crashes, then you know to look somewhere else other than FM) if not – continue.)

Step5. Install FM (Nothing else) DO NOT LAUNCH any DBs – let the thing run

Step6. (If no crashes) Launch a newly programmed DB (DO NOT PUT anything on the system from before) Let it run

Step7. No crashes – put your DBs back on and restart. (DO NOT connect to any external sources) Let it run

Step8. (No crash) reconnect to external sources (LAN, WAN, NET etc.)

Step9 (No crash) install one programme after another and let the thing run well beyond the normal crash time after each.

Step10. If you have no further crashes – cool, if you do, you will know exactly when and after what – then you can start to do something about it.

This whole thing might seem childish to some of you experts out there, but I’ve spent so much time hunting for problems that just can’t be the result of ‘this’ or ‘that’ only to find they were. How about, for example (this is a true story) just letting a machine run for 20 – 30 hours, without an OS, and monitoring the power flow – sometimes just a slight change can screw everything up. What about a defect on the HD? Just one little seg, that causes a crash? We can curse the software here, but this machine ran just fine until the recovery….. Now what does that tell us? How about this guy who no longer works there? Maybe a little revenge along the way??? Who knows? But one thing is sure – installing everything at once, and then testing is BAD. And always pull a problem machine from the net! Usually an over-worked machine will not simply crash. It will start to show other signs first – like search requests that take 10 hours to complete etc.

Now! Just one other tip here – I had a similar problem on a Windows system, not with a web application but over a LAN. The whole thing ran for hours, and then crashed. I exchanged the server, found that the original server ran fine disconnected from the LAN, and the new server crashed too. I entered a small routine in my FM solution that logged user and date and time, waited for the next crash, and isolated the problem to one client – what I found was a still working but sometimes not network patch cable – this shouldn’t have caused a server crash but it did. I changed the cable, and wow – since then no more crashes. It turned out the guy was touching the thing with his foot every now and then, and not crashing the server directly, but shorting the switch – you live and learn.

Well – good luck, and remember – no matter how good you are, sometimes you just have to start at the beginning……..

Rigsby

Link to comment
Share on other sites

First of all let me thank Rigsby, and of course Keith for their last posts, Keith you're right, threads like these are always worth checking out and learning from.

Rigsby,

I have to thank you for your detailed explinations and suggestions... they are very well thought out.

quote:

Step1. Backup everything

I've done that...

quote:

Step2. Clear the whole machine (Format) and that means every drive.

I've done that...

quote:

Step3. Disconnect the server from every outside source
Link to comment
Share on other sites

This topic is 7159 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.