Jump to content

Missing record for newly opened file


This topic is 5730 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Hi, I'm new to this forum, just found out about it today. Been using FM7 for 1.5 years now as the patient database for our clinic and day care surgery. It has been great to use FM to organise our computerisation, though have had to struggle through many frustrating programming aspects and have a lot more to learn.

I am having a weird problem now and it has been appearing on and off for the last 6 months. In the clinic we have 3 FM7 networked together and the receptionist hosts the files. Sometimes when the receptionist registers a new patient and makes a new patient record, she finds when she tries to access the patient record after leaving it, it can't be found. Even going to show all records does not show this record. However the 2 client FM7 computers have no problem at all. While the host can't find record the clients can. These are the events that I have so far found to lead to this behaviour.

1) It is the first new record created of the day. All subsequent new records of that day can be found and displayed. The patient ID displayed that show all records will show the a missing ID number. Whereas strangely the clients show the missing record/ID no.

2) Also noted that possibly this happens when when the patient record file is first opened for the day and the new record is made immediately in the patient registration table. Whereas when other patient records in the same table that has been browsed before making a new registration/record, this problem doesn't seem to happen. However browsing other tables in the same file doesn't stop this from happening. At this time I am still assessing/trouble shooting to confirm the problem does not happen when the patient records is browsed before making a new record.

3) I have tried making a clone of the file and import the records for the tables, but the problem re-emerged one week later. Am now getting to staff to browse records upon opening the file to see if it still re-occurs, so far after several weeks, it seems to work.

4) To be able to access the missing record, FM7 on the host needs to be Quit, then restarting FM7 and opening the file will give the host access to the missing record. Just closing the problem file and opening it again does not work, the missing record is still missing.

Has anybody else had this problem or any idea what is going on? And of course how to fix this? All the computers use Mac OS X 10.3.9 and FM7 Pro.

Thanks.

Link to comment
Share on other sites

A couple of simple things first: make sure thateverybody is using the latest version of FMP 7 -- FMP 7.0v3. The v3 update is free from the FMI web site.

Secondly, you could have some data corruption. Make a backup of the system and then save a compresseed copy of the database and see if this is better. If it's not then run the Recover command over the database.

Link to comment
Share on other sites

Vaughn, thanks for the input. Yes, all the FM7s have been updated to 7.03 (that solved some chronic problems) a year ago.

Just a clarification. I thought that by making an empty clone and importing the records again is supposed to clear any corrupted files.

Compressed is the same as "saving as a compact file" right?

Thanks

Edited by Guest
Link to comment
Share on other sites

I would suspect another copy of the file is jumping into your mix. Do you have File Sharing on? You aren't letting someone use the file which is being hosted are you (are they on the HOSTED system)?

Can you explain some of this to us? And how do you handle backup copies of the file ... do they exist anywhere else or do you zip them?

Link to comment
Share on other sites

Hi LaRetta, I believe I have file sharing on as in the FM network Extended privileges, is this what you mean? Sorry for my lack of comprehension of the terms. I haven't delved into the system for almost year now.

There are 3 computers networked together, the receptionists one launches FM7 and the files first to always become the host. Subsequently the other 2 computers will log in to be the clients.

The backup copies are done auto by script and manually. The scripted auto back up is done into a thumbdrive plugged into the host on opening and closing of the main file.

Also there is a script that backs up another set of files into the Doctor's client computer over the network everytime the receptionist prints the patient's clinical bill.

So in short opening and closing the main file backs up into a thumbdrive on the host computer and there is a repeated backup throughout the day to another computer on the network.

Manual back up is done regularly on to a CD-R.

The files are all saved with the same name as the original, but into folders with different names.

Hope, I have given suitable information?

Additional info: I forgot to mention, a backup is also done in the host computer on another folder everytime the patient bill is print, together with saving over the network to the doctors computer.

Edited by Guest
Link to comment
Share on other sites

My apologies, I wasn't clear with my question. Do you have OS file sharing on to the hosted system?

Here is my concern and I learned early on NOT to do it but I did it anyway just to find out what it look/feel like: If you have turned on file sharing on that host and you have the SAME file anywhere else on your network, FM can find it and use it. Since it is an identical copy, you won't know that different files are being accessed; one file one time (when your Receptionist first opens it) and the other file the next (what your clients find). During a test (with OS file sharing on), I traced the path FM went through to find the file. It was shared with another station who in turn was shared with another. The path went through 15 systems before it landed on the file - which was the WRONG file to land on anyway (a backup copy I had placed on manager's system).

It's okay to use a hosted file occassionally but if your Receptionist performs a find, everyone will feel it. It truly should only hold the FM file and NOT be used. I highly suggest purchasing your Receptionist another system, putting the FM hosted file in a back room, turning off file sharing (if it is on) and changing your backup process. ALL backups should be zipped so that FM can't find them. And it is never good to back-up a live file (from the OS level). Use 'Save a Copy As' if the file is open.

NOTE: This is my experience using Windows XP. I know nothing about whether Mac OS responds similarly in regards to OS file sharing but I believe it does ...

LaRetta :wink2:

Link to comment
Share on other sites

LaRetta, there is Personal File Sharing. I'm not familiar with windows, so don't know if they work similarly. Yes, personal file sharing is on.

I think I understand what you mean, it raises some points on my design or file interactions. Doesn't the defining the file references sort out that problem?

When the client opens the host file by selecting remote it only offers the files that the host opened. Which should be the one that the host has open (i.e. the receptionist opened), isn't it? I assume it does, because this problem I am having of the receptionist (host) not finding the first newly made record of the day, is not a problem with all subsequent records. And that same record that could not be found is there to be found by the clients. When the host FM is quit and restarted, the missing record is sitting where it should be. So far no record has gone missing permanantly, they all are in the files where they should be. So I don't think anything has landed on the incorrect file, doesn't seem to be.

Putting the host on a dedicated server/pc is part of my plan in the long term, I certainly would want to do it, but we have just set up and will do it once the budget allows.

"It's okay to use a hosted file occassionally but if your Receptionist performs a find, everyone will feel it." - What is meant by that? Could you tell me more please?

Thanks for the input, still a lot to learn and understand.

Link to comment
Share on other sites

I use opener files - I don't use Open Remote; it is much easier for Users, so I can't answer your question about whether they are opening the correct file but I do know this ... file sharing should not be on. FileMaker is its own network. If you are using fmnet and have set a static IP Address, it should find the correct file but if the host is not open and FM finds it elsewhere? If your IP Address (does Macs have them?) is dynamic and the host IP has changed, FM could go on a file-hunt...

Whether this is the problem with the missing record every day? Well nothing else seems to fit - it doesn't seem like corruption because it is a new record each time. As for the Receptionist using the hosted box, she takes precedence. If she runs a looping script, performs a large find etc, her system will steal all the resources and everyone else will just have to wait. And a file being used is more likely to crash ... and crashing while hosted can easily corrupt a file (which can't always be detected much less corrected). Can clients change data in that record that the Receptionist made?

Openers, file sharing and corruption are HUGE subjects. I suggest you search here on Forums to find out the risks you are taking. I need some help from Mac people - I don't know the differences and I don't want to make assumptions that the process is the same between platforms here. But I believe they are similar enough that my concerns are quite real. :wink2:

LaRetta

Link to comment
Share on other sites

I'm not sure how to reply your question on the network, IP, as I'm just a user not a programmer? Anyway I think I know what you mean. We clients open the FM file manually using remote - local hosts, it shows us what is open on the host. Not the other way where it is called favourites. The IP on my network is dynamic so opening remote using favourites method sends it hunting, it normally doesn't find anything. I guess that is what you mean, but in our system clients open manually.

I see what you mean about the Receptionist using the hosted box. Makes sense, I get it. Fortunately nothing she does is intensive. Just database management. Patient records and appointments. I haven't had a crash since the FM7s were updated to v3. Prior to that the significant problem was printing from the client.

Yes, clients can change data the receptionist made, but this not normally necessary if she did her job.

OK, I get the picture about the openers, file sharing and corruption. Will look into it more and workout some better systems for backups and so on, and migrate to a dedicated mac to run the host. But for the moment, wish the problem could be pin pointed.

Link to comment
Share on other sites

This topic is 5730 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • By Tony Morosco
      I'm a botanist, and the tables I am working with are for tracking botanical garden collections. The data represents plants in the garden, and the plants are tagged and show up in the database.  The tables I am working with were created in FMP 7, and I'd like to open them up in FMP 11 (or later.)  The system hasn't been used in years, but still has valuable information.
      One of the tables is giving me problems using the FMP convert and recover commands.
      These tables are all inter-related.  The main table is the Accessions table, which contains records for all of one kind of plant, from the same source, received on the same date.  It is basically a museum standard.
      The other tables are related to each other through this one main table.  The Species table is related to the locations table through the Accessions table. 
      (i.e.  table A relates to table C through the table B, the intermediary)  
      From the Locations table, we can't see the the species information unless the accessions table is present.
      When issuing the open command on the main table to convert the database to FMP 11, I get the message:
      "Accessions.fmp7" is damaged and cannot be opened.  Use the Recover command to recover this file. When using the Recover command from v. 11, I get another message:
      WARNING: problems were detected while recovering the database.  Please review the Recover.log file to see where problems were found and their severity.  The recovered file should NOT be used going forward; copy only the most recent work from it into a backup copy of the original file. Recovery results:   File blocks: scanned and rebuilt 563 blocks, dropped 214 invalid data blocks.   Schema: scanned fields and tables, 1 items modified   Structure: scanned; 1 items modified   Field indexes: rebuilt  
      Opening the recovered database, there are only three records present.  There should be hundreds.  So obviously I am looking on how to wrangle this database open.
      I've attached the log file here, as well as the database structure map.  
      The other files have converted just fine.  But since the main table won't open, we are kind of stuck.
      I can share the files with you through Dropbox or whatever, if needed.
      Please let me know any thoughts you have, either basic or advanced.  And ask for any clarifications or additional questions.   :-)  
      Thanks!
      -Tony
      Recover.log

    • By Tumma K
      Hello, All!

      I am an aspiring developer for Filemaker. The company I work with is stuck in the past working off of Filemaker Pro 4.1

      I was given the task of bringing us up to Filemaker Pro/Server 13. So far my conversion prototypes are successful but we recently had a layout issue that can only be fixed in versions 3-6 (as the file is an .fp3) I work off of a macbook while our network is all Windows 7. In order for me to repair the layouts without tampering our active database, I decided the best option is to repair a copy of our solutions off the network. Unfortunately, when I go to download the trial version of Filemaker Pro 6 off of the respected website, the file is corrupt! I've tried multiple times, with different extraction apps and in different directories.

      My question is;

      Does anyone know a place where I could obtain version 6 (or better yet, 4.0) for an OSX computer? I've looked everywhere!
       
      Thank you for your time,
      Tumma K.
    • By MrEddByrnes
      I'm hoping my question can have a happy ending. In the mid-90's, I purchased Filemaker 3. When Filemaker 5.5 Pro was released, I bought the update CD, which requires the user to either have FM 3 installed or to have the installation CD for FM 3. I've used it all these years, most recently with Windows XP Pro, and it has worked just fine. The databases I began with were long ago converted to FM Pro 5.5 databases.
       
      I'm still using FM Pro 5.5 on a laptop with WinXP Pro, but in 2013, I purchased a PC with Windows 8. I haven't been able to install FM 3 on it, therefore can't install FM Pro 5.5. I am retired and rarely use Filemaker, but I have a few Filemaker databases I'd like to add to my Win 8 machine. I don't feel it's worth upgrading FM for the sake of using a couple of databases.
       
      Has anyone else run into this situation and/or have a (possible) solution? Is there perhaps any other software that can read FM 5.5 databases? Thanks in advance for your help.
       
    • By bmill
      I am using a custom filemaker solution for medical office billing written with fp5 running on a mac with snow leopard. In addition, I have a patient management db (which I wrote) that is linked through pt. ID number to the billing program allowing transfer of some demographic information (name, DOB, etc).
       
      Other than being limited by hardware restrictions, the billing program serves our needs for now and upgrading to fp12 will take some time (and money).  In the meantime, I am upgrading my pt. management program to fp13 and would like to move new patient demographic information from the billing program ( fp5 running on snow leopard through Parallels) and the new pt management program ( fp13 running on OS X 10.9) on the same mac.   
       
      Ideally, demographic information would be entered once into fp5 and then a scipt would make the data available for fp13.
       
      Any ideas on how to make this work?
    • By randyinla
      Hi, can anyone tell me why my on-line database might have stopped allowing me to delete records?  All of my access privileges and passwords are correct.
       
      thanks!
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.