Jump to content
Sign in to follow this  
carlosnorvik

Eliminate obsolete products from drop down list

Recommended Posts

Hi everybody:

I have a product drop down list that shows all products for a certain supplier when making a new order.

The list changes according to the supplier of the products.

 

This is easily done by indicating who the supplier is in the products Table and making the appropriate relationship.

 

Now, I want to shorten the list by eliminating obsolete products (I need to keep history, so I can't simply delete the obsoletes from the products table)

The products table has a field which I can click when a product becomes obsolete.

 

My solution (it works, but I don't like it) is adding a field called obsolete in the purchase orders table, which is automatically set to "no" and I added a second relationship for the value list, so that if product is obsolete, it is no loger valid via the relationship.

 

Any ideas of a better way to do it?

 

Thanks

Carlos

Share this post


Link to post
Share on other sites

Hi Carlos,

 

One option:  In your Products table, create a calculation which inserts the ProductID only if the product is active and then use THAT ProductID in a new value list called Active Products.  The calculation should be indexed.

 

An example calculation in Products could be similar to:

 

If ( not IsObsolete ; ProductID )

 

... where IsObsolete is a number field with a 1.  Adjust as needed to fit your Obsolete field.

  • Like 2

Share this post


Link to post
Share on other sites

Hi LaRetta:

 

Sounds interesting, but if I understand correctly it would entail joining a calculated field, will it hamper performance?

 

Thanks

Carlos

Share this post


Link to post
Share on other sites

The calculation will be on the child side and it will be stored (do not set set it to unstored).  So yes, it has a small hit but no more than any other technique and less than most. 

Share this post


Link to post
Share on other sites

I suppose because I believe that everything has a cost, no matter how slight.  We work in nanoseconds and pts and the very minuscule and nothing is everything or absolute except uncertainty.   :smile:

 

But the hit would be the initial index, wouldn't it?  Thank you for affirming that it is very negligible.  I mean, nothing is for free, is it?   :laugh2:


Edited ... I should have said that the impact is less than anything else.  LOL.

Share this post


Link to post
Share on other sites

But the hit would be the initial index, wouldn't it?

 

Yes. So it does have a cost, but it has already been paid. And it has been paid by waiting at a time where waiting the extra millisecond has no practical significance.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By FMRadio
      Basic Question:
      I am attempting to import 60 records from a CSV file. There are 4 fields per record: First Name, Last Name, Email and Source. 
      When I choose Import Records... > File... from the File menu, everything looks good, 4 data points point to the correct field names: arrow icon "Import this field" but the rest are the double dots icon, "Don't import this field," and when I click on the Import button only the first record is imported.
      I don't use Filemaker frequently enough to remember everything but when I need it, I really need it. I do not remember having to go thru and changing every icon in the Import dialog to import this field, I thought that was automatic.
      I there something missing in the CSV file? I can reprocess that if required. Having to indicate to import for every record will be tedious.
      Thanks in advance for any help.
       
    • By ZoinksScoob
      I just upgraded my Mac OS to Mojave (10.14.4).  I am running FMP Advanced 11.0v4, and my databases are in FP7 format (due to a legacy system at work.)  I now have a repeatable "glitch" where if I perform a find in a database and there are no records that come up as results (i.e., no records match the find), regardless which choice I make next (Cancel or Modify Find), the app quits and I keep getting the window to send the issue to Apple. I can immediately re-open the database, though usually the last 2-3 changes I made weren't saved.  Other than the obvious option of upgrading the app, does anyone know of a workaround for this? Thanks in advanc.
    • By JH Howland
      Filemaker Pro 11 is running on two Windows 10 computers connected as Host and Client over a network.
      The script to import data from an Excel .csv file utilizes the following script step options:
          1. Un-Checked - Specify data source - File
          2. Check - Specify import order, Import Action
              a. Select - Update existing records in found set
              b. Check - Don't import first record (contains field names)
          3. Check - Perform without dialog
      When the Import script is run from the Host computer, and the desired .csv file is manually selected, the Excel first row field names are not imported and the second row with the data is imported as expected. (See Host Import Mapping)
      When the same script is run from the Client computer, the Excel first row field names are imported and not the second row data.  To get the proper result, I have to leave the check box for "Perform without dialog" unchecked and then manually, from the "Import Action" group, check the box for "Don't import first record (contains field names)" to get the proper data imported. (See Client Import Mapping, check box is no longer checked)
      Is this caused by a defect in FMP 11?  I can't figure out why this is happening.


    • By JH Howland
      After my Windows 10 based Filemaker Pro 11 MarinaPro Solution is launched (Path = C:/MarinaPro/Marina.fp7), I need to create a variable ($$source = filewin:/C:/MarinaPro/ResScheduler/) to a revised default "Open File" path.  Because I need to select from several reservation request attachment Excel .csv files, placed in the ResScheduler directory by an Outlook 2010 Macro, my "Import Records" script is set with an "unspecified" data source.
      When my script is activated with Error Capture "Off", I get the obligatory Filemaker Pro Error message, "The file <unknown> could not be found..." and the "Open File window is still set to "Look in: "MarinaPro" (Default).  And, of course with Error Capture "On" there is no Open File window presented.
      I have to manually select and import the first Excel.csv file before the default directory becomes "ResScheduler".
      I want my default "Open File" "Look in:" directory changed from "MarinaPro" to "ResScheduler" before I open the first Excel.csv file.
      Is there a way, nothing I have tried is working.
      Import.pdf
    • By transpower
      I've updated my computer from Windows 7 Pro to Windows 10 Pro.  My FileMaker Pro Advanced 11 does not launch.  I get the message "The application has failed to start because its side-by-side configuration is incorrect."  What's the solution for this issue?
      Update:  I clicked on an fp7 file, and then Windows asked me to insert the FileMaker CD, which I did.  Some files were quickly copied over, and everything works fine now!
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.