Richard Fincher

Filemaker Server 13 -> 14 upgrade, Java

3 posts in this topic

Hi all,

 

I recently upgraded my Filemaker Server 13 to Filemaker Server 14.

To get the new version to install, I had to downgrade my Java8 from u113 to u67 (separately installing the old Java version, not allowing the FMS installer to install Java itself).  I also had to fiddle around to make sure it was running the httpd which comes with FMS and not the one bundled with Mac OS X El Capitan.

My question is, am I now save to upgrade Java back to the latest version.  I'm not anticipating needing to install FMS14 anytime soon, but does the "Deployment" part of FMS use Java, and if so, is it similar fussy about which version?

Share this post


Link to post
Share on other sites

Updating java past the versions supported by each FMS updater has traditionally been a recipe for disaster.  I wouldn't do it.  Obviously it is not ideal from a security point but that can be mitigated by keeping the FMS box dedicated and isolated from the internet as much as possible.

Share this post


Link to post
Share on other sites

Posted (edited)

Thanks for this.  Its behind a ASA Firewall, the admin ports IP restricted (16000)

 

 

Edited by Richard Fincher

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By fileman922
      Hello
      we use filemaker server 15 and some macs takes long to upload an image in the container field, it takes about a minute to insert 100kb image.... when using filemaker server 14 it does not happend.... what could be the problem? 
    • By slywilcox
      So our IT group migrated a Filemaker 14 server with a business application that I support.  Since the migration, the system response has been horrible.  Screens that took about a second to render before are now taking 15 seconds.  I have monitored the server and the most significant statistic seems to be network latency.  Most of the other statistics seem fine, but latency has gone from 20-30 milliseconds to 800 milliseconds at times.  Does anyone have experience with the Scale HC3 architecture running Filemaker solutions?  What has your experience been? Are there words of wisdom to make this better?
    • By LelandLong
      I read that the new 3.01 version does not require Java.
      When I run FMPAv16 on my Mac (10.11.6) and use the sample Email database it works just fine and I see nothing related to Java. I had the older v2.12 plugin installed on here and have just updated to v3.01 today.
      When I run FMPAv16 on a different Mac (10.11.6) and install the v3.01 plugin (never had the plugin installed on this machine before today) and run the sample database a Java App runs without any windows, Just visible in the lower right dock and its single menu is titled "Java"
      Any ideas as to this oddity?
       
      Leland Long
    • By jaylkjr
      I have several customers that are still running Wondows Version 9, which is a version out of date. On attempting to load a 64 bit, ScriptMaster generated Plug-In, I am seeing a dialog that ScriptMaster can't run without Java 64 bit. On installing Java, there is no change and the same issue persists. This goes as far as literally crashing FileMaker. 
      Has anyone experienced this? Although it's really a Java issue, and the OS is out of date, I have two important customers running Windows 9.
    • By milanm
      Has anyone had the following issue and might have a quick fix. I migrated client files from FM Server 13 residing on Mac Server to FM Server 14 residing on Windows Server. All went very well except one thing, which i would be grateful if someone could help me on.   PREVIOUS STATE   - The client had his files hosted on OX platform and with FileMaker 13 Server. - There is a container field in the records that would contain pdf files, these are 1 or more pages document files. - When the user dragged the file into the container field it would display as page thumbnail BOTH on Mac and Windows.   AFTER THE MIGRATION TO WINDOWS SERVER   - files still display thumbnails when dragged on MAC - the files are displaying FILE ICON when dragged into the container on WINDOWS.   Tech boards are suggesting that Windows can not insert the file as picture into the FM container field, but there it happened before. Does anyone have any isight on this behaviour, is it documented anywhere? Thank you