Jump to content

Duplicate Record with script


This topic is 1796 days old. Please don't post here. Open a new topic instead.

Recommended Posts

  • Newbies

Hello all,

I want to start out by saying thank you to everyone that takes time to answer questions on this forum... I've learned a great deal from Forum questions and problems posted by others and have been answered by the great folks in this FM Forums community!

Cheers!

My Question - 

Current Script is an If statement that changes my Maintenance_Task::status from "SCHEDULED" to "SERVICE DUE" when conditions are met in the Hours Field. Also an optional Checkbox to be used when task is completed. See script below:

If (TASK COMPLETED = "TASK COMPLETED"; "COMPLETED"; If (Engineering Machinery::HOURS ≥ NEXT SERVICE; "SERVICE DUE"; "SCHEDULED"))

I would like to have the "SCHEDULED" task be duplicated, and the duplicates status field be changed to "SERVICE DUE". Leaving the original record unaltered, and the new duplicate record to eventually make its way to a "COMPLETED" task and logged as so for records.

Can anyone tell me if this is possible...  If so how can i incorporate it into my current script? 

Thank you for your time

Link to comment
Share on other sites

This topic is 1796 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • By J_rge
      I can see the process appear in the Task Manager and then disappear immediately. And there are no events or messages on FM Server Console that show failed authentication.
      I'm running Windows 10 2004. And the client version is 14.0.4.406_x64.
      Update: Under Event Viewer I can see LIBEAY32.dll is the faulting process.
      Update 2: I have updated the client to 14.0.6.602 and had the same results.
    • By totoleheros
      Hi,
      I am struggling : I have a script using 360Works_ScriptMaster.fmplugin functions. It used to run smoothly with FMP12 and 13. I had to update FMP and now the 360Works_ScriptMaster.fmplugin would not load. I have tried with both FMP14 and FMP15. The 360Works_ScriptMaster.fmplugin is not listed in the pref pane of FMP14/15, while — on the same machine (and the same java 8.121 version) — it is loaded. I have tried to have the file in these directories: /Application/ FMP FileMaker Pro 14 Advanced/Extensions or the ~/Library/Application Support/Filemaker/Filemaker Pro Advanced/14.0 (or 15.0)/Extensions.
      No success. Could someone have a clue about my problem? Many many thanks in advance.
    • By EdwinJ
      We have a script using the 360 Works plugin and it worked for a long time and know we get the message "No login methods supported!". The script is connecting to an exchange server with Imap.  In the script we already use  "forceTrust=True".
      Is there somebody who has the same problem ?
    • By cril
      Hi I'm trying to develop an interface between my filemaker database and a SOAP service. No where in the wsdl is there any authorisation so I believe I need to send my username and password before the SOAP envelope. I'm trying to do that with Scriptmaster but there are only three input parameters none of which appear useful for generating or inputting the HTTP authorisation Basic that needs to be in place. I can't see the fedex modules which may have had the parameters I needed. Can anybody help/advise or suggest another plugin I should use.
       
      Many thanks for reading this.
    • By dysong3
      Hello,
      Stange situation here.  After reinstalling FMS15 to resolve an issue, one of my FMPA clients on just one of my computers displays "connection failed" when trying connect to the available databases on the server when trying to connect with the local ip adresse.  All while several other computers have no problem doing the same.  The FMPA client that has the issue has no problem connect to available databases via an external ip address.  I have never seen this before and can't find any meaningful information on this by googling.  Would anyone have any idea what's going wrong here?  The error appears to be (51) on FMS.
  • Who Viewed the Topic

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.