Jump to content
mjames16

Nesting Unique field autofill values within if () and case()

Recommended Posts

Hi guys, 

Im trying to autofill a field depending on the value of other fields -- Ideally this field would be autofilled with some text immediately followed by a numeric value that increases by 1 for each new record. I currently have this:

If ( Case1 = "A" ; (Case(Type = "Protein" ; "test1xxx"; Type = "Antibody"; "test2xxx"; Type = "DNA"; "test3xxx")))

I would like to replace the "xxx" components with "000" through "999". I was hoping someone would have some insight on this. Any help would be appreciated. 

Thank you! 

Share this post


Link to post
Share on other sites

Create a field and set it to be an auto-entered serial number. Then each part of your calc would like like:

"test1" & theField

Or, like this:

If ( Case1 = "A" ; Case( Type = "Protein" ; "test1"; Type = "Antibody"; "test2"; Type = "DNA"; "test3") & theField )

... but that may not be a good fit if there can be other test types.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Fidalguito
      Hello!
      Our company has about 2,000 employees and we intend that each one has a unique access to the Filemaker platform.
      Does anyone know how to do this en masse, ie without creating an account one by one?
      Thanks for the help.
    • By St3v1e
      Hi everyone,
      Absolutely new user to FMPA 18.
      I managed to cobble a small database together using FMPA 18 on my 2018 iMac (Catalina 10.15.3), and want to share it over a local network with my laptop. I'd like to have the laptop log in via a user account (Data Entry only). I created a user account in the "Manage Security" section, and have made sure the user account has Data Entry only privilege & "write access to all records" is enabled under the advanced tab. I also checked that "fmreauthenticate10" & "fmapp" are checked (Advanced tab).
      My firewall is off, and I've allowed File Sharing in the prefs of my iMac - pointing directly to the Filemaker Pro 18 Advanced folder located in my applications.
      I installed FilemakerGo on my iPad, and can access the file in the Hosts area, but I'm not logging in via the user account I setup (no idea how to do that). But when I tried to connect to the host on my laptop (File/Hosts/Show Hosts), it's not finding the host. I've tried manually adding the host address (192.168.xx.xxx) & also pinged my iMac from the laptop (MacBook pro - 2016 model - running 10.14.6 Mojave)I don't see anything when I add the iMac's IP manually, but do get a response from the ping.
      Why does it work on the iPad (iOS 13.1.2), but not on the MacBook?
      What am I doing wrong & how do I log into either using the user account I set up on the host machine?
      Thanks in advance
       
    • By St3v1e
      Hi,
      As a complete novice to FMP, I'm attempting my very first database. We rely on storing our contracts on Google & Dropbox. I've been trying to either embed the pdf's into a "tab", or (my preferred option) to have an "Add URL" button to link to the online pdf.
      I tried adding a field and copying and pasting the URL, but it's not clickable, and I'd need to add another field for each pdf/contract.
      Is there a better more efficient way to do this?
      Thanks
      Steve
    • By johnmarcel
      I have setup a layer with web viewer. I can maneuver within the website just fine but, I would like it if when the website loads it would send 4 carriage returns to get to a specific field within the website.
      If anyone has any ideas on how I can accomplish this it would be greatly appreciated.
       
      Thank You
      John
    • By john renfrew
      Have copied a shell script which works in other settings onto a new machine
      Changes paths - it zips a backup folder and does a ditto command to copy as a zip file to an external drive
      I worked out that I needed to change the sudoers file to allow no password access to the script. Running the shell script in terminal was requiring a password, now it doesn't 
      Added the fmserver user to that too.
       
      If I run the sh script from the admin console as fmserver it fails straight away, if I run it as the local user with its password it appears to run but in fact times out with a fail message, both of which are about invalid account name or password
       
      The script is working fine when run through terminal, doe not require password, just not when triggered from console.
      Does anyone have any light to shine on this???
  • Who Viewed the Topic

    4 members have viewed this topic:
    Ron Cates  Ismail AlAbdulmohsen  comment  Fitch 
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.