Jump to content

PDF not showing in container field


Recommended Posts

I have a PDF that I cannot view in a container field. Interactive Content is checked. I assume the PDF file is valid because if I'm in Layout Mode with Sample Data on, the image shows in the container field. But, once I go to Browse mode, it doesn't show. If I view container attributes in the data viewer, it appears everything is as it should be. Any thoughts?

 

Thanks,

whardy

Link to post
Share on other sites

I found that article before I posted and tried it. It didn't make any difference, unfortunately. I have scoured the internet for articles dealing with this and simply cannot find a solution.

It seems that it has to be a valid file, as the Show Sample Data displays it fine. I've also tried combination of Insert PDF and Insert File. I've also tried adding the "Image" prefix in Insert File, but to now avail. 

Any other ideas?

Link to post
Share on other sites

Is this a specific PDF file you are having a problem with or does the container field behave the same way with any PDF? If the former, can we see the PDF? If the latter, can we see your file?

 

Edited by comment
Link to post
Share on other sites

Yes, it is all PDFs. I will upload the barebones files I'm working with that displays that behavior. If you click on Preview in Form view, you can see documents. Just not in regular Browse mode.

PDF_Test.fmp12

Link to post
Share on other sites

When I try to open your file, Filemaker performs a recovery due to "improperly closed file". After that the PDFs are displayed as expected - except  for the last one which appears to have been inserted as a file.

image.thumb.png.8a853a3ea2f4246f9fbcebddcf336a08.png

In a cross-post to another forum you describe crashes and error messages which you did not mention here. Which leads me to suspect you have the same problem as the one discussed here:
https://app.works/why-cant-i-view-pdfs/

and in more length here:
https://community.claris.com/en/s/question/0D50H00006ezL3fSAE/pdf-files-in-container-fields-are-not-displaying#comment-689689

---
For indexing: Adobe plugins

Edited by comment
  • Like 1
Link to post
Share on other sites

Comment,

Thanks so much! The Adobe plugins were the issue. The crash and Adobe part were late-developing. You are a genius! I scoured those forums and never came across those posts.

whardy

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • By elipsett
      I'm running FMP 17 Adv on Catalina.

      I have a folder containing the FileMaker file and a large number of PDFs. 
      A script determines if there is a PDF for a particular client, and either sends an email with the PDF attached to that client, or prints out the email body and the PDF.
      The PDF has a known filename, and can be input as an external file or via a container. The filename is available as a $$ variable; the path is the same as the Filemaker file itself.
      The email part works fine.
      The problem is in printing. The script prints out the body of the email perfectly, but I cannot get it to automatically print out the PDF.
      I have Acrobat and Acrobat Reader both installed, although Preview should work as well since they are all PDFs.

      Can anyone give me simple code to print $$Filename located at (same path as Filemaker file, or $$FilePath), specifically for a PDF file?

      Suggestions welcome, but keep in mind that I am not very skilled at Filemaker, and know nothing about AppleScript.
       
      Thanks for your time. 
    • By ChangeAgent
      FileMaker Pro 16.0.6.600
      On a Mac 
      I am having a container field where I store PDF files. 
      Every time I start the DB and I get to a file in the DB with a PDF in it, I get a box asking me: adobe pdf viewer can not find a compatible… etc.
       Now if I select Adobe Acrobat Reader DC it now runs fine, however it will ask me again the next time I open the DB.  Boring indeed.  Any solution to that?
       My first choice would be to use Preview, I did select it when the box appeared but this does not work.  Any solutions to that?
       If it needs to be Adobe Acrobat Reader DC, where can I set the preferences so it does not ask me all the time?  
       Adobe Acrobat Reader DC seems also pretty buggy, crashing at time and not allowing to scroll the PDF and a few more bugs.
      Any solutions anybody knows of?
    • By Gary Hoffman
      My solution for grad student to upload information about their summer internship, including a PDF file from their employer, is not working well this year.
      Last year, we were on FilemakerServer 13 and I built the student-facing layouts for WebDirect. The staff side of the database was accessed through FilemakerPro 13.
      The container field does not store its data externally, but rather internally to the db file.
      This year, we've upgraded to FMS 14, FMP 14, and, of course, the world has gotten wary of PDF files.
      So, our grad students' uploaded PDFs no longer render in the layout where I've placed the container field. If the field is set to optimize for Images, I see a PDF icon and the file name. However, if I change it to optimize for Interactive content (PDF, MP3, etc.), I get an error message that resolves to this: You do not have permission to view this directory or page.
      According to FM documentation, interactive content is rendered by the default browser on the platform, i.e. I.E. on Windows and Safari on Mac.
      This seems to be new behavior. Does anyone else see this?
      Gary
       

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.