Jump to content

Help with script please


Recommended Posts

Hello hope all is keeping well?

Please I need help with this script what I have been trying to do for the last week is to put a saved PDF into a container field after its been created?

I have tried to insert into a container field with the field be interactive and not Interactive but with no joy.

The script attached is where I have been trying to place the script where the red line are?

So after its saved to the desktop import into a container field so we have a copy of the PDF

I hope someone would be so kind to help me

 

Thank You519870981_Screenshot2020-10-05at16_15_20.thumb.png.916d32e74f5b1fc86a6ed12358be13ea.png

Link to post
Share on other sites

Hello comment thank you for the link 

I have tried all the ways listed in the link and all I'm getting is the error 102 field is missing I have tried using another field but still getting the errors I looked up the error code and other recommendations is that pull it off the panel out of the live field but again still getting an error

 

Any Thoughts ????

Link to post
Share on other sites

Well, which field, in which table, are you trying to insert the PDF into? And is it on the current layout?

Your script shows you are in a layout of Job_Samples, showing only related records starting from some parent table. I would have thought that the container field would be defined in this parent table, and therefore accessible from the current context. But apparently you're doing something else.

 

Edited by comment
Link to post
Share on other sites

Ok here goes lol I will do my best to explain?

I am in layout: Job_Details with the Table: Job the Job_Samples is another Table called SAM_Samples which when I done the relationship I called it Job_Samples so you have connected Job_Details to Job_Samples

In the layout Job_Samples I have a container field called pdf and that's where the saved pdf should be Imported.

I have also put a container field in a layout called SAM_Samples and changed the script to input the saved pdf in that one but I'm still getting a error.

I hope this helps.

 

Link to post
Share on other sites

I am afraid I couldn't understand any of it.

I believe you are getting the error because the target field is not on the current layout - i.e. the layout you're on when you call the Insert File script step.

--
Note that there is  a way to insert a file into a container field even if the field is not on the current layout. But I think you should solve the current problem first.

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • By fousthvk
      Does anyone know how to do this? calling the "generate as configured" script stacks the script that gets called after the webveiwer is set at the end of the primary script, there for only the last record in the found set of the loops actually has the image file created and saved to the container field.
    • By bgscott
      Recently converted a FM application from V6 to V19.  The application will run on FM server.  Very new to FM19
      Questions related to temporary path
      I have scripts that exports data to 3 temporary fm12 files.  Two of the temp files hold data that is them imported to other files and one of the temp files holds data for a lookup in another file.
      dhistory imports data from dtemp
      rhistory imports data from rtemp
      vendors looks up data from vtemp
      The temp files are fm12 files
      Questions
      1.  I would like to have the temp files sent to the temporary path on the users computer.  I have not been able to correctly specify the output path to send the temporary files to the temporary folder on the users computer.  This is one attempt: get(temporarypath) & dtemp but this does not sentd the file to the temporary folder
      2.  Once I get the correct syntax to save the temporary files in the temporary folder, how do I tell the import records script step where to find the temporary files?  What is the correct way to point to the file so it would work on any users computer?
      3.  Vendors file performs a relookup in vtemp, so I need a relationship between vtemp table, located in temporary folder, and vendor table.  How do I specify the location of vtemp so it can be found on any users computer?
      Once the script finish running the temporary files are no longer needed and it is my understanding that the temporary files will be deleted when the Filemaker session is closed.
    • By milky
      Hi All,
      Just had a look at the new Add-ons in Fm19.
      Is there a way to make the timer work in reverse.
      i.e. Start from a field (Timer::TimeLength) that a user can input, so that the specified time of say 30:00 will run down to 0:00
      Any help would be appreciated.
      Regards
       
      Milton.
    • By BostonFM
      I am trying to script an import of three worksheets in the same Excel file. The 3 geographical regions worksheets are not structured the same, i.e. field name rows are not in the same place and are named differently.
      The script runs but stops to ask which worksheet to process.
      How do I create a variable/parameter in the script for it to proceed sequentially from worksheet 1-3 without stopping?
      Thanks
      DA
    • By SupportGuys89
      Hello Fellow FM'ers!
      We have been testing Linux and everything has been great, but we are having issues with the authentication via web direct using Windows Federated Services. We followed the steps in the available documentation "Addendum4_ADFS.pdf" and also used "ExtendOAuth_v1.pdf" to get the AD-FS rules configured as well as the necessary admin console requirements (Client Key, Shared Key etc...) We do see the following on attempting to login to our solution:

       
      And when we click on the AD FS Option we do receive a login prompt from our Federated Services:
       

       
      However, even with the correct credentials we still see the following error message:

       
      We have reviewed the logs within AD-FS and no errors are reported and the credentials are passed as expected. Within our solution and Active Directory, we also ensured the user is in the correct group to access our solution via webdirect. I will gladly provide more details into the configuration of AD-FS or FM Admin Console, but these all match the documentation provided by Claris. 
      We went a bit further and got an inhouse developer to take a look and test the flow and he was able to confirm the following:
      Our Endpoints are setup correctly and can be viewed internally @"https://INTERNALADFS/adfs/.well-known/openid-configuration" Initial request  was tested with "https://oidcdebugger.com/"  Postman was then used to test once we received a response. Decoding the jwt received with "https://jwt.ms/"
        The JWT had a unique_name, an email, and a groups array with one of the values in that group array being the group that is set up in the Filemaker solution.   With that said, we are not sure what the next step would be to test this as we appear to be seeing all the correct information in our testing yet we still are not being "authenticated" in our solution. I have also opened a ticket with FIleMaker and no luck as of yet. Any insight would be greatly appreciated!  
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.