Jump to content

FMPro 18 runs into "object not found" error on MBpro M1


Recommended Posts

Hello, I have a database that I run on 3 different computers, all with Mac OS 11.2. FMpro is 18.0.3.317.

A script uses an AppleScript that opens a browser. The AppleScript invokes System Events and contains a "do shell script" step.

On all computers, FMPro, Script Editor Script Menu are "allowed to control computer" in System Prefs.

In the other 2 computes, with the Intel chips, the script runs flawlessly but it stumbles on the M1. M1 vs Intel is the only difference between there 3 setups. I know that v18 is not officially supported with Big Sur but the programs runs perfectly well. Any suggestions would be appreciated.

Link to post
Share on other sites

I would install FMP 19 on the machine (it can coexist with 18), and see if everything works ok on 19. If that’s the case, you’re really left with no other option other than to upgrade. If the problem exists in 19, too, it could be some strange issue with Applescript. 

Link to post
Share on other sites

Thanks, I started to think that I should have run the AS separately on the M1 and I posted the question prematurely. The problem is that all data in the AS comes form FM. I still think that FM is unable to trigger something AS-related. 

Link to post
Share on other sites

That’s a good point. When I do AppleScripting, I first code it separately, since debugging AS in FM is a pain. I then copy and paste into FM, and do the necessary editing to suck in the FM data. 

Link to post
Share on other sites
17 minutes ago, Asu said:

The problem is that all data in the AS comes form FM.

That shouldn't prevent you from testing the script in Script Editor using arbitrary fake data. In parallel, you could experiment with running a simple AppleScript from FMP and seeing at what point if fails.

Of course, this is all rather generic, since we don't know exactly what your script does or how it fails (surely there is an error message?).

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • By Asu
      Hello, I hope this is a simple question: Is there a reverse of the "Quote()" function, that would turn a calculated AppleScript in FM back to a straight AppleScript? I have a very complex  calculated AppleScript that I need to retest. Thanks.
    • By Asu
      Hello, the following is the essence of a problem I need to resolve. The code is AppleScript 
      display dialog "Hello \"world\" "  This code needs to run in FMP18 as a calculated applescript.

      I tried:
      Perform AppleScript [display dialog \"Hello "world" \"] 
      Perform AppleScript [display dialog \"Hello \""world"\" \"]
      Perform AppleScript [display dialog \"Hello "\"world"\" \"]
      Perform AppleScript [display dialog \"Hello \""world\"" \"]
      and other permutations of 1 backslash and 2 quotation marks cause the calculation to be unsavable b/o error.
      Perform AppleScript [display dialog \"Hello \"world\" \"] results in "A identifier can’t go after this “"”." -- after the calculation is saved. (Yes, "A identifier")
      Perform AppleScript [display dialog \"Hello \"\"world\"\" \"] results in A “"” can’t go after this “"”. -- after the calculation is saved
      and an error message of -2740.
      Can anyone help me please?
       

    • By wedgeman
      We are working on a process for passing certain info nuggets out of a solution (FMP 13) in an encrypted method.
      For various reasons a version upgrade isn't feasible. So the plan is to encrypt the nuggets, then pass them into a format for transport.
      Currently, we're using Applescript to pass the particular fields into an AES-256-CBC encryption process in a calculated Applescript step, as follows :
       
       
      The problems which concern me here:
      1. The password is "traveling" into Terminal in plaintext.   Is there a way this can be viewed during the process (a 'ps' or some other method)??
      2. Is there a better method to accomplish this without running as an echo?
       
      I've tried various flavors of this process (successful encryption & transport, etc), but am most concerned about the potential vulnerability from within OSX.. I've run various flavors, then attempted to grep for any of the password strings in log files and Library/Application Support/ folders, but haven't found anything...
      Is this an unfounded issue, or should I be going a different direction?
    • By fed
      I just upgraded to FMP16 from FMP13.  My applescripts no longer work.  I get an error of -10004, for which I cannot find an explanation.
      Any idea what I must change to make Applescripts work in FMP16?
    • By typewriter
      Is it possible to use AppleScript to open the Script Workplace, select a particular script and even scroll to a particular line?
      I looked through several AppleScript sources (there are not so many...) as well as the Dictionary of FIleMaker Pro Advanced 15, but all examples seem to deal with using the database (i.e. finding and manipulating records), not authoring.
      Why would be handy? I have an authoring database where I can store the scripts and scriptsteps of a solution. These are converted from FIlemaker XML using the MBS plugin, not that complicated. Then it's possible to select the scriptsteps that need attention. But locating these scripts in the original solution is quite time consuming, so an AppleScript would save me tons of time.
       
       
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.