Jump to content

Constrain found set supports what version?


This topic is 6444 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I have a problem with the constrain found set script step. Basically, it worked for my client, and then they 'upgraded' (still need to know the version) and now the constrain found set is no longer an option in the perform find script step.

This has broken an important functionality of my database that performed finds against chained criteria between two databases.

Can anyone tell me when constrained found set is not available? There does not appear anyway for me to replicate the functionality without the step.

It was developed using both FileMaker 6 for Windows and FileMaker 5.5 for Mac OS 9

The client is using FileMaker ?? (update to follow) and Mac OS X

Link to comment
Share on other sites

Constrain Found Set can pretty much be simulated using the Modify Last Find script step in any version of FMP.

Modify Last Find

< add the constraining criteria >

Perform Find []

It will fail if there was no last find, or if the last find was cleared by entering Find mode and not performing a find.

Link to comment
Share on other sites

Thank you Vaughan.

FMForums was giving me MySqll connect errors when I was editing my post last night, and my edit was lost.

It's no problem. I have it all worked out, it's just not so nice as before.

I have global fields with value-lists that present an easy to use interface for my client. Instead of constraining the found set by a series of scripts, I just go:

Go to Layout ("Find")

Enter Find Mode ("Restore")

#The find fields are calculation fields that compare the global values in the client's search interface to the criteria

If ("not IsEmpty(GlobalField1)")

Set Field("IsField1", "1")

End If

If ("not IsEmpty(GlobalField2)")

Set Field("IsField2", "1")

End If

#etc...

Go to Layout ("Presentation")

So, if their is a match the boolean 1 will find it. smile.gif

The only blah about it is that the client must press the "find" button every time, whereas before the script was behind the scenes.

Link to comment
Share on other sites

This topic is 6444 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.