Jump to content

Excel Import Issue with Join Tables, Portal, Pop-up Fields


sgtpeppas
 Share

This topic is 2624 days old. Please don't post here. Open a new topic instead.

Recommended Posts

  • Newbies

Greetings! Thanks ahead of time for any guidance

 

I have a library of musical cues. Each cue can be assigned up to 4 genre/subgenres. I have a Cue Entry Layout for the user to enter this and other data for each cue. It is based on the Cue Entry Table. I have 2 separate tables for Genre and Subgenre. I am pulling the Genre and Subgenre data through a portal into the Cue Entry Layout via a join table called cues_CATALOG. That data is populating 2 pop-up menus on Cue Entry. Here is the relationship graph:

 

post-111222-0-38029200-1401297228_thumb.

 

 

I am importing data from an excel. First I import Title and Cue ID (using auto-enter during import for Cue ID) into the Cue Entry Table so that I have the bare-bones record there ready to be matched with the data to come. Second would be the CATALOG data. I am importing this into the join table cues_CATALOG. Here is the excel sheet as I am importing it:

 

post-111222-0-03985500-1401297253_thumb.

 

Import mapping is as follows:

 

Cue ID matched to _CueIDfk

Genre imported to _GenreIDfk

Subgenre imported to _SubgenreIDfk

 

On the surface it appears as though the import is successful:

 

post-111222-0-75984900-1401297280_thumb.

 

 

This is from the layout Cue Entry. These are portal rows from cues_CATALOG with the fields _GenreIDfk and _SubgenreIDfk. These two fields are Pop-up menus being populated by a value list with values from the related primary key fields __GenreIDpk and __SubgenreIDpk from their respective tables cues_catalog_GENRES and cues_catalog_SUBGENRES but displaying the secondary fields Genres and Subgenres.

 

When I click on the pop-up I see that there is no check mark next to "JAZZY":

 

post-111222-0-38813400-1401297302_thumb.

 

 

 

Curious. Additionally the Subgenre pop-up which is dependent upon the Genre pop-up seems to display the imported value but when you click on it you get this:

 

 

post-111222-0-65095700-1401297327_thumb.

 

 

I suppose that's obvious behavior if there isn't actually a value being defined in the Genre pop-up. Question is why isn't there? I certainly imported data into that field. As you can see (or :) not?) from the table view of cues_CATALOG it certainly appears as though data is there. Is this about needing to use primary keys instead of values during import? Or is this a text vs number field issue with the foreign key fields?

 

post-111222-0-03547000-1401297369_thumb.

 

To sum it up I can't figure out why the data I'm importing into the join table cues_CATALOG does not appear to actually be written into the pop-up fields even though it's displaying properly. As you can see this presents all sorts of problems because my whole scheme is based on the logic that this would perform correctly.

 

Someone please preach the gospel of filemaker to me...

 

Kind Regards!

Link to comment
Share on other sites

This topic is 2624 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • By Sinky
      Hi!
      I have a calculation field in a portal which shows the value according to ActivePortalRowNumber. Each row has a special determined value.
      When I manually enter the value in the field before the calculation field and thereby make a particular row active, my calculation field automatically shows the designated value. Great!
      But, if when I do the import from Excel, all data gets nicely imported and the portal shows the imported data but the calculation field is without value. I guess the importing process is not making a portal rows active so the calculation is not working.
      Any ideas how this can be solved?
      Many thanks!
    • By Oyseka
      Hi All. I have a database that is currently sitting on 760MB with 425K records and from the trend it will grow at about 200K records a year now. as it is primarily used on mobile devices I think that this growth will lead to local processing problems. I am looking for a way to "hive off" any records older than say 18 months in the distributed version of the database while keeping all records in an "archive" version and then be able to add new and modified records monthly to the "archive" and removing the oldest month from the distributed version. There are 27 tables involved. Any pointers for achieving this would be appreciated *
    • By SebLetarte
      Hello,
      We have a solution to store pictures(JPEG and NEF) from a photographer. I am trying to mass import the raw files(.NEF) into containers but I have an error message saying 'This file could not be translated using the selected file type'.
      It is possible to drag and drop or File->Insert the file into the container directly but I can't import them from the folder.
      Is this impossible to import files from folder with extensions other than the basic ones? (jpeg, pdf, jpg, png etc)
      Thanks!
    • By fm8443
      I have a script to import an Excel file into an FM Table.
      I have my FM Script setup to Import Records with Arrange by: LAST ORDER.
      But it won't do this.  Every time I run this script it gets the field mappings wrong.  Reverts them back to before.
      Ironically when I do it manually it works.
      Any ideas?  (I have this type of scripted import working fine for other tables)
      (I tried shifting the order of the fields in the actual database table as well -- but that has no effect either.)
    • By fm8443
      I am trying to open my (local) FM 14 Pro file [which has an auto-exec "Import Script"] but the script needs a variable file name.
      How do I pass this variable file name into Filemaker at 1) the time of the file open or 2) at the time of running the script (if I switch to manual execution)?
      Is #1 by using the fmp:// syntax from a web browser external to FM?  (or is that syntax just for use when invoked from INSIDE a FM file?)
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.